Closed Bug 1551802 Opened 2 years ago Closed 2 years ago

New mail notification contains already notified emails

Categories

(Thunderbird :: General, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 375717

People

(Reporter: xracoonx, Unassigned)

Details

(Whiteboard: [dupeme])

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Steps to reproduce:

Receive new email after receiving other emails that were still unseen.

Actual results:

The new mail notification showed the unseen emails as well

Expected results:

The new mail notification shows only the new mails

(Or, if this is a feature rather than a bug, e.g. for reminding people of unseen emails, the new email should at least be on top of the notification list, i.e. they should be sorted by "order received". Otherwise the new email is not even be visible in the notification due to the limited size of the notification box if there are a couple of unseen emails.)

Well, notifications are less then optimal, in TB 68 they sometimes come up blank, bug 1547202. I don't think we will address this bug any time soon.

Whiteboard: [dupeme]

(In reply to Jorg K (GMT+2) (reduced availability 14-19 of Sept.) from comment #1)

Well, notifications are less then optimal, in TB 68 they sometimes come up blank, bug 1547202. I don't think we will address this bug any time soon.

They are actually quite useless for me because I always have many unseen emails automatically filtered into folders for reading them much later if at all and hence I almost never see what message I got recently.

Use the Activity Manager. There's also a nice add-on for notifications on specific folders: Mailbox Alert.

BTW, the blank notifications in bug 1547202 were fixed, so we're back to the state you reported in comment #0 that "unseen" messages get reported again.

Type: defect → enhancement
Component: Untriaged → General

(In reply to Jorg K (GMT+2) (reduced availability 14-19 of Sept.) from comment #3)

Use the Activity Manager. There's also a nice add-on for notifications on specific folders: Mailbox Alert.

BTW, the blank notifications in bug 1547202 were fixed, so we're back to the state you reported in comment #0 that "unseen" messages get reported again.

This is just to highlight that changing the order of emails shown to by date would be very useful and I guess easy to implement?

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 375717
You need to log in before you can comment on or make changes to this bug.