Closed Bug 1551833 Opened 6 months ago Closed 3 months ago

Selecting a search result from global search doesn't work with arrow down, only mouse

Categories

(Thunderbird :: Search, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1490428

People

(Reporter: jorohr, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:66.0) Gecko/20100101 Firefox/66.0

Steps to reproduce:

Started a global search query and then as soon as thunderbird shows suggestions (e-mail addresses that match the string I have typed into), navigate down to one suggestion (a matching e-mail address

Actual results:

Instead of searching for messages related to the selected mail address (xyx@xyx.abc), Thunderbird reproducibly only searches for the string I have typed into the search field. This behaviour occurs only when I use the keyboard to navigate down to the suggestion, not when I use the mouse. However, since I use the keyboard to type in the search string, the natural work flow is that next I use the keyboard to go to the suggestion that I want to select.

Expected results:

Just the same as when using the mouse to select a suggestion: Thunderbird should perform a global search over it.

We're talking about the Ctrl+K search here, the global one. In TB 60 and TB 68 navigating the popup of search suggestions works fine for me.

Maybe some add-on interferes? Try with all add-ons disabled, see Help menu.

Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1490428
You need to log in before you can comment on or make changes to this bug.