Closed Bug 1551870 Opened 6 months ago Closed 5 months ago

Filter URLs field becomes empty after switching back from different developer tools/panels

Categories

(DevTools :: Netmonitor, defect, P2)

68 Branch
defect

Tracking

(firefox-esr60 unaffected, firefox67 unaffected, firefox67.0.1 unaffected, firefox68 fixed, firefox69 verified)

VERIFIED FIXED
Firefox 69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox67.0.1 --- unaffected
firefox68 --- fixed
firefox69 --- verified

People

(Reporter: ashu, Assigned: ntim)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

  • Go to any website
  • Open Network monitoring tool
  • Put any string in URL filter field
  • Switch to a different panel/tool and switch back to Network tool

(see the attached screencast)

Actual results:

Filter URLs field becomes empty

Expected results:

Earlier string should still be present

Component: Untriaged → Netmonitor
Product: Firefox → DevTools

The priority flag is not set for this bug.
:Honza, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(odvarko)

Thanks for the report!

I can confirm this bug is easily reproducible on my machine.

Honza

Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(odvarko)
Priority: -- → P3
Summary: [Network Panel] Filter URLs field becomes empty after switching back from different developer tools/panels → Filter URLs field becomes empty after switching back from different developer tools/panels

Some pointers:

  1. The filter box is rendered here:
    https://searchfox.org/mozilla-central/rev/7556a400affa9eb99e522d2d17c40689fa23a729/devtools/client/netmonitor/src/components/Toolbar.js#366
  2. setRequestFilterText prop (a function) is passed to onChange. This function is firing setRequestFilterText action (see the connect method at the bottom of the file)

The place above looks like good start to investigate.

Honza

This seems to be a regression, I can see that it works in the current release (67)
Honza

Priority: P3 → P2

(In reply to Jan Honza Odvarko [:Honza] (always need-info? me) from comment #4)

This seems to be a regression, I can see that it works in the current release (67)
Honza

yeah, it is working on 68.0b5 as well.

I tried to do a regression range on Windows 10 x64 but I received this INFO: There are no build artifacts on inbound for these changesets (they are probably too old).

Here are the results:
No more inbound revisions, bisection finished.
Last good revision: 2f94885dcf94f823f37c99231c79146b6b907e4c
First bad revision: 4440662cd0177f3fc3200cff190daed47d71a167
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2f94885dcf94f823f37c99231c79146b6b907e4c&tochange=4440662cd0177f3fc3200cff190daed47d71a167

Thanks!

@Tim: it looks like this bug 1223368 caused the regression.

Could you please look at that?
Honza

Flags: needinfo?(ntim.bugs)
Flags: needinfo?(ntim.bugs)
Attachment #9069614 - Attachment description: Bug 1551870 - Reintroduce netmonitor-toolbar-container so React doesn't re-render the toolbar when switching panels. r=Honza → Bug 1551870 - Reintroduce netmonitor-toolbar-container in single-toolbar mode so React doesn't re-render the toolbar when switching panels. r=Honza
Assignee: nobody → ntim.bugs
Status: NEW → ASSIGNED
Pushed by jodvarko@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/37918f3c49df
Reintroduce netmonitor-toolbar-container in single-toolbar mode so React doesn't re-render the toolbar when switching panels. r=Honza

NI Jan as Tim is not accepting NI atm.

Backed out changeset 37918f3c49df (bug 1551870) for eslint failure at browser_net_filter-value-preserved.js on a CLOSED TREE.

Backout link: https://hg.mozilla.org/integration/autoland/rev/76f821a99146f3d472886701d0782cc4506c2507

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&resultStatus=testfailed%2Cbusted%2Cexception&revision=37918f3c49dfa66c3fb8c5a12ee3e11a9e35d088&selectedJob=249925497

Log link: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=249925497&repo=autoland&lineNumber=225

Log snippet:

[task 2019-06-04T13:01:09.794Z] copying build/lib.linux-x86_64-2.7/psutil/_psutil_posix.so -> psutil
[task 2019-06-04T13:01:09.794Z]
[task 2019-06-04T13:01:09.794Z] Error processing command. Ignoring because optional. (optional:packages.txt:comm/build/virtualenv_packages.txt)
[task 2019-06-04T13:09:07.342Z] TEST-UNEXPECTED-ERROR | /builds/worker/checkouts/gecko/devtools/client/netmonitor/test/browser_net_filter-value-preserved.js:19:7 | 'toolbars' is never reassigned. Use 'const' instead. (prefer-const)
[taskcluster 2019-06-04 13:09:07.711Z] === Task Finished ===
[taskcluster 2019-06-04 13:09:08.524Z] Unsuccessful task run with exit code: 1 completed in 752.536 seconds

Flags: needinfo?(odvarko)
Flags: needinfo?(odvarko)
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/e6dd869ef484
Reintroduce netmonitor-toolbar-container in single-toolbar mode so React doesn't re-render the toolbar when switching panels. r=Honza
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69
Status: RESOLVED → VERIFIED

Comment on attachment 9069614 [details]
Bug 1551870 - Reintroduce netmonitor-toolbar-container in single-toolbar mode so React doesn't re-render the toolbar when switching panels. r=Honza

Beta/Release Uplift Approval Request

  • User impact if declined: Functional regression in netmonitor that can be annoying for developers
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Trivial JS fix with test
  • String changes made/needed: None
Attachment #9069614 - Flags: approval-mozilla-beta?

Comment 5 says beta68 isn't affected. Which is it? :)

(In reply to Julien Cristau [:jcristau] from comment #14)

Comment 5 says beta68 isn't affected. Which is it? :)

I can definitely reproduce on 68b7. Ashutosh, could you please re-check if you can reproduce on v68 ? Thanks!

Flags: needinfo?(ashu)

Yeah, I can reproduce it on Firefox 68.0b7

Flags: needinfo?(ashu)

Comment on attachment 9069614 [details]
Bug 1551870 - Reintroduce netmonitor-toolbar-container in single-toolbar mode so React doesn't re-render the toolbar when switching panels. r=Honza

devtools fix. this should be in 68.0b9.

Attachment #9069614 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.