Closed Bug 1551871 Opened 8 months ago Closed 8 months ago

Intermittent devtools/client/debugger/test/mochitest/browser_dbg-sourcemapped-preview.js | Uncaught exception - failed to preview

Categories

(DevTools :: Debugger, defect, P1)

defect

Tracking

(firefox-esr60 unaffected, firefox67 unaffected, firefox68 fixed, firefox69 fixed)

RESOLVED FIXED
Firefox 69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox68 --- fixed
firefox69 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: jlast)

References

Details

(Keywords: intermittent-failure, regression, Whiteboard: [stockwell fixed])

Attachments

(2 files)

Filed by: rgurzau [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=246565859&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/T-ArOBcKQnaXHHQHaPfHPQ/runs/0/artifacts/public/logs/live_backing.log


11:58:20 INFO - TEST-PASS | devtools/client/debugger/test/mochitest/browser_dbg-sourcemapped-preview.js | expression is highlighted as paused -
11:58:20 INFO - TEST-PASS | devtools/client/debugger/test/mochitest/browser_dbg-sourcemapped-preview.js | gutter is visible -
11:58:20 INFO - TEST-PASS | devtools/client/debugger/test/mochitest/browser_dbg-sourcemapped-preview.js | Breakpoint reverted -
11:58:20 INFO - Buffered messages logged at 11:58:14
11:58:20 INFO - Hovering at 2, 8
11:58:20 INFO - Buffered messages logged at 11:58:16
11:58:20 INFO - Hovering at 2, 8
11:58:20 INFO - Buffered messages logged at 11:58:17
11:58:20 INFO - Hovering at 2, 8
11:58:20 INFO - Buffered messages logged at 11:58:18
11:58:20 INFO - Hovering at 2, 8
11:58:20 INFO - Buffered messages logged at 11:58:19
11:58:20 INFO - Hovering at 2, 8
11:58:20 INFO - Buffered messages logged at 11:58:20
11:58:20 INFO - Hovering at 2, 8
11:58:20 INFO - Buffered messages finished
11:58:20 INFO - TEST-UNEXPECTED-FAIL | devtools/client/debugger/test/mochitest/browser_dbg-sourcemapped-preview.js | Uncaught exception - failed to preview
11:58:20 INFO - Leaving test bound

See Also: → 1552702
[task 2019-05-20T10:57:36.072Z] 10:57:36     INFO - Buffered messages logged at 10:57:29
[task 2019-05-20T10:57:36.073Z] 10:57:36     INFO - Hovering at 14, 12
[task 2019-05-20T10:57:36.074Z] 10:57:36     INFO - Buffered messages logged at 10:57:30
[task 2019-05-20T10:57:36.074Z] 10:57:36     INFO - Hovering at 14, 12
[task 2019-05-20T10:57:36.075Z] 10:57:36     INFO - Buffered messages logged at 10:57:31
[task 2019-05-20T10:57:36.076Z] 10:57:36     INFO - Hovering at 14, 12
[task 2019-05-20T10:57:36.077Z] 10:57:36     INFO - Buffered messages logged at 10:57:32
[task 2019-05-20T10:57:36.078Z] 10:57:36     INFO - Hovering at 14, 12
[task 2019-05-20T10:57:36.078Z] 10:57:36     INFO - Buffered messages logged at 10:57:33
[task 2019-05-20T10:57:36.079Z] 10:57:36     INFO - Hovering at 14, 12
[task 2019-05-20T10:57:36.080Z] 10:57:36     INFO - Buffered messages logged at 10:57:34
[task 2019-05-20T10:57:36.081Z] 10:57:36     INFO - Hovering at 14, 12
[task 2019-05-20T10:57:36.081Z] 10:57:36     INFO - Buffered messages finished
[task 2019-05-20T10:57:36.082Z] 10:57:36     INFO - TEST-UNEXPECTED-FAIL | devtools/client/debugger/test/mochitest/browser_dbg-sourcemapped-preview.js | Uncaught exception - failed to preview

11:09:55     INFO - Buffered messages logged at 11:09:49
11:09:55     INFO - Hovering at 29, 19
11:09:55     INFO - Buffered messages logged at 11:09:50
11:09:55     INFO - Hovering at 29, 19
11:09:55     INFO - Buffered messages logged at 11:09:51
11:09:55     INFO - Hovering at 29, 19
11:09:55     INFO - Buffered messages logged at 11:09:52
11:09:55     INFO - Hovering at 29, 19
11:09:55     INFO - Buffered messages logged at 11:09:53
11:09:55     INFO - Hovering at 29, 19
11:09:55     INFO - Buffered messages logged at 11:09:54
11:09:55     INFO - Hovering at 29, 19
11:09:55     INFO - Buffered messages finished
11:09:55     INFO - TEST-UNEXPECTED-FAIL | devtools/client/debugger/test/mochitest/browser_dbg-sourcemapped-preview.js | Uncaught exception - failed to preview
[task 2019-05-20T11:09:09.576Z] 11:09:09     INFO - Buffered messages logged at 11:09:03
[task 2019-05-20T11:09:09.578Z] 11:09:09     INFO - Hovering at 14, 12
[task 2019-05-20T11:09:09.579Z] 11:09:09     INFO - Buffered messages logged at 11:09:04
[task 2019-05-20T11:09:09.580Z] 11:09:09     INFO - Hovering at 14, 12
[task 2019-05-20T11:09:09.581Z] 11:09:09     INFO - Buffered messages logged at 11:09:05
[task 2019-05-20T11:09:09.582Z] 11:09:09     INFO - Hovering at 14, 12
[task 2019-05-20T11:09:09.583Z] 11:09:09     INFO - Buffered messages logged at 11:09:06
[task 2019-05-20T11:09:09.584Z] 11:09:09     INFO - Hovering at 14, 12
[task 2019-05-20T11:09:09.587Z] 11:09:09     INFO - Buffered messages logged at 11:09:07
[task 2019-05-20T11:09:09.588Z] 11:09:09     INFO - Hovering at 14, 12
[task 2019-05-20T11:09:09.589Z] 11:09:09     INFO - Buffered messages logged at 11:09:08
[task 2019-05-20T11:09:09.590Z] 11:09:09     INFO - Hovering at 14, 12
[task 2019-05-20T11:09:09.591Z] 11:09:09     INFO - Buffered messages finished
[task 2019-05-20T11:09:09.592Z] 11:09:09     INFO - TEST-UNEXPECTED-FAIL | devtools/client/debugger/test/mochitest/browser_dbg-sourcemapped-preview.js | Uncaught exception - failed to preview
Priority: P5 → P1

feel free to land this to stop the bleeding, but note that I'll be working on this soon. This is definitely an issue we caused lately and I'd like to get to the bottom of it.

Keywords: leave-open
Whiteboard: [stockwell disable-recommended] → [stockwell disabled]
Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/96d3637d6e79
disabled browser_dbg-sourcemapped-preview.js on linux and macosx1010 r=jmaher
Duplicate of this bug: 1552702
Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0fd346904cf7
Fix Intermittent browser_dbg-sourcemapped-preview.js. r=davidwalsh

Looks like the fix landed in comment 17 and leave-open should have been removed.

Assignee: nobody → jlaster
Keywords: leave-open
Target Milestone: --- → Firefox 69
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Whiteboard: [stockwell disabled] → [stockwell fixed]
You need to log in before you can comment on or make changes to this bug.