Closed Bug 1552024 Opened 6 months ago Closed 6 months ago

[File a new bug if this happens again] Intermittent browser_telemetry_completeBadSize.js | A promise chain failed to handle a rejection: BitsError {type: 50, action: 6, stage: 2, codeType: none} - stack: BitsError@resource://gre/modules/Bits.jsm:79:5

Categories

(Toolkit :: Application Update, defect, P5)

Unspecified
Windows
defect

Tracking

()

RESOLVED DUPLICATE of bug 1546957
Tracking Status
firefox66 --- unaffected
firefox67 --- unaffected
firefox67.0.1 --- unaffected
firefox68 --- fix-optional

People

(Reporter: intermittent-bug-filer, Unassigned)

Details

(Keywords: intermittent-failure, regression)

Filed by: dluca [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=246643582&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/NZ9lsI_NQ2-37eh41G2XbA/runs/0/artifacts/public/logs/live_backing.log


INFO - TEST-START | toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js
18:02:59 INFO - GECKO(3972) | JavaScript error: resource://gre/modules/Bits.jsm, line 79: Error: BitsError {type: 50, action: 6, stage: 2, codeType: none}
18:02:59 INFO - TEST-INFO | started process screenshot
18:03:00 INFO - TEST-INFO | screenshot: exit 0
18:03:00 INFO - Buffered messages logged at 18:02:59
18:03:00 INFO - Entering test bound setupTestCommon
18:03:00 INFO - Leaving test bound setupTestCommon
18:03:00 INFO - Entering test bound telemetry_completeBadSize
18:03:00 INFO - Console message: [JavaScript Error: "Error: BitsError {type: 50, action: 6, stage: 2, codeType: none}" {file: "resource://gre/modules/Bits.jsm" line: 79}]
18:03:00 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js | The update.session.from_app_version value should exist. - true == true -
18:03:00 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js | The update.session.from_app_version value should equal the expected value. - "68.0a1" == "68.0a1" -
18:03:00 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js | The update.session.mar_partial_size_bytes value should not exist. - true == true -
18:03:00 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js | The update.session.mar_complete_size_bytes value should exist. - true == true -
18:03:00 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js | The update.session.mar_complete_size_bytes value should equal the expected value. - 14191 == 14191 -
18:03:00 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js | The update.session.intervals.check value should exist. - true == true -
18:03:00 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js | The update.session.intervals.check value should be equal to or greater than 1. - 1 >= 1 -
18:03:00 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js | The update.session.intervals.download_bits_partial value should not exist. - true == true -
18:03:00 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js | The update.session.intervals.download_bits_complete value should exist. - true == true -
18:03:00 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js | The update.session.intervals.download_bits_complete value should be equal to or greater than 1. - 1 >= 1 -
18:03:00 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js | The update.session.intervals.download_internal_partial value should not exist. - true == true -
18:03:00 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js | The update.session.intervals.download_internal_complete value should exist. - true == true -
18:03:00 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js | The update.session.intervals.download_internal_complete value should be equal to or greater than 1. - 1 >= 1 -
18:03:00 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js | The update.session.intervals.stage_partial value should not exist. - true == true -
18:03:00 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js | The update.session.intervals.stage_complete value should not exist. - true == true -
18:03:00 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js | The update.session.intervals.apply_partial value should not exist. - true == true -
18:03:00 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js | The update.session.intervals.apply_complete value should not exist. - true == true -
18:03:00 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js | The update.session.downloads.bits_partial_bytes value should not exist. - true == true -
18:03:00 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js | The update.session.downloads.bits_partial_seconds value should not exist. - true == true -
18:03:00 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js | The update.session.downloads.bits_complete_bytes value should exist. - true == true -
18:03:00 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js | The update.session.downloads.bits_complete_bytes value should be equal to or greater than 1. - 1419 >= 1 -
18:03:00 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js | The update.session.downloads.bits_complete_seconds value should exist. - true == true -
18:03:00 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js | The update.session.downloads.bits_complete_seconds value should be equal to or greater than 1. - 1 >= 1 -
18:03:00 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js | The update.session.downloads.internal_partial_bytes value should not exist. - true == true -
18:03:00 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js | The update.session.downloads.internal_partial_seconds value should not exist. - true == true -
18:03:00 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js | The update.session.downloads.internal_complete_bytes value should exist. - true == true -
18:03:00 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js | The update.session.downloads.internal_complete_bytes value should be equal to or greater than 1. - 1419 >= 1 -
18:03:00 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js | The update.session.downloads.internal_complete_seconds value should exist. - true == true -
18:03:00 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js | The update.session.downloads.internal_complete_seconds value should be equal to or greater than 1. - 1 >= 1 -
18:03:00 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js | The update.startup.from_app_version value should not exist. - true == true -
18:03:00 INFO - Buffered messages finished
18:03:00 INFO - TEST-UNEXPECTED-FAIL | toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js | A promise chain failed to handle a rejection: BitsError {type: 50, action: 6, stage: 2, codeType: none} - stack: BitsError@resource://gre/modules/Bits.jsm:79:5
18:03:00 INFO - cancelAsync@resource://gre/modules/Bits.jsm:384:13
18:03:00 INFO - Downloader_cancel@resource://gre/modules/UpdateService.jsm:3736:27
18:03:00 INFO - Downloader_onProgress@resource://gre/modules/UpdateService.jsm:4257:12
18:03:00 INFO - wrappedObserver_onProgress@resource://gre/modules/Bits.jsm:562:20
18:03:00 INFO - Rejection date: Wed May 15 2019 18:02:59 GMT+0000 (Greenwich Mean Time) - false == true - JS frame :: resource://testing-common/PromiseTestUtils.jsm :: assertNoUncaughtRejections :: line 257
18:03:00 INFO - Stack trace:
18:03:00 INFO - resource://testing-common/PromiseTestUtils.jsm:assertNoUncaughtRejections:257
18:03:00 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1140
18:03:00 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1144
18:03:00 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:1005
18:03:00 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
18:03:00 INFO - Leaving test bound telemetry_completeBadSize
18:03:00 INFO - GECKO(3972) | MEMORY STAT | vsize 19406227MB | vsizeMaxContiguous 66096673MB | residentFast 1423MB
18:03:00 INFO - TEST-OK | toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js | took 382ms
18:03:00 INFO - checking window state
18:03:00 INFO - TEST-START | toolkit/mozapps/update/tests/browser/browser_telemetry_complete_applied.js
18:03:00 INFO - GECKO(3972) | MEMORY STAT | vsize 19406229MB | vsizeMaxContiguous 66096673MB | residentFast 1426MB
18:03:00 INFO - TEST-OK | toolkit/mozapps/update/tests/browser/browser_telemetry_complete_applied.js | took 273ms

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → DUPLICATE
Summary: Intermittent toolkit/mozapps/update/tests/browser/browser_telemetry_completeBadSize.js | A promise chain failed to handle a rejection: BitsError {type: 50, action: 6, stage: 2, codeType: none} - stack: BitsError@resource://gre/modules/Bits.jsm:79:5 → [File a new bug if this happens again] Intermittent browser_telemetry_completeBadSize.js | A promise chain failed to handle a rejection: BitsError {type: 50, action: 6, stage: 2, codeType: none} - stack: BitsError@resource://gre/modules/Bits.jsm:79:5
Duplicate of bug: 1546957
You need to log in before you can comment on or make changes to this bug.