bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

mozilla -jsconsole <url> tries to load URL as chrome

VERIFIED DUPLICATE of bug 74303

Status

Core Graveyard
Cmd-line Features
VERIFIED DUPLICATE of bug 74303
16 years ago
9 years ago

People

(Reporter: Shanmugavelu Shanmuganathan (gone), Assigned: Bill Law)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
mozilla --sync --no-xshm -jsconsole  http://camera01.cs.wustl.edu

This brings up two navigator windows with smallest possible height.
This happens only when with url. 
if I try the same experiment with java.sun.com (or any other)
two windows appear, but the windows have no menus in it. 

I saw the same behaviour on a Linux too.

Comment 1

16 years ago
when you do

mozilla -jsconsole URL

what you are telling it is to bring up the javscript console, and have it (the
javascript console) load the URL.
(Reporter)

Comment 2

16 years ago
Got it. 
But isn't the problem that the windows are tiny (with
http://camera01.cs.wustl.edu)  a bug?

Comment 3

16 years ago
ok, when you do "-jsconsole URL", it initially tries to do javascript console,
but that doesn't take arguments (URL is an argument for jsconsole).  When it
realizes that, it takes URL to be the chrome.  you should get the same behavior with

mozilla -chrome http://camera01.cs.wustl.edu

if this is a bug, it's in command-line handling
Assignee: Matti → law
Component: Browser-General → XP Apps: Cmd-line Features
QA Contact: imajes-qa → sairuh
(Reporter)

Comment 4

16 years ago
On a Linux machine I typed
mozilla -chrome http://camera01.cs.wustl.edu

(Cancelled  the username/password dialog box)
I got a tiny window. 

Comment 5

16 years ago
-chrome foo means take foo and use it as chrome, the cancel causes the page to
be effectively empty, there's no bug there.
OS: OSF/1 → All
Hardware: DEC → All
(Reporter)

Comment 6

16 years ago
Even if I type a valid  Username and password the window height and width
is the minimum.

Comment 7

16 years ago
I tried -chrome with a couple of web pages, and it gave very bizarre results
each time. but that's not a bug - you must expect it to do bizarre things if you
tell it to do bizarre things.

the question is why does:
mozilla -jsconsole URL
try and launch the URL as chrome?

when the -jsconsole doesn't take an argument, shouldn't it take the URL as a URL?

apologies if i'm way off base here, or this should be a dupe of one of the other
command line parsing bugs, but this seems wrong to me. confirming, and
resummarising.
Severity: major → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Browser comes up with height < 1cm. → mozilla -jsconsole <url> tries to load URL as chrome

Comment 8

16 years ago
> the question is why does:
> mozilla -jsconsole URL
> try and launch the URL as chrome?
> 
> when the -jsconsole doesn't take an argument, shouldn't it take the URL as a 
> URL?

bug 74303

Comment 9

16 years ago
ok, so if the only issue here is the command line parsing, and that's covered by
the other bug, then this is a dupe, right?  marking as such, please thwap me if
you disagree...

*** This bug has been marked as a duplicate of 74303 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
v dup.
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: Cmd-line Features → Cmd-line Features
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.