If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

pcmarket.singtao.com - Missing Banner at Page

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
Chinese-Traditional
RESOLVED WORKSFORME
16 years ago
3 years ago

People

(Reporter: Peter Woo, Unassigned)

Tracking

Details

(Whiteboard: [chinese-traditional], URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

Very awkful javascript was used to produce a simple <a><img></a> equivalent. 
However, I.E. could produce the image as expected.

Reproducible: Always
Steps to Reproduce:
1.Go to the page using Mozilla.
2.A blank rectangle at the top, which is supposedly a gif banner ad.
3.Go to the same page using I.E. to check for expected result.


Actual Results:  A blank rectangle at the top, which is supposed to be a gif
banner ad.


Expected Results:  To see the gif banner ad.

Comment 1

15 years ago
Source looks like this:
<iframe SRC="http://203.194.152.2/Adv/Output.cfm?Browser=IE..">
  <script src="http://203.194.152.2/Adv/Output.cfm?Browser=Netscape.."></script>
  <noscript>
    <a href="http://203.194.152.2/Adv/Output_click2.cfm?.." target=_top>
    <img src="http://203.194.152.2/Adv/Output_ad.cfm?.."></a>
  </noscript>
</iframe>

The source of the iframe only returns a page for a MSIE User-Agent. For non-MSIE
browsers it returns an empty page. Mozilla supports IFRAME, so it won't render
anything between <iframe> and </iframe>. The <script src=Browser=Netscape> does
return some javascript, but Mozilla won't see that.

I think the best option is to remove the browser sniffing code.

Note: 203.194.152.2 is owned by iadvantage.net.hk.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 98 → All
Summary: Missing Banner at Page → pcmarket.singtao.com - Missing Banner at Page

Comment 2

15 years ago
Created attachment 91700 [details]
a screen shot

Comment 3

15 years ago
Traditional Chinese site. Moving to Other.
Assignee: momoi → other
Component: Asian → Other
QA Contact: ruixu → other
Whiteboard: [chinese-traditional]
Assignee: other → chinese-traditional
Component: Other → Chinese-Traditional
QA Contact: other → chinese-traditional
404
Mozilla/5.0 (Android; Mobile; rv:23.0) Gecko/23.0 Firefox/23.0
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.