Closed Bug 1552142 Opened 4 months ago Closed 2 months ago

Text inside the contrast badges should be unselectable

Categories

(DevTools :: Accessibility Tools, enhancement)

enhancement
Not set

Tracking

(firefox66 disabled, firefox67 disabled, firefox68 wontfix, firefox69 wontfix, firefox70 verified)

VERIFIED FIXED
Firefox 70
Tracking Status
firefox66 --- disabled
firefox67 --- disabled
firefox68 --- wontfix
firefox69 --- wontfix
firefox70 --- verified

People

(Reporter: tbabos, Assigned: shellyc23, Mentored)

Details

(Keywords: good-first-bug)

Attachments

(1 file)

Affected versions
Nightly 68.0a1 (2019-05-15)

Affected platforms
All

Steps to reproduce

  • Launch Nightly
  • Go to twitter.com (or any other page)
  • Enable a11y
  • Perform a full page contrast audit
  • Hover over the "contrast" badges

Expected result
The text inside the badges should be unselectable and the mouse cursor should not change into the "Text select" form.

Actual Result
The text inside the contrast badges is selectable.

Blocks: 1522207
No longer blocks: 1522207

This requires setting user-select CSS property for the .badge class in https://searchfox.org/mozilla-central/source/devtools/client/accessibility/accessibility.css to none.

Mentor: yzenevich
Keywords: good-first-bug

Hello,

I would like to take a stab at this.

I added -moz-user-select: none; to the .badge class in devtools/client/accessibility/accessibility.css .

Assignee: nobody → shellyc23
Status: NEW → ASSIGNED
Pushed by yura.zenevich@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/bab3a664928e
Text inside the contrast badges should be unselectable r=yzen
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70

Since the status are different for nightly and release, what's the status for beta?
For more information, please visit auto_nag documentation.

Please nominate this for Beta approval when you get a chance.

Flags: needinfo?(shellyc23)

Yura, is this something we should nominate for uplift?

Flags: needinfo?(yzenevich)

(In reply to Ryan VanderMeulen [:RyanVM] from comment #8)

Yura, is this something we should nominate for uplift?

Not crucial. I would just let it ride the train.

Flags: needinfo?(yzenevich)
Flags: needinfo?(shellyc23)
Flags: qe-verify+
Flags: needinfo?(tbabos)

Verified-fixed on latest Beta 70.0b7 on Windows 10 64, Mac OS 10.13 and Ubuntu 18.04
Closing it as verified - fixed.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: needinfo?(tbabos)
You need to log in before you can comment on or make changes to this bug.