@amazon alias isn't present for non-en-US builds

RESOLVED FIXED in Firefox 68

Status

()

defect
P1
normal
RESOLVED FIXED
Last month
7 days ago

People

(Reporter: standard8, Assigned: standard8)

Tracking

(Regression, {regression})

unspecified
Firefox 68
Points:
1
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox67 unaffected, firefox68 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

Last month

I noticed earlier today that the @amazon alias wasn't present for locales not using the en-US build.

This was a side effect of the short name changing to a different format (not using list.json's) when we moved to WebExtensions in bug 1496075.

The amazon-de one was further broken because I missed updating it in bug 1549821.

However, we've agreement from product that the @amazon alias can be used everywhere Amazon is available, so I'll change the code to handle that.

Assignee

Updated

Last month
Blocks: 1552188

Comment 2

Last month
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ca120c3031d2
Fix the @amazon search alias on non-en-US builds. r=mikedeboer

Comment 3

Last month
bugherder
Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Assignee

Updated

25 days ago
Points: --- → 1
You need to log in before you can comment on or make changes to this bug.