Closed Bug 1552191 Opened 7 months ago Closed 7 months ago

Fix permafailing webreplay tests

Categories

(DevTools :: Debugger, defect, P3)

defect

Tracking

(firefox68 fixed)

RESOLVED FIXED
Firefox 68
Tracking Status
firefox68 --- fixed

People

(Reporter: jdescottes, Assigned: jdescottes)

References

Details

Attachments

(1 file)

In bug 1551718 we are skipping three webreplay tests:

[browser_dbg_rr_console_warp-01.js]
skip-if = true
[browser_dbg_rr_console_warp-02.js]
skip-if = true
[browser_dbg_rr_logpoint-01.js]
skip-if = true

They are all failing because of context menu issues most likely linked to https://bugzilla.mozilla.org/show_bug.cgi?id=1543940

Since webreplay tests were not running on try for a while, we missed this regression. The context menu element should be retrieved from the toolbox top document.

3 webreplay tests regressed while the webreplay test suite was no longer running on try.

Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0013ca341d7c
Fix webreplay tests using webconsole context menu r=jlast
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
You need to log in before you can comment on or make changes to this bug.