Last Comment Bug 155221 - Word wrap preference discarded always (Preferences->Mail->Composition->Wrap Plain Text Messages=XX)
: Word wrap preference discarded always (Preferences->Mail->Composition->Wrap P...
Status: VERIFIED DUPLICATE of bug 155219
:
Product: MailNews Core
Classification: Components
Component: Composition (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Jean-Francois Ducarroz
: esther
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-01 10:57 PDT by Bryce Mozilla Nesbitt
Modified: 2008-07-31 01:22 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Bryce Mozilla Nesbitt 2002-07-01 10:57:40 PDT
The code exists to read the user's word wrap width preference:

       if (NS_SUCCEEDED(rv) && prefs) 
          prefs->GetIntPref("mailnews.wraplength", &width);
       // Let sanity reign!
       if (width < 10)
         width = 10;
       else if (width > 30000)
         width = 30000; 

But the calculated width is never passed anywhere.  In addition 30000 is a
very abitrary number, not supported by any of the RFC's relating to creating
plain text (text/plain) messages.

I have attached a patch that moves this code to a place where it can have
some effect, rationalizes the limits to match the RFC's, and allows
specification of 0.  All this works perfectly with our without format=flowed
text.  The existing issues with utf-8 are not affected.

Plese consider applying this patch.
Comment 1 Bryce Mozilla Nesbitt 2002-07-01 11:00:59 PDT

*** This bug has been marked as a duplicate of 155219 ***
Comment 2 esther 2002-07-15 19:34:47 PDT
verified

Note You need to log in before you can comment on or make changes to this bug.