TV fails to verify mochitest-devtools-webreplay tests

RESOLVED FIXED in Firefox 69

Status

defect
P1
normal
RESOLVED FIXED
Last month
29 days ago

People

(Reporter: gbrown, Assigned: gbrown)

Tracking

(Blocks 1 bug)

unspecified
mozilla69
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox69 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

Last month

Bug 1535287 noted that webreplay (M(dt-wr)) tests are not run by test-verify. Part of the problem was bug 1551718: M(dt-wr) was not running tests either. But with bug 1551718 fixed, TV still fails on webreplay tests:

https://treeherder.mozilla.org/#/jobs?repo=try&tier=1%2C2%2C3&selectedJob=246861090&revision=cbe074c3915fe7d7c75ee257408a8b12652c5507

TV tries to run webreplay tests as browser-chrome, with no subsuite specified:

17:24:48 INFO - Per-test suites: {'mochitest-browser-chrome': ('--flavor=browser',)}

17:26:41 INFO - Calling ['/Users/cltbld/tasks/task_1558027411/build/venv/bin/python', '-u', '/Users/cltbld/tasks/task_1558027411/build/tests/mochitest/runtests.py', '--appname=/Users/cltbld/tasks/task_1558027411/build/application/Firefox Nightly.app/Contents/MacOS/firefox', '--utility-path=tests/bin', '--extra-profile-file=tests/bin/plugins', u'--symbols-path=https://queue.taskcluster.net/v1/task/V9udMa0QRlmpY31Qjhn2LA/artifacts/public/build/target.crashreporter-symbols.zip', '--certificate-path=tests/certs', '--quiet', '--log-raw=/Users/cltbld/tasks/task_1558027411/build/blobber_upload_dir/mochitest-browser-chrome_raw.log', '--log-errorsummary=/Users/cltbld/tasks/task_1558027411/build/blobber_upload_dir/mochitest-browser-chrome_errorsummary.log', '--screenshot-on-fail', '--cleanup-crashes', '--marionette-startup-timeout=180', '--sandbox-read-whitelist=/Users/cltbld/tasks/task_1558027411/build', '--log-raw=-', '--flavor=browser', '--verify-max-time=900', '--verify', u'devtools/client/webreplay/mochitest/browser_dbg_rr_logpoint-02.js'] with output_timeout 1000

17:26:42 ERROR - No tests were found for flavor 'browser' and the following manifest filters:
17:26:42 ERROR - skip_if, run_if, fail_if, remove_imptest_failure_expectations, subsuite(name=None), pathprefix(['devtools/client/webreplay/mochitest/browser_dbg_rr_logpoint-02.js'])
17:26:42 ERROR -
17:26:42 ERROR - Make sure the test paths (if any) are spelt correctly and the corresponding
17:26:42 ERROR - --flavor and --subsuite are being used. See mach mochitest --help for a
17:26:42 ERROR - list of valid flavors.
17:26:42 ERROR -

Assignee

Comment 1

Last month

A new entry was required to map the subsuite name to the mozharness
config name - simple!

Assignee

Updated

Last month
Priority: -- → P1

Comment 2

29 days ago
Pushed by gbrown@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7b5f1a48d4e9
Support webreplay subsuite in test-verify; r=bc

Comment 3

29 days ago
bugherder
Status: NEW → RESOLVED
Closed: 29 days ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Assignee

Updated

29 days ago
Duplicate of this bug: 1535287
You need to log in before you can comment on or make changes to this bug.