Closed Bug 1552324 Opened 2 years ago Closed 5 months ago

Implement Network.responseReceived

Categories

(Remote Protocol :: Network, enhancement, P1)

enhancement

Tracking

(firefox78 fixed)

RESOLVED FIXED
Firefox 78
Tracking Status
firefox78 --- fixed

People

(Reporter: ochameau, Assigned: maja_zf)

References

(Blocks 1 open bug)

Details

(Whiteboard: [puppeteer-beta-reserve])

Attachments

(1 file)

See bug 1552325 comment 0.

Here is an example of such event:

{"method":"Network.responseReceived","params":{"requestId":"F931C3A196EED24B5886CF5D1842D29E","loaderId":"F931C3A196EED24B5886CF5D1842D29E","timestamp":68261.802608,"type":"Document","response":{"url":"http://localhost:8889/wp-admin/post-new.php","status":200,"statusText":"OK","headers":{"Date":"Thu, 16 May 2019 18:02:36 GMT","Server":"Apache/2.4.25 (Debian)","X-Powered-By":"PHP/7.2.18","Expires":"Wed, 11 Jan 1984 05:00:00 GMT","Cache-Control":"no-cache, must-revalidate, max-age=0","X-Frame-Options":"SAMEORIGIN","Referrer-Policy":"strict-origin-when-cross-origin","Vary":"Accept-Encoding","Content-Encoding":"gzip","Content-Length":"51673","Keep-Alive":"timeout=5, max=79","Connection":"Keep-Alive","Content-Type":"text/html; charset=UTF-8"},"headersText":"HTTP/1.1 200 OK\r\nDate: Thu, 16 May 2019 18:02:36 GMT\r\nServer: Apache/2.4.25 (Debian)\r\nX-Powered-By: PHP/7.2.18\r\nExpires: Wed, 11 Jan 1984 05:00:00 GMT\r\nCache-Control: no-cache, must-revalidate, max-age=0\r\nX-Frame-Options: SAMEORIGIN\r\nReferrer-Policy: strict-origin-when-cross-origin\r\nVary: Accept-Encoding\r\nContent-Encoding: gzip\r\nContent-Length: 51673\r\nKeep-Alive: timeout=5, max=79\r\nConnection: Keep-Alive\r\nContent-Type: text/html; charset=UTF-8\r\n\r\n","mimeType":"text/html","requestHeaders":{"Host":"localhost:8889","Connection":"keep-alive","Upgrade-Insecure-Requests":"1","User-Agent":"Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3494.0 Safari/537.36","Accept":"text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8","Accept-Encoding":"gzip, deflate, br","Accept-Language":"en-US,en;q=0.9","Cookie":"wordpress_23778236db82f19306f247e20a353a99=admin%7C1558202553%7CVuVC3Z18s9haDWOEEiOcN7Z4NWd3jdjorB94Vm6SErb%7C10b74bec70ab51a52c5d7b6c5dd4ea17fb80e6299d88b979e47b996c7fd24d3c; wordpress_test_cookie=WP+Cookie+check; wordpress_logged_in_23778236db82f19306f247e20a353a99=admin%7C1558202553%7CVuVC3Z18s9haDWOEEiOcN7Z4NWd3jdjorB94Vm6SErb%7C66d3f40ceebce50047aad36163b9a95b8348188efe559cb40f6971279586fa1e; wp-settings-1=editor%3Dtinymce; wp-settings-time-1=1558029753"},"requestHeadersText":"GET /wp-admin/post-new.php HTTP/1.1\r\nHost: localhost:8889\r\nConnection: keep-alive\r\nUpgrade-Insecure-Requests: 1\r\nUser-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3494.0 Safari/537.36\r\nAccept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8\r\nAccept-Encoding: gzip, deflate, br\r\nAccept-Language: en-US,en;q=0.9\r\nCookie: wordpress_23778236db82f19306f247e20a353a99=admin%7C1558202553%7CVuVC3Z18s9haDWOEEiOcN7Z4NWd3jdjorB94Vm6SErb%7C10b74bec70ab51a52c5d7b6c5dd4ea17fb80e6299d88b979e47b996c7fd24d3c; wordpress_test_cookie=WP+Cookie+check; wordpress_logged_in_23778236db82f19306f247e20a353a99=admin%7C1558202553%7CVuVC3Z18s9haDWOEEiOcN7Z4NWd3jdjorB94Vm6SErb%7C66d3f40ceebce50047aad36163b9a95b8348188efe559cb40f6971279586fa1e; wp-settings-1=editor%3Dtinymce; wp-settings-time-1=1558029753\r\n","connectionReused":true,"connectionId":192,"remoteIPAddress":"[::1]","remotePort":8889,"fromDiskCache":false,"fromServiceWorker":false,"encodedDataLength":0,"timing":{"requestTime":68261.694328,"proxyStart":-1,"proxyEnd":-1,"dnsStart":-1,"dnsEnd":-1,"connectStart":-1,"connectEnd":-1,"sslStart":-1,"sslEnd":-1,"workerStart":-1,"workerReady":-1,"sendStart":2.694,"sendEnd":2.737,"pushStart":0,"pushEnd":0,"receiveHeadersEnd":107.836},"protocol":"http/1.1","securityState":"neutral"},"frameId":"A966F77A1F3A97FF8CEEAD72EFE9B104"}}
Blocks: 1552326

The responseReceived event is only used to emit the Request "response" event. This event is not directly used by Gutenberg. It is used by waitForNavigation to get the response content, but it doesn't block the method.

Priority: P2 → P3
Whiteboard: [puppeteer-alp
Whiteboard: [puppeteer-alp → [puppeteer-alpha]
Priority: P3 → P2

Nothing in the Gutenberg e2e tests is making use of this event. It's only received because Puppeteer enabled the Network domain by default. As such it's not blocking out alpha release.

No longer blocks: puppeteer-gutenberg
Priority: P2 → P3
Whiteboard: [puppeteer-alpha]
Whiteboard: [puppeteer-beta]
Whiteboard: [puppeteer-beta] → [puppeteer-beta-reserve]
No longer blocks: 1599257
Priority: P3 → P2
Assignee: nobody → mjzffr
Status: NEW → ASSIGNED
Priority: P2 → P1
Pushed by mjzffr@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/2518e3505983
Implement subset of Network.responseReceived r=remote-protocol-reviewers,whimboo
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 78
Regressions: 1638508
You need to log in before you can comment on or make changes to this bug.