Closed Bug 1552339 Opened 5 months ago Closed 5 months ago

Perma [tier2] Android mochitest dom/webauthn/tests/test_webauthn_attestation_conveyance.html | Is a FIDO U2F Attestation - got "fido-u2f", expected "none"

Categories

(Core :: DOM: Web Authentication, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox68 --- fixed
firefox69 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: jcj)

References

(Regression)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [stockwell disable-recommended])

Attachments

(1 file)

Filed by: opoprus [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=246855845&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/B8AWC5IQTyyort8suqoNYQ/runs/0/artifacts/public/logs/live_backing.log


[task 2019-05-16T18:28:58.345Z] 18:28:58 INFO - 221 INFO TEST-START | dom/webauthn/tests/test_webauthn_attestation_conveyance.html
[task 2019-05-16T18:28:58.348Z] 18:28:58 INFO - Buffered messages logged at 18:27:48
[task 2019-05-16T18:28:58.349Z] 18:28:58 INFO - 222 INFO add_task | Entering test
[task 2019-05-16T18:28:58.350Z] 18:28:58 INFO - 223 INFO add_task | Leaving test
[task 2019-05-16T18:28:58.351Z] 18:28:58 INFO - 224 INFO add_task | Entering test
[task 2019-05-16T18:28:58.354Z] 18:28:58 INFO - 225 INFO TEST-PASS | dom/webauthn/tests/test_webauthn_attestation_conveyance.html | Is a None Attestation
[task 2019-05-16T18:28:58.355Z] 18:28:58 INFO - 226 INFO TEST-PASS | dom/webauthn/tests/test_webauthn_attestation_conveyance.html | attStmt is a map
[task 2019-05-16T18:28:58.355Z] 18:28:58 INFO - 227 INFO TEST-PASS | dom/webauthn/tests/test_webauthn_attestation_conveyance.html | attStmt is empty
[task 2019-05-16T18:28:58.356Z] 18:28:58 INFO - Buffered messages logged at 18:27:49
[task 2019-05-16T18:28:58.357Z] 18:28:58 INFO - 228 INFO TEST-PASS | dom/webauthn/tests/test_webauthn_attestation_conveyance.html | Is a None Attestation
[task 2019-05-16T18:28:58.358Z] 18:28:58 INFO - 229 INFO TEST-PASS | dom/webauthn/tests/test_webauthn_attestation_conveyance.html | attStmt is a map
[task 2019-05-16T18:28:58.359Z] 18:28:58 INFO - 230 INFO TEST-PASS | dom/webauthn/tests/test_webauthn_attestation_conveyance.html | attStmt is empty
[task 2019-05-16T18:28:58.360Z] 18:28:58 INFO - 231 INFO TEST-PASS | dom/webauthn/tests/test_webauthn_attestation_conveyance.html | Is a None Attestation
[task 2019-05-16T18:28:58.361Z] 18:28:58 INFO - 232 INFO TEST-PASS | dom/webauthn/tests/test_webauthn_attestation_conveyance.html | attStmt is a map
[task 2019-05-16T18:28:58.363Z] 18:28:58 INFO - 233 INFO TEST-PASS | dom/webauthn/tests/test_webauthn_attestation_conveyance.html | attStmt is empty
[task 2019-05-16T18:28:58.364Z] 18:28:58 INFO - Buffered messages finished
[task 2019-05-16T18:28:58.365Z] 18:28:58 INFO - 234 INFO TEST-UNEXPECTED-FAIL | dom/webauthn/tests/test_webauthn_attestation_conveyance.html | Is a FIDO U2F Attestation - got "fido-u2f", expected "none"
[task 2019-05-16T18:28:58.366Z] 18:28:58 INFO - SimpleTest.is@https://example.com/tests/SimpleTest/SimpleTest.js:320:16
[task 2019-05-16T18:28:58.367Z] 18:28:58 INFO - getAttestationCertFromAttestationBuffer/<@https://example.com/tests/dom/webauthn/tests/test_webauthn_attestation_conveyance.html:26:9
[task 2019-05-16T18:28:58.367Z] 18:28:58 INFO - 235 INFO TEST-UNEXPECTED-FAIL | dom/webauthn/tests/test_webauthn_attestation_conveyance.html | Bad result! Received a: TypeError: aAttestationObj.attStmt.x5c is undefined
[task 2019-05-16T18:28:58.367Z] 18:28:58 INFO - SimpleTest.ok@https://example.com/tests/SimpleTest/SimpleTest.js:275:18
[task 2019-05-16T18:28:58.368Z] 18:28:58 INFO - arrivingHereIsBad@https://example.com/tests/dom/webauthn/tests/test_webauthn_attestation_conveyance.html:52:7
[task 2019-05-16T18:28:58.368Z] 18:28:58 INFO - 236 INFO add_task | Leaving test
[task 2019-05-16T18:28:58.369Z] 18:28:58 INFO - 237 INFO add_task | Entering test
[task 2019-05-16T18:28:58.370Z] 18:28:58 INFO - 238 INFO TEST-PASS | dom/webauthn/tests/test_webauthn_attestation_conveyance.html | Expecting a TypeError, got TypeError: 'attestation' member of PublicKeyCredentialCreationOptions 'unknown' is not a valid value for enumeration AttestationConveyancePreference.
[task 2019-05-16T18:28:58.370Z] 18:28:58 INFO - 239 INFO add_task | Leaving test
[task 2019-05-16T18:28:58.371Z] 18:28:58 INFO - 240 INFO TEST-OK | dom/webauthn/tests/test_webauthn_attestation_conveyance.html | took 3080ms

Regressed by: 1551229
Assignee: nobody → jjones
Status: NEW → ASSIGNED

There are 209 total failures on android-em-7-0-x86_64 debug and opt in the last 7 days

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=247489774&repo=autoland&lineNumber=3089

[task 2019-05-21T05:55:18.041Z] 05:55:18 INFO - 221 INFO TEST-START | dom/webauthn/tests/test_webauthn_attestation_conveyance.html
[task 2019-05-21T05:55:18.042Z] 05:55:18 INFO - Buffered messages logged at 05:55:10
[task 2019-05-21T05:55:18.042Z] 05:55:18 INFO - 222 INFO add_task | Entering test
[task 2019-05-21T05:55:18.042Z] 05:55:18 INFO - 223 INFO add_task | Leaving test
[task 2019-05-21T05:55:18.042Z] 05:55:18 INFO - 224 INFO add_task | Entering test
[task 2019-05-21T05:55:18.042Z] 05:55:18 INFO - 225 INFO TEST-PASS | dom/webauthn/tests/test_webauthn_attestation_conveyance.html | Is a None Attestation
[task 2019-05-21T05:55:18.042Z] 05:55:18 INFO - 226 INFO TEST-PASS | dom/webauthn/tests/test_webauthn_attestation_conveyance.html | attStmt is a map
[task 2019-05-21T05:55:18.042Z] 05:55:18 INFO - 227 INFO TEST-PASS | dom/webauthn/tests/test_webauthn_attestation_conveyance.html | attStmt is empty
[task 2019-05-21T05:55:18.042Z] 05:55:18 INFO - 228 INFO TEST-PASS | dom/webauthn/tests/test_webauthn_attestation_conveyance.html | Is a None Attestation
[task 2019-05-21T05:55:18.042Z] 05:55:18 INFO - 229 INFO TEST-PASS | dom/webauthn/tests/test_webauthn_attestation_conveyance.html | attStmt is a map
[task 2019-05-21T05:55:18.042Z] 05:55:18 INFO - 230 INFO TEST-PASS | dom/webauthn/tests/test_webauthn_attestation_conveyance.html | attStmt is empty
[task 2019-05-21T05:55:18.043Z] 05:55:18 INFO - 231 INFO TEST-PASS | dom/webauthn/tests/test_webauthn_attestation_conveyance.html | Is a None Attestation
[task 2019-05-21T05:55:18.043Z] 05:55:18 INFO - 232 INFO TEST-PASS | dom/webauthn/tests/test_webauthn_attestation_conveyance.html | attStmt is a map
[task 2019-05-21T05:55:18.043Z] 05:55:18 INFO - 233 INFO TEST-PASS | dom/webauthn/tests/test_webauthn_attestation_conveyance.html | attStmt is empty
[task 2019-05-21T05:55:18.043Z] 05:55:18 INFO - Buffered messages finished
[task 2019-05-21T05:55:18.043Z] 05:55:18 INFO - 234 INFO TEST-UNEXPECTED-FAIL | dom/webauthn/tests/test_webauthn_attestation_conveyance.html | Is a FIDO U2F Attestation - got "fido-u2f", expected "none"
[task 2019-05-21T05:55:18.043Z] 05:55:18 INFO - SimpleTest.is@https://example.com/tests/SimpleTest/SimpleTest.js:320:16
[task 2019-05-21T05:55:18.043Z] 05:55:18 INFO - getAttestationCertFromAttestationBuffer/<@https://example.com/tests/dom/webauthn/tests/test_webauthn_attestation_conveyance.html:26:9
[task 2019-05-21T05:55:18.043Z] 05:55:18 INFO - 235 INFO TEST-UNEXPECTED-FAIL | dom/webauthn/tests/test_webauthn_attestation_conveyance.html | Bad result! Received a: TypeError: aAttestationObj.attStmt.x5c is undefined
[task 2019-05-21T05:55:18.043Z] 05:55:18 INFO - SimpleTest.ok@https://example.com/tests/SimpleTest/SimpleTest.js:275:18
[task 2019-05-21T05:55:18.043Z] 05:55:18 INFO - arrivingHereIsBad@https://example.com/tests/dom/webauthn/tests/test_webauthn_attestation_conveyance.html:52:7
[task 2019-05-21T05:55:18.043Z] 05:55:18 INFO - 236 INFO add_task | Leaving test
[task 2019-05-21T05:55:18.043Z] 05:55:18 INFO - 237 INFO add_task | Entering test
[task 2019-05-21T05:55:18.044Z] 05:55:18 INFO - 238 INFO TEST-PASS | dom/webauthn/tests/test_webauthn_attestation_conveyance.html | Expecting a TypeError, got TypeError: 'attestation' member of PublicKeyCredentialCreationOptions 'unknown' is not a valid value for enumeration AttestationConveyancePreference.
[task 2019-05-21T05:55:18.044Z] 05:55:18 INFO - 239 INFO add_task | Leaving test
[task 2019-05-21T05:55:18.044Z] 05:55:18 INFO - 240 INFO TEST-OK | dom/webauthn/tests/test_webauthn_attestation_conveyance.html | took 571ms

J.C. are there any updates here? this has reached the disable recommended query, should we disable it until there is a fix?

Flags: needinfo?(jjones)
Whiteboard: [stockwell disable-recommended] → [stockwell needswork:owner]

Sorry, was out yesterday.

This test is specifically that direct attestation works... which it doesn't on Android, and the regressing bug explicitly disabled. I'll attach a patch to if-check Android for just this one case rather than disable the whole test.

Flags: needinfo?(jjones)
Priority: P5 → P1
Duplicate of this bug: 1553390
Pushed by jjones@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1765feffe210
On Android, direct attestations are anonymized r=keeler
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
You need to log in before you can comment on or make changes to this bug.