Perma [tier2] Android mochitest dom/smil/test/test_smilConditionalProcessing.html | b is in effect with passing conditional processing test on a - got +0, expected 100

RESOLVED FIXED in Firefox 69

Status

()

defect
P1
normal
RESOLVED FIXED
Last month
9 days ago

People

(Reporter: intermittent-bug-filer, Assigned: violet.bugreport)

Tracking

(Regression, {regression})

unspecified
mozilla69
Unspecified
Android
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox66 unaffected, firefox67 unaffected, firefox67.0.5 unaffected, firefox68 wontfix, firefox69 fixed)

Details

(Whiteboard: [geckoview:fenix:m6][stockwell disabled])

Attachments

(2 attachments)

Reporter

Description

Last month
treeherder

Filed by: opoprus [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=246880942&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/PZFoOk9tTKyBnkXmKr1jcA/runs/0/artifacts/public/logs/live_backing.log


[task 2019-05-16T20:16:42.100Z] 20:16:42 INFO - 1367 INFO TEST-START | dom/smil/test/test_smilConditionalProcessing.html
[task 2019-05-16T20:16:42.100Z] 20:16:42 INFO - Buffered messages logged at 20:16:33
[task 2019-05-16T20:16:42.101Z] 20:16:42 INFO - 1368 INFO TEST-PASS | dom/smil/test/test_smilConditionalProcessing.html | a has resolved start time at start
[task 2019-05-16T20:16:42.101Z] 20:16:42 INFO - 1369 INFO TEST-PASS | dom/smil/test/test_smilConditionalProcessing.html | a is in effect at start
[task 2019-05-16T20:16:42.101Z] 20:16:42 INFO - 1370 INFO TEST-PASS | dom/smil/test/test_smilConditionalProcessing.html | b has resolved start time at start
[task 2019-05-16T20:16:42.102Z] 20:16:42 INFO - 1371 INFO TEST-PASS | dom/smil/test/test_smilConditionalProcessing.html | a has unresolved start time with failing conditional processing test
[task 2019-05-16T20:16:42.102Z] 20:16:42 INFO - 1372 INFO TEST-PASS | dom/smil/test/test_smilConditionalProcessing.html | a is not in effect with failing conditional processing test
[task 2019-05-16T20:16:42.102Z] 20:16:42 INFO - 1373 INFO TEST-PASS | dom/smil/test/test_smilConditionalProcessing.html | b has unresolved start time with failing conditional processing test on a
[task 2019-05-16T20:16:42.102Z] 20:16:42 INFO - 1374 INFO TEST-PASS | dom/smil/test/test_smilConditionalProcessing.html | a has resolved start time after removing test
[task 2019-05-16T20:16:42.103Z] 20:16:42 INFO - 1375 INFO TEST-PASS | dom/smil/test/test_smilConditionalProcessing.html | a is in effect after removing test
[task 2019-05-16T20:16:42.103Z] 20:16:42 INFO - 1376 INFO TEST-PASS | dom/smil/test/test_smilConditionalProcessing.html | b has resolved start time after removing test on a
[task 2019-05-16T20:16:42.103Z] 20:16:42 INFO - 1377 INFO TEST-PASS | dom/smil/test/test_smilConditionalProcessing.html | a does not dispatch end events with failing condition processing test
[task 2019-05-16T20:16:42.103Z] 20:16:42 INFO - 1378 INFO TEST-PASS | dom/smil/test/test_smilConditionalProcessing.html | b is not in effect with failing conditional processing test on a
[task 2019-05-16T20:16:42.103Z] 20:16:42 INFO - Buffered messages finished
[task 2019-05-16T20:16:42.103Z] 20:16:42 INFO - 1379 INFO TEST-UNEXPECTED-FAIL | dom/smil/test/test_smilConditionalProcessing.html | b is in effect with passing conditional processing test on a - got +0, expected 100
[task 2019-05-16T20:16:42.104Z] 20:16:42 INFO - SimpleTest.is@SimpleTest/SimpleTest.js:320:16
[task 2019-05-16T20:16:42.104Z] 20:16:42 INFO - @dom/smil/test/test_smilConditionalProcessing.html:64:1
[task 2019-05-16T20:16:42.104Z] 20:16:42 INFO - 1380 INFO TEST-OK | dom/smil/test/test_smilConditionalProcessing.html | took 150ms

Updated

Last month
Regressed by: 1543823

It seems unlikely that Accept-Language header bug 1543823 would break a SMIL test.

Whiteboard: [geckoview:p5]?
Assignee

Comment 2

Last month

It seems unlikely that Accept-Language header bug 1543823 would break a SMIL test.

This SMIL test is special, because it tests the systemLanguage SVG attribute, which seems to be related.

The failing check essentially assumes en is one of the accepted language, the failure indicates en is no longer an accepted language.

Does the change in Bug 1543823 have impact on intl.accept_languages somehow?

I think this SMIL test isn't quite correct anyway, because it should've set the language setting intl.accept_languages at the beginning.

Comment hidden (Intermittent Failures Robot)

(In reply to violet.bugreport from comment #2)

This SMIL test is special, because it tests the systemLanguage SVG attribute, which seems to be related.

The failing check essentially assumes en is one of the accepted language, the failure indicates en is no longer an accepted language.

Oh! In that case, this is definitely not a P5.

Matt, this test failure is a regression from your Accept-Language fix.

Does the change in Bug 1543823 have impact on intl.accept_languages somehow?

I think this SMIL test isn't quite correct anyway, because it should've set the language setting intl.accept_languages at the beginning.

Yes. The fix for bug 1543823 does set intl.accept_languages.

Flags: needinfo?(mbrubeck)
OS: Unspecified → Android
Priority: P5 → P1
Whiteboard: [geckoview:p5]? → [geckoview:fenix:m6]
Assignee

Comment 5

Last month

Yes. The fix for bug 1543823 does set intl.accept_languages.

To clarify, before this change, en is always an entry in intl.accept_languages by default in our testing environment. After the change, en is no longer an entry by default in Android 7.0 x86-64.

This change looks strange to me since en is recommended to be included per https://searchfox.org/mozilla-central/source/toolkit/locales/en-US/chrome/global/intl.properties#13. But I'm not particularly familiar with locale stuff.

Do you know if this behavior change is intended? If it is intended, we can modify the testcase by setting:

SpecialPowers.pushPrefEnv({"set": [["intl.accept_languages", "en"]]}, runInternal);

at beginning to get rid of the failures.

Flags: needinfo?(cpeterson)
Comment hidden (Intermittent Failures Robot)
Whiteboard: [geckoview:fenix:m6][stockwell disable-recommended] → [geckoview:fenix:m6][stockwell needswork:owner]
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Whiteboard: [geckoview:fenix:m6][stockwell disable-recommended] → [geckoview:fenix:m6][stockwell needswork:owner]
Comment hidden (Intermittent Failures Robot)

There are in 510 total failures the last 7 days on android-em-7-0-x86_64 android and debug.

Retrigger range: https://treeherder.mozilla.org/#/jobs?repo=autoland&searchStr=android%2C7.0%2Cx86-64%2Cdebug%2Cmochitests%2Ctest-android-em-7.0-x86_64%2Fdebug-mochitest-e10s-2%2Cm%282%29&tochange=45917510825962e52348c2d3abc18ae84d2ae6ee&fromchange=3200f7d369342c9c42dce3088211631deb0f52fb&selectedJob=246881376

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=247491788&repo=autoland&lineNumber=4202

[task 2019-05-21T06:32:39.460Z] 06:32:39 INFO - 1749 INFO TEST-START | dom/smil/test/test_smilConditionalProcessing.html
[task 2019-05-21T06:32:39.460Z] 06:32:39 INFO - Buffered messages logged at 06:32:31
[task 2019-05-21T06:32:39.460Z] 06:32:39 INFO - 1750 INFO TEST-PASS | dom/smil/test/test_smilConditionalProcessing.html | a has resolved start time at start
[task 2019-05-21T06:32:39.460Z] 06:32:39 INFO - 1751 INFO TEST-PASS | dom/smil/test/test_smilConditionalProcessing.html | a is in effect at start
[task 2019-05-21T06:32:39.460Z] 06:32:39 INFO - 1752 INFO TEST-PASS | dom/smil/test/test_smilConditionalProcessing.html | b has resolved start time at start
[task 2019-05-21T06:32:39.460Z] 06:32:39 INFO - 1753 INFO TEST-PASS | dom/smil/test/test_smilConditionalProcessing.html | a has unresolved start time with failing conditional processing test
[task 2019-05-21T06:32:39.460Z] 06:32:39 INFO - 1754 INFO TEST-PASS | dom/smil/test/test_smilConditionalProcessing.html | a is not in effect with failing conditional processing test
[task 2019-05-21T06:32:39.461Z] 06:32:39 INFO - 1755 INFO TEST-PASS | dom/smil/test/test_smilConditionalProcessing.html | b has unresolved start time with failing conditional processing test on a
[task 2019-05-21T06:32:39.461Z] 06:32:39 INFO - 1756 INFO TEST-PASS | dom/smil/test/test_smilConditionalProcessing.html | a has resolved start time after removing test
[task 2019-05-21T06:32:39.461Z] 06:32:39 INFO - 1757 INFO TEST-PASS | dom/smil/test/test_smilConditionalProcessing.html | a is in effect after removing test
[task 2019-05-21T06:32:39.461Z] 06:32:39 INFO - 1758 INFO TEST-PASS | dom/smil/test/test_smilConditionalProcessing.html | b has resolved start time after removing test on a
[task 2019-05-21T06:32:39.461Z] 06:32:39 INFO - 1759 INFO TEST-PASS | dom/smil/test/test_smilConditionalProcessing.html | a does not dispatch end events with failing condition processing test
[task 2019-05-21T06:32:39.461Z] 06:32:39 INFO - 1760 INFO TEST-PASS | dom/smil/test/test_smilConditionalProcessing.html | b is not in effect with failing conditional processing test on a
[task 2019-05-21T06:32:39.461Z] 06:32:39 INFO - Buffered messages finished
[task 2019-05-21T06:32:39.461Z] 06:32:39 INFO - 1761 INFO TEST-UNEXPECTED-FAIL | dom/smil/test/test_smilConditionalProcessing.html | b is in effect with passing conditional processing test on a - got +0, expected 100
[task 2019-05-21T06:32:39.461Z] 06:32:39 INFO - SimpleTest.is@SimpleTest/SimpleTest.js:320:16
[task 2019-05-21T06:32:39.461Z] 06:32:39 INFO - @dom/smil/test/test_smilConditionalProcessing.html:64:1
[task 2019-05-21T06:32:39.461Z] 06:32:39 INFO - 1762 INFO TEST-OK | dom/smil/test/test_smilConditionalProcessing.html | took 40ms

Matt should we disable this until there is a fix?

Flags: needinfo?(mbrubeck)
Flags: needinfo?(mbrubeck)
Whiteboard: [geckoview:fenix:m6][stockwell disable-recommended] → [geckoview:fenix:m6][stockwell needswork:owner]
Duplicate of this bug: 1553051

Joel, can you take a look at thise?

Flags: needinfo?(jmaher)

if this hits disable-recommended we should be disabling the test and needinfo the owner, not migrating it to needswork:owner :)

Once the 'en' language is figured out the test can be re-enabled.

Flags: needinfo?(jmaher)

Bug was being worked on, reason why I migrated it.

NI Cosmin so he can disable it.

Flags: needinfo?(csabou)

Feel free to temporarily disable this test. The GV team will review this test failure at bug triage this week.

Flags: needinfo?(cpeterson)

Comment 17

26 days ago
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/622f7bf7f386
Disable dom/smil/test/test_smilConditionalProcessing.html on Android 7.0 for frequent failures. r=jmaher
Flags: needinfo?(csabou)
Keywords: leave-open
Whiteboard: [geckoview:fenix:m6][stockwell needswork:owner] → [geckoview:fenix:m6][stockwell disabled]

(In reply to Pulsebot from comment #17)

Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/622f7bf7f386
Disable dom/smil/test/test_smilConditionalProcessing.html on Android 7.0 for
frequent failures. r=jmaher

I think you'll want to disable this test in 68 Beta, too.

Whiteboard: [geckoview:fenix:m6][stockwell disabled] → [geckoview:fenix:m6][stockwell disabled][checkin-needed-beta]
Whiteboard: [geckoview:fenix:m6][stockwell disabled][checkin-needed-beta] → [geckoview:fenix:m6][stockwell disabled]
Comment hidden (Intermittent Failures Robot)

(In reply to violet.bugreport from comment #5)

Do you know if this behavior change is intended? If it is intended, we can modify the testcase by setting:

SpecialPowers.pushPrefEnv({"set": [["intl.accept_languages", "en"]]}, runInternal);

at beginning to get rid of the failures.

Yes, this looks like the right fix.

Flags: needinfo?(mbrubeck)
Assignee

Comment 23

21 days ago

The test assumes "en" is always an accepted language, it's not correct.
This assumption isn't what is being tested here anyway.
We should set language preference at the beginning before testing to avoid
irrelevant failure.

Comment 24

21 days ago
Pushed by violet.bugreport@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/f4260d7b6296
Should not assume en is always an accepted language r=birtles
Comment hidden (Intermittent Failures Robot)
Assignee: nobody → violet.bugreport
Assignee

Updated

20 days ago
Status: NEW → RESOLVED
Closed: 20 days ago
Resolution: --- → FIXED
Assignee

Updated

20 days ago
Keywords: leave-open

Violet, does this test bug affect Fennec or just GeckoView? If it affects Fennec, we should uplift the test fix to 68 Beta.

Flags: needinfo?(violet.bugreport)
Assignee

Comment 28

19 days ago

It only affects "android-em-7-0-x86_64", I don't know which one it belongs to.

Flags: needinfo?(violet.bugreport)

(In reply to violet.bugreport from comment #28)

It only affects "android-em-7-0-x86_64", I don't know which one it belongs to.

Thanks. In that case, I don't think we need to uplift. That test machine is used just for GeckoView tests, not Fennec.

Target Milestone: --- → mozilla69
You need to log in before you can comment on or make changes to this bug.