Closed Bug 1552389 Opened 8 months ago Closed 6 months ago

Port bug 1551738 - Add in-tree support for comm-esr68

Categories

(Thunderbird :: Build Config, task, critical)

task
Not set
critical

Tracking

(thunderbird_esr6868+ fixed, thunderbird68 fixed, thunderbird69 fixed)

RESOLVED FIXED
Thunderbird 69.0
Tracking Status
thunderbird_esr68 68+ fixed
thunderbird68 --- fixed
thunderbird69 --- fixed

People

(Reporter: rjl, Assigned: rjl)

References

Details

Attachments

(5 files, 3 obsolete files)

No description provided.
Attached patch 36292.patch (obsolete) — Splinter Review
Assignee: nobody → rob
Attachment #9065588 - Flags: review?(geoff)
Attachment #9065588 - Flags: review?(geoff) → review+
Attached patch comm-unified_36315.patch (obsolete) — Splinter Review

No changes, fixed commit message.

Attachment #9065588 - Attachment is obsolete: true
Attachment #9065801 - Flags: review?(geoff)
Attachment #9065802 - Flags: review?(geoff)
Comment on attachment 9065801 [details] [diff] [review]
comm-unified_36315.patch

Same patch, so you can really set the r+ yourself. We trust you :-)
Attachment #9065801 - Flags: review?(geoff) → review+
Comment on attachment 9065802 [details] [diff] [review]
comm-unified_36317.patch

Looks OK to me.
Attachment #9065802 - Flags: review?(geoff) → review+

Actually, is there a reason for this being so inconsistent. You have these variations:

comm-esr(60|68)
comm-(beta|esr.*)
comm-(beta|esr60|esr68)

To find this stuff easily, I'd suggest to make it one of these two:

comm-esr.*
comm-(beta|esr.*)

or

comm-(esr60|esr68)
comm-(beta|esr60|esr68)
Comment on attachment 9065801 [details] [diff] [review]
comm-unified_36315.patch

Review of attachment 9065801 [details] [diff] [review]:
-----------------------------------------------------------------

::: taskcluster/ci/repo-update/kind.yml
@@ +19,1 @@
>                      comm-beta: "1"

Can beta be merged with esr here?
Attached patch 36378.patchSplinter Review

Fixed up the pattern matching to use esr60|esr68

Attachment #9065801 - Attachment is obsolete: true
Attachment #9066520 - Flags: review?(jorgk)
Comment on attachment 9066520 [details] [diff] [review]
36378.patch

That's nicer, don't you think? I'll land it with the other batch tonight.
Attachment #9066520 - Flags: review?(jorgk) → review+

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/961f2ce1e0e7
Port bug 1551738: Add in-tree support for esr68. r=darktrojan,jorgk
https://hg.mozilla.org/comm-central/rev/df9479faea45
Port bug 1551738: Add esr68 support to bouncer tasks. r=darktrojan

Keywords: checkin-needed
Target Milestone: Thunderbird 68.0 → Thunderbird 69.0
Comment on attachment 9065802 [details] [diff] [review]
comm-unified_36317.patch

I guess this needs to go onto beta to end up in ESR68.
Attachment #9065802 - Flags: approval-comm-beta+
Attached patch esr68_part3.patch (obsolete) — Splinter Review
For review only.
I'd like to find out the answer to the question of bz2 MAR files
before landing this if possible.
Attachment #9072916 - Flags: review?(geoff)
Comment on attachment 9072916 [details] [diff] [review]
esr68_part3.patch

Review of attachment 9072916 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry about the delay. This is fine by me.
Attachment #9072916 - Flags: review?(geoff) → review+
Updated patch, I had missed the beetmover artifact_map changes.

Verified fix by generating a full taskgraph locally and checking
where the various artifacts get Beetmoved to.
Comment on attachment 9072916 [details] [diff] [review]
esr68_part3.patch

Superseded by esr68_part3_version2.patch
Attachment #9072916 - Attachment is obsolete: true
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/ff3f3dc92e3a
Port bug 1551738: Complete ESR68 support in CI. r=darktrojan

The last patch didn't apply to trunk:
1 out of 1 hunks FAILED -- saving rejects to file taskcluster/ci/beetmover-checksums/kind.yml.rej
1 out of 1 hunks FAILED -- saving rejects to file taskcluster/ci/beetmover-repackage/kind.yml.rej
Those changes were already in the files. Most likely it will apply to beta.

Status: NEW → RESOLVED
Closed: 7 months ago
Keywords: leave-open
Resolution: --- → FIXED
There were some things that needed cleanup for the sake of
consistency. No functional changes.
Attachment #9073425 - Flags: review?(geoff)
Comment on attachment 9073425 [details] [diff] [review]
regex_cleanup.patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Testing completed (on c-c, etc.): 
Risk to taking this patch (and alternatives if risky):
None. This should apply cleanly to beta and there are no functional changes.
I am requesting two other uplifts to go with this one, after which our Taskcluster configurations will be mostly in sync between comm-central and comm-beta.
Attachment #9073425 - Flags: approval-comm-beta?
Attachment #9073425 - Flags: review?(geoff) → review+
Attachment #9073425 - Flags: approval-comm-beta? → approval-comm-beta+

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/384e0fef96b7
Follow up: Remove esr release references and use consistent regex style. r=darktrojan DONTBUILD

Keywords: checkin-needed

Some changes to non-Thunderbird repositories on Github are necessary. I'm going to reference them in this bug to make them easier to find.

Scriptworker:
https://github.com/mozilla-releng/scriptworker/pull/364

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Tom, jlund suggested that you would be best to review that scriptworker pull request.

Flags: needinfo?(mozilla)

(In reply to Rob Lemley [:rjl] from comment #25)

Scriptworker:
https://github.com/mozilla-releng/scriptworker/pull/364

This should be deployed.

Flags: needinfo?(mozilla)
Severity: major → critical
Type: defect → task
These are the Balrog rules that get updated during the release
process. New rules are necessary due to the overlap between
the release of 68.0 and 60.9.
Attachment #9078825 - Flags: review?(geoff)
Comment on attachment 9078825 [details] [diff] [review]
balrog_rules_esr68.patch

[Approval Request Comment]
Regression caused by (bug #): N/A
User impact if declined: The automatic update process for 68.0, 60.9 and anything in between will be adversely affected.
Testing completed (on c-c, etc.): no
Risk to taking this patch (and alternatives if risky):
Minimal/no risk. This needs to be uplifted or the release process will try to update the same rule for both 68 and 60 releases, and that could cause things like a downgrade from 68.0 to 60.9.
Attachment #9078825 - Flags: approval-comm-esr68?
Attachment #9078825 - Flags: approval-comm-beta?
Comment on attachment 9078825 [details] [diff] [review]
balrog_rules_esr68.patch

Review of attachment 9078825 [details] [diff] [review]:
-----------------------------------------------------------------

Should this be in somebody's list of tasks to do as we prepare for a new ESR?
Attachment #9078825 - Flags: review?(geoff) → review+

(In reply to Geoff Lankow (:darktrojan) from comment #30)

Should this be in somebody's list of tasks to do as we prepare for a new ESR?

Yes it should. Thanks for reminding me.

Keywords: checkin-needed

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/eda28203dc5f
Set Balrog rules to update for esr68. r=darktrojan

Status: REOPENED → RESOLVED
Closed: 7 months ago6 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
Attachment #9078825 - Flags: approval-comm-esr68?
Attachment #9078825 - Flags: approval-comm-esr68+
Attachment #9078825 - Flags: approval-comm-beta?
Attachment #9078825 - Flags: approval-comm-beta+
See Also: → 1572836
You need to log in before you can comment on or make changes to this bug.