Closed Bug 1552629 Opened 1 year ago Closed 1 year ago

'Edit and Resend' button is misaligned if there is no 'Referrer Policy' header

Categories

(DevTools :: Netmonitor, defect, P3)

67 Branch
defect

Tracking

(firefox69 verified)

VERIFIED FIXED
Firefox 69
Tracking Status
firefox69 --- verified

People

(Reporter: tanhengyeow, Assigned: vi.le)

Details

(Keywords: good-first-bug)

Attachments

(3 files)

Attached image intended.jpg

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.157 Safari/537.36

Steps to reproduce:

  1. Check out requests with no 'Referrer Policy' header. E.g. Requests from this site.

Actual results:

The 'Edit and Resend' button is placed in an odd position (Refer to results.jpg).

Expected results:

The 'Edit and Resend' button should be flushed to the right at the original width (Refer to intended.jpg).

Attached image results.jpg

Thanks for the report Heng Yeow! I can reproduce this on my machine.

Honza

Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: good-first-bug
Priority: -- → P3

Hi, can I take this one? :-) I think the problem lies here because summaryEditAndResendBtn is linked to summaryReferrerPolicy.

Flags: needinfo?(odvarko)

Assigned to you, thanks for helping with this bug!
Honza

Flags: needinfo?(odvarko)
Assignee: nobody → vi.le
Status: NEW → ASSIGNED

If the "Referrer Policy" header is missing, summaryReferrerPolicy is null,
so summaryEditAndResendBtn contains only the "Edit and Resend" button, making it
misaligned. We fix this by making sure summaryEditAndResendBtn always contains
the last non-null header.

Pushed by jodvarko@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9341602d655c
Fix misaligned "Edit and Resend" button in the netmonitor Headers panel;r=Honza
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69
QA Whiteboard: [qa-69b-p2]

Verified with 69.0 with Windows 10, macOS 10.13, Ubuntu 16.04.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.