Running marAppApply* xpcshell tests fail locally

RESOLVED FIXED in Firefox 68

Status

()

defect
P3
normal
RESOLVED FIXED
Last month
5 days ago

People

(Reporter: rstrong, Assigned: rstrong)

Tracking

({regression})

68 Branch
mozilla69
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox66 unaffected, firefox67 unaffected, firefox67.0.5 unaffected, firefox68 fixed, firefox69 fixed)

Details

Attachments

(1 attachment)

I've been having intermittent problems running the marAppApply* xpcshell tests locally since the profile changes landed. It turns out that it was trying to show the profile manager. Specifying the path to an empty profile fixes it for me. Patch coming up.

I think this might be due to having a stray MOZILLA_OFFICIAL in one of my included mozconfigs and the recent e10s changes where e10s can only be disabled locally in non MOZILLA_OFFICIAL builds.

(In reply to Robert Strong (Robert they/them) [:rstrong] (use needinfo to contact me) from comment #1)

I think this might be due to having a stray MOZILLA_OFFICIAL in one of my included mozconfigs and the recent e10s changes where e10s can only be disabled locally in non MOZILLA_OFFICIAL builds.

This didn't fix it. :(

Specify a profile when running marAppApply* xpcshell tests to prevent the application from trying to display the profile manager
Don't unset LD_LIBRARY_PATH when running the tests on Linux so startup dependencies can be found

Summary: Running marAppApply* xpcshell tests fail locally without specifying a profile path → Running marAppApply* xpcshell tests fail locally

Comment 4

28 days ago
Pushed by rstrong@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2adbd9cb0977
(xpcshell test only) - Fix app update xpcshell tests so it is possible to run them locally. r=bytesized

Comment 5

27 days ago
bugherder
Status: ASSIGNED → RESOLVED
Closed: 27 days ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
You need to log in before you can comment on or make changes to this bug.