Closed Bug 1552669 Opened 2 years ago Closed 2 years ago

Perma win shippable tier2 raptor-main TEST-UNEXPECTED-FAIL: no raptor test results were found for raptor-wasm-godot-chromium

Categories

(Testing :: Raptor, defect, P5)

Version 3
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1552812

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Regression)

Details

(Keywords: intermittent-failure, regression)

Filed by: apavel [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=247226614&repo=mozilla-central
Full log: https://queue.taskcluster.net/v1/task/Q0ufb-WmTciAPmu6QDxuRQ/runs/0/artifacts/public/logs/live_backing.log


00:18:47 INFO - raptor-main starting chromium
00:18:47 INFO - Application command: C:\Users\task_1558222496\fetches\chrome-win\Chrome.exe --user-data-dir=c:\users\task_1558222496\appdata\local\temp\tmpyfpz7o.mozrunner --profile-directory=Default --no-first-run --use-mock-keychain --no-default-browser-check --load-extension=C:\Users\task_1558222496\build\tests\raptor\raptor..\webext\raptor
00:18:48 INFO - raptor-control-server reading test settings from raptor-wasm-godot-chromium.json
00:18:48 INFO - raptor-control-server received webext_status: raptor runner.js is loaded!
00:18:48 INFO - raptor-control-server sent test settings to web ext runner
00:18:48 INFO - raptor-control-server received webext_status: * pausing 30 seconds to let browser settle... *
00:19:18 INFO - raptor-control-server received webext_status: running 5 pagecycles of http://localhost:49772/wasm-godot/index.html
00:19:18 INFO - raptor-control-server received webext_status: opened new empty tab: 3
00:19:19 INFO - raptor-control-server received webext_status: begin pagecycle 1
00:19:19 INFO - raptor-control-server received webext_status: closing Tab: 3
00:19:19 INFO - raptor-control-server received webext_status: Open new tab
00:19:19 INFO - raptor-control-server received webext_status: Removed tab: 3
00:19:19 INFO - raptor-control-server received webext_status: opened new empty tab: 5
00:19:20 INFO - raptor-control-server received webext_status: update tab: 5
00:19:20 INFO - raptor-control-server received webext_status: test tab updated: 5
00:21:19 INFO - raptor-control-server received webext_raptor-page-timeout: [u'raptor-wasm-godot-chromium', u'http://localhost:49772/wasm-godot/index.html']
00:21:53 INFO - raptor-control-server received webext_screenshot
00:21:53 INFO - results-handler received screenshot
00:21:53 INFO - raptor-control-server received webext_status: __raptor_shutdownBrowser
00:21:53 INFO - raptor-control-server received webext_status: Removed tab: 5
00:21:53 INFO - raptor-control-server shutting down browser (pid: 6420)
00:22:09 INFO - raptor-main removing webext C:\Users\task_1558222496\build\tests\raptor\raptor..\webext\raptor
00:22:09 INFO - results-handler summarizing raptor test results
00:22:09 INFO - raptor-output error: no raptor test results found for raptor-wasm-godot-chromium
00:22:09 INFO - raptor-output error: no raptor test results found, so no need to combine browser cycles
00:22:09 INFO - raptor-output error: no summarized raptor results found for raptor-wasm-godot-chromium
00:22:09 INFO - raptor-output screen captures can be found locally at: C:\Users\task_1558222496\build\screenshots.html
00:22:09 INFO - raptor-control-server shutting down control server
00:22:10 INFO - raptor-main finished
00:22:10 INFO - raptor-main TEST-UNEXPECTED-FAIL: no raptor test results were found for raptor-wasm-godot-chromium
00:22:10 ERROR - Return code: 1
00:22:10 WARNING - setting return code to 1
00:22:10 CRITICAL - PERFHERDER_DATA was seen 0 times, expected 1.

I don't think bug 1552548 could have caused this since it only runs on power tests and none of these failures are from a power test.

I noticed that the failures are all on chromium though and that the chromium binary used was updated between the previous mozilla-central push, and the one which started the failures.

For the previous push, the following binary was used: https://queue.taskcluster.net/v1/task/WG9mRadFTeeASqW8yhMA-g/artifacts/public/chromium-win32.tar.bz2

The push which has these failures uses the binary: https://queue.taskcluster.net/v1/task/fa_xM7K-TiWu5IDRECByMQ/artifacts/public/chromium-win32.tar.bz2

:rwood, would you have any ideas? I am wondering if this is related to the api-keys error we've seen on other platforms since I see that the binaries have a "API keys missing" message when I run them locally.

Flags: needinfo?(gmierz2) → needinfo?(rwood)

Joel can you take a look at this?

Flags: needinfo?(jmaher)

redirecting to bug 1552812

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(rwood)
Flags: needinfo?(jmaher)
Resolution: --- → DUPLICATE
Duplicate of bug: 1552812
See Also: → 1553038

(In reply to Greg Mierzwinski [:sparky] from comment #3)

:rwood, would you have any ideas? I am wondering if this is related to the api-keys error we've seen on other platforms since I see that the binaries have a "API keys missing" message when I run them locally.

See bug 1552812; looks like Chromium update broke things. Not much we can do; let it ride for a bit and see if Chromium has a fix soon that resolves it.

You need to log in before you can comment on or make changes to this bug.