Closed Bug 1552787 Opened 1 year ago Closed 1 year ago

Log a more verbose error message in the console when a abuse report fails for a client or server submission error

Categories

(Toolkit :: Add-ons Manager, task, P2)

68 Branch
task

Tracking

()

VERIFIED FIXED
mozilla69
Tracking Status
firefox68 --- verified
firefox69 --- verified

People

(Reporter: rpl, Assigned: rpl)

References

Details

Attachments

(3 files)

To make it easier to investigate issues related to "report submit" errors the AbuseReport's submit method should log a more verbose error message in the browser console.

Assignee: nobody → lgreco
Blocks: 1540175
Status: NEW → ASSIGNED
Priority: -- → P2
Depends on: 1552799
Pushed by luca.greco@alcacoop.it:
https://hg.mozilla.org/integration/autoland/rev/412b2751c79a
Log a more verbose error message in the console when a abuse report fails for a client or server submission error. r=mixedpuppy
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Marking as qe-verify-, this change is tested as part of the automated tests.

Flags: qe-verify-

Is this something which should be considered for Beta uplift or can it ride the trains?

Flags: needinfo?(lgreco)

Verified as fixed in latest FF Nightly, Windows 10x64 and macOS 10.14.5

Please see post fix screenshot attached.

Status: RESOLVED → VERIFIED
Attached image Postfix Screenshot

(In reply to Ryan VanderMeulen [:RyanVM] from comment #6)

Is this something which should be considered for Beta uplift or can it ride the trains?

It wouldn't be strictly necessary, but it has been helpful to investigate the reasons behind reports that the API endpoint rejects, and so it would be nice to have it.

I initially marked this as qe-verify- as it is tested in automation and it doesn't fix any particular issue for a user, but QA used the verbose error recently and so I asked them to verify this bug explicitly.

Flags: needinfo?(lgreco)

Comment on attachment 9067986 [details]
Bug 1552787 - Log a more verbose error message in the console when a abuse report fails for a client or server submission error. r?mixedpuppy!

Beta/Release Uplift Approval Request

  • User impact if declined: No visible impact (but it makes easier to provide useful details if a user is not able to report an abuse for a particular extension and wants to report the issue to us on bugzilla).
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Not strictly necessary to verify manually, as it is tested in automation, but QA can also verify it on beta, e.g. by changing the abuse report url from about:config ("extensions.abuseReport.url") to point it to a fake API endpoint that always returns an HTTP error on any report submission.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The change shouldn't be risky as it is restricted to the abuse report error reporting and tested in automation.
  • String changes made/needed:
Attachment #9067986 - Flags: approval-mozilla-beta?
Flags: qe-verify- → qe-verify+
QA Whiteboard: [qa-triaged]

Comment on attachment 9067986 [details]
Bug 1552787 - Log a more verbose error message in the console when a abuse report fails for a client or server submission error. r?mixedpuppy!

debugging help for addon abuse report errors, approved for 68.0b10

Attachment #9067986 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Verified as fixed in 68.0b12 .

I will attach a postfix screenshot

You need to log in before you can comment on or make changes to this bug.