Closed Bug 1552790 Opened 5 years ago Closed 3 years ago

Right click menu on dark background has white separators unlike Safari

Categories

(Core :: Widget: Cocoa, defect, P3)

68 Branch
Desktop
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 34572

People

(Reporter: sheelgautam995, Unassigned)

References

()

Details

(Keywords: parity-safari)

Attachments

(4 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:68.0) Gecko/20100101 Firefox/68.0

Actual results:

Right click menu in Firefox has weird white separators instead of normal dark separators in Safari. This issue only happens when the menu is summoned on pages with dark background. Take a look at the attached screenshots.

Attached image Firefox.png
Attached image Safari.png
Component: Untriaged → Menus
Keywords: parity-safari
OS: Unspecified → macOS
Hardware: Unspecified → Desktop
Summary: Right click menu on dark background looks weird as compared to Safari → Right click menu on dark background has white separators unlike Safari

This is an issue with our native widget implementation on mac, so moving there.

Component: Menus → Widget: Cocoa
Product: Firefox → Core

Hm, note that I actually can't reproduce on macOS 10.13 .

Are you using dark mode in mojave? Can you attach a copy of your about:support information (help > troubleshooting information, then click 'copy raw data to clipboard', then attach to this bug at https://bugzilla.mozilla.org/attachment.cgi?bugid=1552790&action=enter )

Flags: needinfo?(sheelgautam995)

I am not using dark mode.

Flags: needinfo?(sheelgautam995)
Attached image Firefox2.png

See how white separators only show on dark background but not on white. Looks like some transparency bug.

This is indeed an issue on 10.14 only. I'm unable to reproduce on 10.13.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Severity: normal → S3

This is fixed. Please mark the bug as fixed.

Fixed by bug 34572.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: