Closed Bug 1552799 Opened 1 year ago Closed 1 year ago

[about:addons] Hide abuse report report action on system and builtin addons

Categories

(Toolkit :: Add-ons Manager, defect, P3)

68 Branch
defect

Tracking

()

VERIFIED FIXED
mozilla69
Tracking Status
firefox68 --- verified
firefox69 --- verified

People

(Reporter: vcarciu, Assigned: rpl)

References

Details

Attachments

(4 files)

Attached image defaultthemereport.gif

Windows 10x64, FF 68.0a1 (2019-05-19) (64-bit)

Steps to reproduce:
1.In about:addons, try to abuse report a default theme

Expected results:
1.A helpful message should be displayed, saying that default themes cannot be reported

or

2.We can totally hide the abuse reporting for default themes

Actual results:
"There was an error sending the report for <<default theme name>>." is displayed

NOTES:
Please see the attached video

Assignee: nobody → lgreco
Status: NEW → ASSIGNED
Priority: -- → P3
Pushed by luca.greco@alcacoop.it:
https://hg.mozilla.org/integration/autoland/rev/7c6cc79b65dd
Hide report action on system and builtin addons. r=mstriemer
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Summary: The error message when reporting a default firefox theme is not helpful → [about:addons] Hide abuse report report action on system and builtin addons

Verfied as fixed on Windows 10x64 and macOS 10.13.6 using FF Nightly, buildid 20190610093815.

I will attach a postfix video.

Status: RESOLVED → VERIFIED
Attached image Postfix video

Comment on attachment 9067622 [details]
Bug 1552799 - Hide report action on system and builtin addons. r?mstriemer!

Beta/Release Uplift Approval Request

  • User impact if declined: The HTML about:addons page will show a report action for builtin and system addons (if they are visible in about:addons, like the default themes).
    Trying to report an abuse of a system or builtin addon will not complete successfully, because the AMO API endpoint does not accept the submitted report and and a generic "report submission error" will be shown to a user.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Same STR used to verify it on Nightly (as described in the comment 0 from this issue)
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The change is small (a single line change, only applied to the abuse report action included in the HTML about:addons), and it is covered by additional automated tests (which are actually the biggest part of the patch itself).
  • String changes made/needed:
Attachment #9067622 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Blocks: 1540175
QA Whiteboard: [qa-triaged]

Comment on attachment 9067622 [details]
Bug 1552799 - Hide report action on system and builtin addons. r?mstriemer!

fix for html about:addons, approved for 68.0b10

Attachment #9067622 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Verified as fixed in FF Beta 68.0b10 (64-bit) on Win10x64 and macOS 10.15.4

Please see postfix video attached.

Attached image Postfix video
You need to log in before you can comment on or make changes to this bug.