Status

Camino Graveyard
Tabbed Browsing
--
enhancement
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: Warren TenBrook, Assigned: Simon Fraser)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Chimera 2002070105 does not have a widget to close a browser tab.

Expected Result:  Tab bar should contain an "X" widget to close the active tab,
or the Toolbar should have an optional "X-Tab" icon button with a popup tab list
to select the tab to close, and the 'Stop' button an octagon to differentiate it
from the 'X' close widget.

Actual Result: User has no tab close widget and must wade through the Window
menu or cmd-y to close tab.

Also see open chimera.mozdev.org boogs 1101, 1282, 1339

Comment 1

16 years ago
Custom widgets would really stink, and they would add clutter, too. I suggest
trapping context clicks (control-clicks, right-clicks) on the tabs and allowing
the user to close a tab from a context menu. The menu could contain the
following items, and maybe a few others:

- Close tab
- Open in New Tab (ie. nab the current tab's location, spawn a new tab and point
it at the previous tab's location)
- Open Tab in New Window (or, a command for removing the tab from the tab bar
and into a new window)
- Add Page to Bookmarks
(Reporter)

Comment 2

16 years ago
Since we have a File...Close Tab menu, a context menu would seem to add more
complexity.  Perhaps a context menu could be added to the mounting RFE Bugs That
Would Not Die.

The Mozdev lists had a ton of comments like "Help! How do you close the tabs?" 
with the reply "Please, clueless user...JUST CTL-Y." But browser tabs are
specialized windows, and windows have had close widgets for twenty years (I am
*not* suggesting each tab needs a close button!).  Users are disoriented and
slowed down if they're forced to use a menu or key combo to close a tab.

I think the argument is largely aesthetic; it's probably best to leave it for
saari, pink and sfraser to decide.

Comment 3

16 years ago
Actually, couldn't this be implemented by way of a toolbar button? That way the
"we don't want no steenkin' close tab widget" people (like me) could just
command-drag it out of the toolbar, while the others could just keep it there
and place it where ever they want to.
(Reporter)

Comment 4

16 years ago
Good suggestion; a toolbar button would do the trick.  As I suggested above, a
toolbar button popup menu could also select a background tab to close.

Comment 5

16 years ago
As others have said here, putting close widgets on every tab would be a waste of
space, probably be ugly too, and most certainly be breaking Apple's HIG. Having
said that though, I think providing users with multiple ways of doing things is
a good thing. Adding choice does not add complexity, because most of the
complexity is hidden. For example, we can add a toolbar icon (my favoured
approach), users can still use cmd-W or the item in the File menu, AND later on
we always have the option of adding contextual menu trapping on tabs, drop down
menu on the toolbar icon etc, without adding to the perceived complexity because
most of these closing methods are hidden from view until you use them (Just In
Time disclosure of information).

In any case, I think the toolbar icon is the best place to start.

Comment 6

16 years ago
Created attachment 93919 [details]
Proposed toolbar icon for Close Tab

Since people seem in favor of the Close Tab toolbar button idea originally
proposed by Reporter, here's my suggestion for the button's icon.

Comment 7

16 years ago
I'd like to see this button as well
Just add this as a toolbar button which is off by default.

Comment 9

16 years ago
I agree with the toolbar button
btw:
When I click on attachment #1 [details] [diff] [review] Chimera/2002081205 does nothing

Comment 10

16 years ago
Primary advantages of putting widget in tab bar:
(one instance, at right end, as in main mozilla trunk)
- proximity to tabs make functionality easier to intuit
- widget is only visible when there are tabs to close
- consumes very little space

Comment 11

16 years ago
I am against including this, but if we do, close widgets go at the left end!

Comment 12

16 years ago
Steve don't just give in like that.. It's like 8 to 1 so far =)

comment #10
/Primary advantages of putting widget in tab bar:
/(one instance, at right end, as in main mozilla trunk)
/- proximity to tabs make functionality easier to intuit
     A toolbar icon would be just as close... and larger even
     Plus if you think the button works better from the left... cmd-drag to the
left of the toolbar... to the right... middle... etc...
/- widget is only visible when there are tabs to close
     button would enabled/disabled
/- consumes very little space
     ditto with a toolbar button

Adding a widget just isn't a good idea. If someone want a button to close a tab
it will be there, if not they can cmd-drag it away. With the widget it's always
there in a static place... can't cmd-drag it around
Component: Toolbars & Menus → Tabbed Browsing
QA Contact: winnie → sairuh
also see bug 160566 for adding a new tab button.

Comment 14

16 years ago
What do people think of the new/close tab icons in the latest Pinstripe theme
for Mozilla? I think they're good.
i think the close icon we want to use would be the circular, gray, (x) icon that
project builder uses to close split frames and the finder uses to clear a text
field in shaguar. that seems to be the "close widget" apple is pushing inside
windows, though they haven't yet said anything along those lines.
(Reporter)

Comment 16

16 years ago
Pink or Greg's icon suggestions are fine, but beware using the "X" symbol for
two purposes: 'Close' vs 'Stop'

Suggest 'Stop' icon be redone as stop-sign octagon and dedicate 'X' icon to
'Close' functions per my original report.

Comment 17

16 years ago
Currently dragging a tab into the browser has no effect.  Perhaps this could
close a tab with a dock-like poof.

Comment 18

16 years ago
*** Bug 168676 has been marked as a duplicate of this bug. ***

Comment 19

16 years ago
I agree with #15. The gray buttons are sufficiently unintrusive. I think New Tab
could be implemented with a similar circular control. The icons for these
buttons need to be self-explanatory, though. Mozilla had problems with users not
understanding the new tab/close tab buttons. Close should be the X icon, but
what should the New button's icon be? A starburst? A small document icon?

And where would these reside? On the left side of the tab bar when the tab bar
is visible? Or on the right? Or somewhere else?

Comment 20

16 years ago
I like the sound of a Finder-search-field-(x) close widget on the right-hand
side of the tab (as they do in the Finder, iTunes etc), no new tab widget needed

Comment 21

16 years ago
Well in any case, there needs to be _something_. Currently, you can't close a
tab with the mouse at all (Oct 5 2002). You must either command-W, or choose a
command from the main menu. 

Context menu. Pros: less clutter, works for people used to mozilla.
Cons: Contextual menus are hidden, so putting critical features there is bad for
useability. 2. Contextual menus suck if you don't have a > 1 button mouse.

Close box: Pros: Easy, intuitive.
Cons: More visual clutter; box takes aways space used to name the tab.

I think a close box would be preferable, but I'll take a contextual menu over
nothing.

Comment 22

16 years ago
What about replacing the current globe icon with a close icon. Having the close
icon and the globe would make things too cluttered I think. There doesn't really
seem to be a good reason for the globe icon either.

Comment 23

16 years ago
> What about replacing the current globe icon with a close icon.

What globe icon? Are you referring to the icons in the tabs? For your
information, those icons change to display the site's icon if the website
provides one. Just check out Apple.com, for example. The globe changes to an
Apple. So the icons should definitely not be replaced with a close widget. Just
add a single widget to the left (or right) edge of the tab bar as suggested in
comment #15.

Comment 24

16 years ago
Yes, that is the icon I mean. It seems to me that the site icon isn't as 
important a feature as having a close widget. With the site icon/globe icon 
and a close widget in the tab there would hardly be any room for the title of 
the tab, especially when the user has lots of tabs open.

I think that usability would be degraded with the added clutter of two icons 
in a tab. The user wouldn't be able to recognize what a tab is because the 
title would be cropped off.
(Assignee)

Comment 25

16 years ago
Site icons in tabs are draggable, so have utility.

Comment 26

16 years ago
Putting a close widget in the tab itself is a bad idea. LimeWire does this, and
half the time I try to select a tab to bring it to the front, I accidently click
on the close widget and close the tab instead. This is bad interface design, IMO. 

Using toolbar icons is also a bad idea. When I'm on my ibook, I need all the
screen real estate I can get. Cluttering up my toolbar with more icons is not an
option, especially if we end up spawning toolbar icons for all of the numerous
things you should be able to do with tabs (open a new tab, close current tab,
open current tab in a new window, duplicate tab, etc.). And good luck finding
icon graphics for those functions that people will consistantly understand.

Personally, I strongly think using the context menu is the best solution. There
are a lot of things you should be able to easily do with tabs that you currently
can't. Putting all of these functions into a context menu seems like a
no-brainer to me. I would certainly be more likely to look for such functions in
the context menu than in the customize toolbar interface! And even though I only
have a 1-button mouse, I use context menus constantly in the Finder and other
web browsers like Mozilla and IE. Chimera's context menus are frustratingly
lacking in functionality.

I would suggest that even if you do decide to implement the toolbar icon idea,
you still implement the same functionality in the context menu. Plus, I would
REALLY like the ability to open the current page/tab in a new window from the
context menu. Right now, I have to copy the URL from the address bar, close the
current tab, open a new window, and paste in the URL. This is tedious. All of
these types of functions belong in the context menu. That's what it's there for.

Comment 27

16 years ago
I've thought about this some more and I'll take back #20 and agree with the
above (#26). Putting a widget, however neat, into the tab itself could be
annoying at pretty much all times except the specific moment you want to close
the tab. A CM would be enough.

Comment 28

16 years ago
Bug #161376 was opened as [RFE] Provide contextual menu support for tabs.
Summary: [RFE] Provide Tab Close Widget → Provide Tab Close Widget

Comment 29

16 years ago
After using Phoenix for OS X all day (yes, such a thing exists), I have to admit
I'm a bit warmer to the idea of having a tab-close widget in the tab bar (but
just one, not per tab). I'm still not totally sold on the idea (since it
probably violates some HIG), and I still think that such functionality should be
provided in the context menus, but I do think this is an idea that should at
least be seriously considered (which I'm sure the mozilla staff is already
doing). Anyway, just wanted to share my new-found enlightenment, as if anyone
cared :)

Comment 30

16 years ago
Where did you get Phoenix for OSX? Or is this an XDarwin thing?

Comment 31

16 years ago
Re to comment #30, Phoenix for OS X is actually a sort of a pseudo-hack. But a
good one. http://www.kmgerich.com/misc.html

Re to comment #29, does it relly matter that tab close widgets are against the
HIG when the whole document container system (tabs) is against the HIG and still
works admirably?
(Assignee)

Comment 32

16 years ago
taking
Assignee: saari → sfraser
(Assignee)

Comment 33

16 years ago
For want of a better solution (that is easily doable), we've added a Close Tab
button to the main toolbar (on the customization palette).
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
rs vrfy --see bug 180839.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.