Closed Bug 1552960 Opened 3 months ago Closed 3 months ago

Build bustage after bug 1551738: Exception: No platform matching u'thunderbird-source' nor 'default' found while determining item `s3_bucket_paths` in `s3_bucket_paths`

Categories

(Thunderbird :: Build Config, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 69.0

People

(Reporter: jorgk, Assigned: jorgk)

References

(Regression)

Details

Attachments

(4 files, 2 obsolete files)

Attached patch WIP, not working all all. (obsolete) — Splinter Review

Running the taskcluster tool locally, I get:
0:03.91 Error loading tasks for kind beetmover-source:
[snip]
Exception: No platform matching u'thunderbird-source' nor 'default' found while determining item s3_bucket_paths in s3_bucket_paths

I tried to port a few bits of bug 1551738 with no success. I'll attach a WIP.

Try runs:
https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=e6a347496e9762f8d17db9d8a3ad656e31d8f9d6
https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=e28eae60d261c508ef3ed670fbe434f325da07b2

This may also need M-C changes, perhaps here:
https://hg.mozilla.org/try/rev/d730625e539d7268b6afe838f7c5b30dcb87b448

Maybe Geoff wants to spend some time on this. Or Tom can give us a hint.

Flags: needinfo?(rob)
Flags: needinfo?(mozilla)
Flags: needinfo?(geoff)

Ported some from here: https://hg.mozilla.org/mozilla-central/rev/7144d26d331ccd17dc9c5b3a79f424fc53a0f1dc but still with "Firefox" in the config which doesn't appear to be right.

Rather than modifying m-c, the solution is to copy the artifact manifest to c-c, and change the artifact_map's to point at the c-c copies.

Flags: needinfo?(mozilla)
Attached patch pp.patch (obsolete) — Splinter Review

Thanks, Tom. This one works but needs some clean-up.

Assignee: nobody → jorgk
Attachment #9066190 - Attachment is obsolete: true
Flags: needinfo?(rob)
Flags: needinfo?(geoff)
Attached patch pp.patchSplinter Review

I'm going to land this now and then Rob can to a clean-up around the edges.

Attachment #9066207 - Attachment is obsolete: true

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/7566abd1aa2c
Port parts of bug 1551738 (rev 7144d26d331ccd17dc9c5b3a79f424fc53a0f1dc) and add artifact manifests. rs=bustage-fix

Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 69.0
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/ac1f260073e5
Follow-up: remove yaml separator --- from copied files. rs=bustage-fix DONTBUILD
Attached patch 36375.patchSplinter Review

We don't need the custom transform function anymore. Removing it will fix the validation error as the .xpi file was listed twice.

Attachment #9066474 - Flags: review?(jorgk)
Comment on attachment 9066474 [details] [diff] [review]
36375.patch

OK. Are you actually saying that all the stuff I landed was alright? Have you looked at it? Does some of it need to be removed? I just dumped all the FF files in with only some minor tweaks.
Attachment #9066474 - Flags: review?(jorgk) → review+
Keywords: checkin-needed
Attached patch 36376.patchSplinter Review

It was trying to upload checksums to an s3 bucket named "default" instead of "pub/thunderbird/nightly"

Attachment #9066483 - Flags: review?(jorgk)
Comment on attachment 9066483 [details] [diff] [review]
36376.patch

Interesting, I should really know more about that stuff.
Attachment #9066483 - Flags: review?(jorgk) → review+
Attached patch 36377.patchSplinter Review

Cleaned up the manifest files.

Attachment #9066512 - Flags: review?(jorgk)
Comment on attachment 9066512 [details] [diff] [review]
36377.patch

Thanks, I knew some of that stuff needed to be pulled out, but at 12:30 AM I didn't have the patience.
Attachment #9066512 - Flags: review?(jorgk) → review+

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/49774aa1a8ef
Follow-up: Remove custom Thunderbird Langpack transform. r=jorgk
https://hg.mozilla.org/comm-central/rev/cca897225fa9
Follow-up: Fix S3 bucket path for checksum uploads. r=jorgk
https://hg.mozilla.org/comm-central/rev/cfeeca7996f6
Follow-up: Cleanup Beetmover manifests. r=jorgk
https://hg.mozilla.org/comm-central/rev/93545cdce0cc
Follow-up: Restore yaml separator --- since it's required now. r=me DONTBUILD

Keywords: checkin-needed
Regressed by: 1567725
You need to log in before you can comment on or make changes to this bug.