Jump-to-function-definition buttons are no longer visible in the console

VERIFIED FIXED in Firefox 68

Status

defect
P2
normal
VERIFIED FIXED
Last month
25 days ago

People

(Reporter: mattheww, Assigned: jlast)

Tracking

(Regression, {regression})

unspecified
Firefox 69

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox67+ wontfix, firefox68+ verified, firefox69- verified)

Details

(Whiteboard: [qa-triaged])

Attachments

(3 attachments)

Reporter

Description

Last month

What were you doing?

I entered a function name in the console, hoping to be able to jump straight to it.

What happened?

The jump-to-function-definition button is invisible. I was still able to get to the function, but it involved a certain amount of blind clicking.

Anything else we should know?

The other locations that I know about where the icon is used, like event popups in the inspector, are fine. So are other icons in the console, like the jump-to-inspector icon on DOM nodes.

This happens on a clean profile and in both light and dark themes. I think it was caused by the CSS changes in bug 1548438: the button.jumpDefinition style no longer sets a stroke, so I think it's no longer passing anything in to the svg's context-stroke, or else whatever it passes in doesn't work for drawing a mask.

It looks like https://phabricator.services.mozilla.com/D29605#diff-change-HFIFwLkQU1vM reverted parts of https://phabricator.services.mozilla.com/D24742

ni? Logan, it doesn't seem like this was intentional – were they pulled in from github?

Flags: needinfo?(lsmyth)
Keywords: regression
Priority: -- → P2

Yep, looks like the changes should have been made in https://searchfox.org/mozilla-central/source/devtools/client/debugger/packages/devtools-reps/src/reps/reps.css#271 The files in shared are build artifacts and are overwritten on build.

Jason, you up for reverting that part of your patch and updating reps?

Flags: needinfo?(lsmyth) → needinfo?(jlaster)

67 is impacted. When this bug is fixed, we should probably uplift it.

Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → All
Regressed by: 1548438
Hardware: Unspecified → All
Assignee

Comment 4

Last month

Logan, on it.

Flags: needinfo?(jlaster)

Comment 6

Last month
Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bd089729aaea
Jump-to-function-definition buttons are no longer visible in the console. r=nchevobbe

[Tracking Requested - why for this release]: Broken CSS hides a button in Console that developers need to jump to functions definitions in the Debugger. We expect that advanced users depend on this functionality, but only occasionally.

Comment 8

Last month
bugherder
Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69
Assignee

Comment 9

Last month

re-opening so that we can uplift

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

The bug can/should remain closed for the uplifts, if it's fixed in central.

Status: REOPENED → RESOLVED
Closed: Last monthLast month
Resolution: --- → FIXED
Assignee

Comment 11

Last month
Posted patch jump-1.patchSplinter Review

Beta/Release Uplift Approval Request

  • User impact if declined: users wont see the jump-to-definition button
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): it only affects the console
  • String changes made/needed:
Attachment #9067039 - Flags: approval-mozilla-beta?

Slightly confused as this is listed as regressed by 1548438, which is only in 68, but 67 is marked as affected.

Comment on attachment 9067039 [details] [diff] [review]
jump-1.patch

devtools console css fix, approved for 68.0b5
Attachment #9067039 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
Whiteboard: [qa-triaged]

Fix verified with 68.06, 69.0a1 (2019-05-27) on Windows 10, macOS 10.13, Ubuntu 16.04.

Status: RESOLVED → VERIFIED
Flags: qe-verify+

Cristi, can you double check that 67 is affected? Thanks!

Flags: needinfo?(cristian.fogel)

67.0(20190516215225) and 67.0.1(20190529130856) are not affected.

Flags: needinfo?(cristian.fogel)
You need to log in before you can comment on or make changes to this bug.