Calendar tab doesn't always restore to the right view

RESOLVED FIXED in 7.0

Status

defect
RESOLVED FIXED
2 months ago
Last month

People

(Reporter: darktrojan, Assigned: darktrojan)

Tracking

unspecified

Details

Attachments

(1 attachment)

I usually leave my calendar tab open, and on the multi-week view. I've noticed that sometimes when I start Thunderbird the calendar tab has the week or day view.

We get the view to show (in getLastCalendarView) from the selected index of view-deck, which in turn gets it from the XUL store via the overlay loader. The overlay loader itself has special handling for <deck> elements. There's some timing issue here.

I've tried modifying getLastCalendarView to directly query the XUL store but I think even that doesn't work every time. I wonder if we should just skip the XUL store altogether and keep the most-recently-used view in a pref.

This might be more effective than I thought. In any case I think it's worth doing.

Assignee: nobody → geoff
Status: NEW → ASSIGNED
Attachment #9067253 - Flags: review?(philipp)

Related to or same as Bug 1549082?

Quite possibly related, although there's some differences.

My proposed solution failed again today, so it's not perfect but it seems more reliable than it was.

Comment on attachment 9067253 [details] [diff] [review]
1553000-last-calendar-view-1.diff

Review of attachment 9067253 [details] [diff] [review]:
-----------------------------------------------------------------

I'm fine with using a pref as well.
Attachment #9067253 - Flags: review?(philipp) → review+
Keywords: checkin-needed
Comment on attachment 9067253 [details] [diff] [review]
1553000-last-calendar-view-1.diff

Look what I forgot to set (again).
Attachment #9067253 - Flags: approval-calendar-beta?(philipp)

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/8503388a3844
Get last-used calendar view directly from the XUL store. r=philipp

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 7.1
Attachment #9067253 - Flags: approval-calendar-beta?(philipp) → approval-calendar-beta+
Duplicate of this bug: 1549082
You need to log in before you can comment on or make changes to this bug.