[remote-dbg-next] new about:debugging should be enabled only on Nightly and Dev Edition

RESOLVED FIXED in Firefox 68

Status

task
P1
normal
RESOLVED FIXED
Last month
Last month

People

(Reporter: jdescottes, Assigned: jdescottes)

Tracking

unspecified
Firefox 69
Dependency tree / graph
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox67 unaffected, firefox67.0.5 unaffected, firefox68+ fixed, firefox69 verified)

Details

(Whiteboard: [qa-triaged])

Attachments

(3 attachments)

It was decided to hold on the release of Remote Debugging until 69, but we would still like users to be able to use remote debugging in Firefox DevEdition in order to connect to Fenix/Firefox preview.

We should update the preference for the new about:debugging to be false on release and beta, true on the other channels.

Assignee

Updated

Last month
Summary: [remote-dbg-next] new about:debugging should be enabled only on Nightly, Dev Edition and Beta → [remote-dbg-next] new about:debugging should be enabled only on Nightly and Dev Edition
Assignee

Updated

Last month
Blocks: 1553042
Attachment #9066315 - Attachment description: Bug 1553028 - Disabled new about:debugging on Beta and Release channels → Bug 1553028 - Disable new about:debugging on Beta and Release channels
Assignee

Updated

Last month
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Priority: -- → P1

Comment 2

Last month
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/38a89c912778
Disable new about:debugging on Beta and Release channels r=daisuke

I believe this patch actually disables it on DevEdition as well, because it's built from mozilla-beta and so matches RELEASE_OR_BETA.

You might want "#if defined(MOZ_DEV_EDITION) || defined(NIGHTLY_BUILD)" instead

Flags: needinfo?(jdescottes)

Comment 4

Last month
bugherder
Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69
Assignee

Updated

Last month
Status: RESOLVED → REOPENED
Flags: needinfo?(jdescottes)
Resolution: FIXED → ---

Thanks for the info, I couldn't test any of that locally.

I ended up pulling from beta, grafting my patch there and checking that it was setting my pref to false but I had no idea how to test this on DevEdition. I'll submit an updated patch with your suggestion.

Comment 7

Last month
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1a57fadeb896
Fix the condition for enabling new aboutdebugging on DevEdition and Nightly r=jcristau

Comment 8

Last month
bugherder
Status: REOPENED → RESOLVED
Closed: Last monthLast month
Resolution: --- → FIXED
Assignee

Comment 9

Last month

Beta/Release Uplift Approval Request

  • User impact if declined: It was decided to hold remote debugging in DevEdition until 69, due to lack of QA resources to perform a final QA sign off in Beta 68. This patch will disable the new remote debugging on Release and Beta.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce:
  • open Firefox Beta with a new profile
  • go to about:debugging
    With the patch: the old about:debugging should be displayed, ie the sidebar should contain "Add-ons", "Tabs", "Workers"
    Without the patch: the new about:debugging is displayed, ie the sidebar should contain "Setup", "This Firefox" and the devices section with a refresh button.
  • List of other uplifts needed: Bug 1553029, Bug 1553031
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Simple preference change, beta and release will go back to what was set in 67 cycle.
  • String changes made/needed:
Attachment #9066623 - Flags: approval-mozilla-beta?
Assignee

Updated

Last month
Flags: qe-verify+
Whiteboard: [qa-triaged]

Comment 10

Last month

As confusing as this was :)) We can confirm this issue Verified as Fixed in Nightly 69 the preference in about config is TRUE which means we Have Setup, This Firefox and the refresh button as for Beta when the patch will land it should be set to False and the OLD about:debugging will be displayed. I will mark this issue Verified as Fixed in our latest Nightly build 69.0a1 (2019-05-21).

Comment on attachment 9066623 [details] [diff] [review]
bug1553028-beta.patch

looks like this uses RELEASE_OR_BETA which isn't what we want
Attachment #9066623 - Flags: approval-mozilla-beta? → approval-mozilla-beta-

Comment on attachment 9066315 [details]
Bug 1553028 - Disable new about:debugging on Beta and Release channels

the patches from central graft cleanly to beta so I'll move the approval flag here.

Attachment #9066315 - Flags: approval-mozilla-beta+
Attachment #9066447 - Flags: approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.