[remote-dbg-next] WebIDE deprecation message should only be displayed if new about:debugging is enabled

VERIFIED FIXED in Firefox 68

Status

task
P1
normal
VERIFIED FIXED
28 days ago
24 days ago

People

(Reporter: jdescottes, Assigned: jdescottes)

Tracking

(Blocks 1 bug)

unspecified
Firefox 69
Dependency tree / graph

Firefox Tracking Flags

(firefox67 unaffected, firefox67.0.5 unaffected, firefox68+ verified, firefox69 verified)

Details

(Whiteboard: [qa-triaged])

Attachments

(2 attachments)

We started showing a deprecation message for WebIDE in Firefox 68. This deprecation message has a link that opens about:debugging. However this doesn't make any sense with the old about:debugging since it doesn't have any remote debugging features.

The new about:debugging was supposed to ride the trains with 68, but it turns out Release 68 will not have the new about:debugging.

The deprecation message should only be displayed if the new about:debugging is enabled.

Assignee

Updated

28 days ago
Type: defect → task
Assignee

Updated

27 days ago
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Assignee

Comment 1

27 days ago

Rather than having a separate preference for showing the deprecation message, we should reuse the aboutdebugging new pref

Assignee

Comment 2

27 days ago

There was a last minute schedule change for remote debugging release and we will not ride the trains with Firefox 68
The deprecation schedule is therefore shifting by one release. We update the deprecation message in WebIDE here and we should
uplift this change to beta if possible. The patch was written in order to be uplifted, we can go for a simpler version if the
uplift is a no go.

Assignee

Updated

27 days ago
Priority: -- → P1

Comment 3

27 days ago
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/92a16e67af5e
Update WebIDE deprecation message to stop mentioning release 69 r=flod,daisuke

Comment 4

27 days ago
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b2b3da42e524
Show WebIDE deprecation message if the new about:debugging is enabled r=daisuke
Assignee

Updated

27 days ago
Blocks: 1553033
Assignee

Updated

27 days ago
Duplicate of this bug: 1553033

Comment 6

27 days ago
bugherder
Status: ASSIGNED → RESOLVED
Closed: 27 days ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69
Assignee

Comment 7

26 days ago

Comment on attachment 9066318 [details]
Bug 1553029 - Show WebIDE deprecation message if the new about:debugging is enabled

Beta/Release Uplift Approval Request

  • User impact if declined: It was decided to hold remote debugging in DevEdition until 69, due to lack of QA resources to perform a final QA sign off in Beta 68.
    The first patch will prevent from showing the WebIDE deprecation message when the new remote debugging is not enabled.
    The second patch updates the deprecation message (which will still be displayed in DevEdition for instance) to say WebIDE will be removed in "an upcoming release" instead of "release 69"
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: STRs for first patch:
  • open Firefox Beta with a new profile
  • open WebIDE
    With the patch: No message should be displayed
    Without the patch: A deprecation is displayed with an "Open about:debugging" button

If you want to verify this on Nightly, you can just open Firefox Nightly and then set devtools.aboutdebugging.new-enabled to false in about:config.

STRs for second patch:

  • open Firefox Nightly or DevEdition with a new profile
  • open WebIDE
    With the patch: A deprecation message should be displayed in WebIDE and should not mention a specific release number
    Without the patch: A deprecation message is displayed in WebIDE and mentions "release 69"
  • List of other uplifts needed: Bug 1553028, Bug 1553031
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): First patch is a small JS change that is already covered by automated test. Second change is a string change, but we added extra code to make sure the application would not crash in case the string was missing from language packs lagging behind.
  • String changes made/needed: Removed error_webIDEDeprecated, added error_webIDEDeprecated2 in devtools/client/locales/en-US/webide.properties
Attachment #9066318 - Flags: approval-mozilla-beta?
Assignee

Updated

26 days ago
Attachment #9066328 - Flags: approval-mozilla-beta?
Assignee

Updated

26 days ago
Flags: qe-verify+
Whiteboard: [qa-triaged]

Comment 8

26 days ago

Verified as fixed on Firefox Nightly 69.0a1 (2019-05-21) on Windows 10 x 64, Mac OS X 10.14 and on Ubuntu 18.04 x64.

Comment on attachment 9066318 [details]
Bug 1553029 - Show WebIDE deprecation message if the new about:debugging is enabled

approved for 68.0b4

Attachment #9066318 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9066328 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

woops. jumped the gun a little, sorry about that.

flod, is the string change here ok to uplift?

Flags: needinfo?(francesco.lodolo)

(In reply to Julien Cristau [:jcristau] from comment #10)

woops. jumped the gun a little, sorry about that.

flod, is the string change here ok to uplift?

Yes, it's OK this early.

Flags: needinfo?(francesco.lodolo)

Comment 13

24 days ago

Verified as fixed on Firefox 68.0b4 on Windows 10 x 64, Mac OS X 10.14 and on Ubuntu 18.04 x64.

Status: RESOLVED → VERIFIED

Updated

24 days ago
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.