Closed Bug 1553076 Opened 1 year ago Closed 1 year ago

Checksums for releases don't contain msi, stub installers, or pkg files

Categories

(Release Engineering :: General, defect)

defect
Not set
normal

Tracking

(firefox-esr60 unaffected, firefox-esr68 fixed, firefox68 fixed, firefox69 fixed, firefox70 fixed)

RESOLVED FIXED
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- fixed
firefox68 --- fixed
firefox69 --- fixed
firefox70 --- fixed

People

(Reporter: h11p5g, Assigned: nthomas)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:67.0) Gecko/20100101 Firefox/67.0

Actual results:

Cannot find checksums for .msi files on http://ftp.mozilla.org/pub/firefox/releases/67.0/ in SHA256SUMS and SHA512SUMS files.

Status: UNCONFIRMED → NEW
Component: Untriaged → General
Ever confirmed: true
Product: Firefox → Release Engineering
QA Contact: catlee
Summary: Cannot find checksums for .msi → Checksums for .msi are only available for Nightly
Version: 67 Branch → unspecified
Flags: needinfo?(mtabara)
Flags: needinfo?(bugspam.Callek)

Preliminary investigation -- they exist in the candidate directory .beet files, .... still to do: more investigation

It looks like the [.beet files] are the release equivalent of the nightly .checksum files. So those are present in both places. It looks like the generate-checksums doesn't include .msi files, so the aren't included in the summary files.

In testing adding msi files I noticed we also don't include the windows stub installers or the new mac pkgs.

Assignee: nobody → nthomas
Flags: needinfo?(mtabara)
Flags: needinfo?(bugspam.Callek)
See Also: → 1514903, MSI
Summary: Checksums for .msi are only available for Nightly → Checksums for releases don't contain msi, stub installers, or pkg files

This doesn't cover snap (eg snap/firefox-68.0.1.snap). That'd be a more involved fix because it appears the .beet is placed in snap/ instead of beetmover-checksums/, and still references target.snap.

(In reply to Nick Thomas [:nthomas] (UTC+12) from comment #6)

This doesn't cover snap (eg snap/firefox-68.0.1.snap). That'd be a more involved fix because it appears the .beet is placed in snap/ instead of beetmover-checksums/, and still references target.snap.

It'd make sense to add .snap here anyway, so when that get fixed, it will be picked up automatically.

Sure, done. Filed bug 1567337 to fix up beetmover.

See Also: → 1567337
Attachment #9079185 - Attachment description: Bug 1553076 - Checksums for releases don't contain msi, stub installer, or pkg files, r=callek → Bug 1553076 - Checksums for releases don't contain msi, stub installer, or pkg files, r=callek DONTBUILD
Pushed by nthomas@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0f2be9ede5df
Checksums for releases don't contain msi, stub installer, or pkg files, r=Callek DONTBUILD
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.