SW Start button not always working / unresponsive

RESOLVED FIXED in Firefox 69

Status

defect
P1
normal
RESOLVED FIXED
3 months ago
2 days ago

People

(Reporter: ogasidlo, Assigned: ladybenko)

Tracking

(Depends on 1 bug, Blocks 2 bugs)

unspecified
Firefox 69
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox69 fixed)

Details

(Whiteboard: foundation-work )

Attachments

(3 attachments)

When trying to re-start a stopped service worker, the start button stays unresponsive after clicking it. It seems like it is not working.

about:debugging shows the SW right after clicking the start button in the app panel as running.

As this is working in remote debugging and probably a few other issues have also been fixed there on the way, we should compare the code and see what we can migrate to the app panel.

Blocks: 1553786
Priority: -- → P3
Assignee: nobody → balbeza
Status: NEW → ASSIGNED
Priority: P3 → P1
Keywords: leave-open
Pushed by balbeza@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/be1055dc6ffe
Part 1: Share the workers-listener module between the new about debugging and application panel r=jdescottes,Ola
Duplicate of this bug: 1553786
Keywords: leave-open
Pushed by balbeza@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cd1169815137
Part 2: Disable debugging/start links if sw cannot be debugged (multie10s) r=Ola,fluent-reviewers,flod
https://hg.mozilla.org/integration/autoland/rev/45a594318918
Part 3: add test for Start worker button r=Ola
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69
Duplicate of this bug: 1467095
You need to log in before you can comment on or make changes to this bug.