Closed Bug 1553286 Opened 5 months ago Closed 5 months ago

Mark legacycall hooks as MOZ_CAN_RUN_SCRIPT

Categories

(Core :: DOM: Bindings (WebIDL), defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox68 --- fixed
firefox69 --- fixed

People

(Reporter: bzbarsky, Assigned: bzbarsky)

Details

Attachments

(1 file)

No description provided.
Summary: Mark legacycall hooks are MOZ_CAN_RUN_SCRIPT → Mark legacycall hooks as MOZ_CAN_RUN_SCRIPT
Pushed by bzbarsky@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d5ce5a80aa79
Mark legacycall hooks (and a few other binding hooks) as MOZ_CAN_RUN_SCRIPT.  r=mccr8
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Blocks: 1551282

Comment on attachment 9066529 [details]
Bug 1553286. Mark legacycall hooks (and a few other binding hooks) as MOZ_CAN_RUN_SCRIPT. r=mccr8

Beta/Release Uplift Approval Request

  • User impact if declined: Can't land the fix for bug 1551282.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This is just adding annotations to some function to make static analysis happy. There should be no runtime behavior change here.
  • String changes made/needed:
Attachment #9066529 - Flags: approval-mozilla-release?
Attachment #9066529 - Flags: approval-mozilla-beta?

Comment on attachment 9066529 [details]
Bug 1553286. Mark legacycall hooks (and a few other binding hooks) as MOZ_CAN_RUN_SCRIPT. r=mccr8

prerequisite for bug 1551282; approved for 68.0b5

Attachment #9066529 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment on attachment 9066529 [details]
Bug 1553286. Mark legacycall hooks (and a few other binding hooks) as MOZ_CAN_RUN_SCRIPT. r=mccr8

Looks like we won't need this for bug 1551282.

Attachment #9066529 - Flags: approval-mozilla-release?
No longer blocks: 1551282
You need to log in before you can comment on or make changes to this bug.