Closed Bug 1553356 Opened 3 months ago Closed 2 months ago

Intermittent devtools/client/webconsole/test/mochitest/browser_webconsole_warning_groups_filtering.js | Message includes the expected "Navigated to" content - "Content blocked messages 3" -

Categories

(DevTools :: Console, defect, P5)

defect

Tracking

(firefox-esr60 unaffected, firefox67 unaffected, firefox68 unaffected, firefox69 fixed)

RESOLVED FIXED
Firefox 69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: nchevobbe)

References

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

Filed by: aiakab [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=247649513&repo=mozilla-central
Full log: https://queue.taskcluster.net/v1/task/MH-2MhLgThetVI70RtBBvw/runs/0/artifacts/public/logs/live_backing.log


23:51:17 INFO - Checking "simple message 2"
23:51:17 INFO - TEST-PASS | devtools/client/webconsole/test/mochitest/browser_webconsole_warning_groups_filtering.js | Message includes the expected "simple message 2" content - "simple message 2 content-task.js line 59 > eval:4:21" -
23:51:17 INFO - Checking "Navigated to"
23:51:17 INFO - Buffered messages finished
23:51:17 INFO - TEST-UNEXPECTED-FAIL | devtools/client/webconsole/test/mochitest/browser_webconsole_warning_groups_filtering.js | Message includes the expected "Navigated to" content - "Content blocked messages 3" -
23:51:17 INFO - Stack trace:
23:51:17 INFO - chrome://mochikit/content/browser-test.js:test_ok:1314
23:51:17 INFO - chrome://mochitests/content/browser/devtools/client/webconsole/test/mochitest/head.js:checkConsoleOutputForWarningGroup/<:1347
23:51:17 INFO - chrome://mochitests/content/browser/devtools/client/webconsole/test/mochitest/head.js:checkConsoleOutputForWarningGroup:1301
23:51:17 INFO - chrome://mochitests/content/browser/devtools/client/webconsole/test/mochitest/browser_webconsole_warning_groups_filtering.js:testContentBlockingMessage:94
23:51:17 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1116
23:51:17 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1144
23:51:17 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:1005
23:51:17 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
23:51:17 INFO - Checking "▶︎⚠ Content blocked messages"
23:51:17 INFO - Not taking screenshot here: see the one that was previously logged
23:51:17 INFO - TEST-UNEXPECTED-FAIL | devtools/client/webconsole/test/mochitest/browser_webconsole_warning_groups_filtering.js | Uncaught exception - at chrome://mochitests/content/browser/devtools/client/webconsole/test/mochitest/head.js:1307 - TypeError: message.querySelector(...) is null
23:51:17 INFO - Stack trace:
23:51:17 INFO - checkConsoleOutputForWarningGroup/<@chrome://mochitests/content/browser/devtools/client/webconsole/test/mochitest/head.js:1307:18
23:51:17 INFO - checkConsoleOutputForWarningGroup@chrome://mochitests/content/browser/devtools/client/webconsole/test/mochitest/head.js:1301:20
23:51:17 INFO - testContentBlockingMessage@chrome://mochitests/content/browser/devtools/client/webconsole/test/mochitest/browser_webconsole_warning_groups_filtering.js:94:3
23:51:17 INFO - Async*Tester_execTest/<@chrome://mochikit/content/browser-test.js:1116:34
23:51:17 INFO - Tester_execTest@chrome://mochikit/content/browser-test.js:1144:12
23:51:17 INFO - nextTest/<@chrome://mochikit/content/browser-test.js:1005:14
23:51:17 INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:803:59
23:51:17 INFO - Leaving test bound testContentBlockingMessage
23:51:17 INFO - GECKO(3348) | console.warn: "Error while detaching the thread front: 'detach' request packet to 'server1.conn355.child1/context18' can't be sent as the connection is closed."
23:51:18 INFO - Removing tab.
23:51:18 INFO - Waiting for event: 'TabClose' on [object XULElement].
23:51:18 INFO - Got event: 'TabClose' on [object XULElement].
23:51:18 INFO - Tab removed and finished closing
23:51:18 INFO - GECKO(3348) | MEMORY STAT | vsize 1600MB | vsizeMaxContiguous 128MB | residentFast 821MB | heapAllocated 411MB
23:51:18 INFO - TEST-OK | devtools/client/webconsole/test/mochitest/browser_webconsole_warning_groups_filtering.js | took 2374ms
23:51:18 INFO - checking window state

Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED

The failures indicated that some warning messages
were placed before the navigation marker, when they
should be placed after.
We now listen to the load event instead of DOMContentLoaded
to ensure the page is fully loaded and the warning gets
reported into the right page session.

Duplicate of this bug: 1558814
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ddbad8f00d61
Fix browser_webconsole_warning_groups_filtering.js intermittent. r=Ola.
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69
You need to log in before you can comment on or make changes to this bug.