Closed Bug 1553387 Opened 7 months ago Closed 7 months ago

'Window' menu mostly empty (missing the list of windows) since switching to browser.xhtml

Categories

(Firefox :: General, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- fixed

People

(Reporter: glob, Assigned: bgrins)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

69.0a1 (2019-05-21) (64-bit) macOS

A change in recent nightly builds has resulted in a mostly empty 'Window' menu - just Minimise and Zoom, no actual windows are listed.

mozregression narrowed it down to https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=5a721a7648f2db40785729ed8fc7c7444c1afcaf&tochange=ad38bcbe7879cf715df2a49840b62d1235689882 - bug 1534407

Has Regression Range: --- → yes
Has STR: --- → yes
Assignee: nobody → bgrinstead
Priority: -- → P1

This is a createElement -> createXULElement call we missed in Bug 1551320: https://searchfox.org/mozilla-central/rev/6c9f60f8cc064a1005cd8141ecd526578ae9da7a/toolkit/content/macWindowMenu.js#13. Updating that fixes the menu, but I'm going to do a try push with the assertion at https://bugzilla.mozilla.org/show_bug.cgi?id=1551320#c18 & browser.xul turned back on to make sure we didn't miss anything else.

(In reply to Brian Grinstead [:bgrins] from comment #1)

This is a createElement -> createXULElement call we missed in Bug 1551320: https://searchfox.org/mozilla-central/rev/6c9f60f8cc064a1005cd8141ecd526578ae9da7a/toolkit/content/macWindowMenu.js#13.

This was probably missed because this code isn't triggered by any tests, as far as I can tell. Going to fix that in the patch.

Pushed by bgrinstead@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dd05a7d4bd38
Use createXULElement for 'window' menuitems on osx r=Gijs
Pushed by bgrinstead@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dfabf5135cf1
Use createXULElement for 'window' menuitems on osx r=Gijs

Oops, I updated to address Gijs' comments and had a good try push, but I hadn't stepped through the Submit to Phabricator (YES/No/Always) prompt in the terminal before using lando (so phab didn't have the latest version).

Flags: needinfo?(bgrinstead)
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69
You need to log in before you can comment on or make changes to this bug.