Closed Bug 1553396 Opened 4 months ago Closed 4 months ago

Firefox Android Nightly download links are 404

Categories

(www.mozilla.org :: Product Details, defect)

Production
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: agibson, Unassigned)

References

(Regression)

Details

Attachments

(1 file)

I'm not entirely sure if this is the right component for this particular bug:

STR:

1.) Visit https://www.mozilla.org/en-US/firefox/android/nightly/all/
2.) Click on either download links for "ARM devices
(Android 4.1+)" or "Intel devices
(Android 4.1+ x86 CPU)"

Expected result:

A file download for both links

Actual result: 404 not found.

Assignee: nobody → jlorenzo
Blocks: ESR-Fennec
Status: NEW → ASSIGNED

Thanks Alex for filing this bug. I looked into the problem and I thought it was a Bouncer issue too. However, I double checked its admin console, and I noticed bouncer doesn't manage nightly. In fact, [1] directly points to an archive.mozilla.org location [2]. Therefore, I believe we need to update the www website to use [3] instead. The main reason is: we're moving Fennec Nighly to the esr68 branch (bug 1523402). Therefore, from now on, the version number will remain 68.0a1 until Fenix replaces Fennec sometimes next year.

How does this sound to you?

[1] https://www.mozilla.org/en-US/firefox/android/nightly/all/
[2] https://archive.mozilla.org/pub/mobile/nightly/latest-mozilla-central-android-api-16/fennec-69.0a1.multi.android-arm.apk
[3] https://archive.mozilla.org/pub/mobile/nightly/latest-mozilla-central-android-api-16/fennec-68.0a1.multi.android-arm.apk and https://archive.mozilla.org/pub/mobile/nightly/latest-mozilla-central-android-x86/fennec-68.0a1.multi.android-i386.apk (Please note the version number being 68.0a1)

Assignee: jlorenzo → nobody
Status: ASSIGNED → NEW
Flags: needinfo?(agibson)

Thanks for the info. I took a look in bedrock, and I believe mozorg gets the version number from product-details.

Paul, do you think this fix likely applies to product-details, or would the website be a better place to override and pin Nightly at 68.0a1?

Component: Bouncer → Product Details
Flags: needinfo?(agibson) → needinfo?(pmac)
Product: Webtools → www.mozilla.org
Version: Trunk → Production
Regressed by: 1548552

I do consider this a product details bug. If the latest release of Nightly is 68 then product-details shouldn't say 69. I've added a NI for :rail.

Flags: needinfo?(pmac) → needinfo?(rail)

Though I will say it would be nice if we didn't have to rely on product-details for this and could instead have a bouncer link like release channel fennec[0]. The product could be fennec-nightly-latest since we already have fennec-latest and fennec-beta-latest.

[0] https://download.mozilla.org/?product=fennec-latest&os=android&lang=multi

(In reply to Paul [:pmac] McLanahan from comment #3)

I do consider this a product details bug. If the latest release of Nightly is 68 then product-details shouldn't say 69. I've added a NI for :rail.

We're in a tricky situation. Nightly Desktop is 69, but Fennec Nightly remains on 68.

(In reply to Paul [:pmac] McLanahan from comment #4)

Though I will say it would be nice if we didn't have to rely on product-details for this and could instead have a bouncer link like release channel fennec[0]. The product could be fennec-nightly-latest since we already have fennec-latest and fennec-beta-latest.

That looks like a perfect plan to me 👍 I'm creating the products on bouncer.

Flags: needinfo?(rail)

Amazing! Can we start using those on the site now Johan? Will they remain updated with new releases?

Assuming we can I filed the attached PR to update the site to use these bouncer links.

I also created https://github.com/mozilla/release-services/pull/2125 to use separate versions for fennec and firefox.

Thanks :rail! That'll be important as well.

Duplicate of this bug: 1553714

This is fixed on dev: https://www-dev.allizom.org/en-US/firefox/android/nightly/all/

Will verify after our next production push. Thanks all!

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED

(In reply to Paul [:pmac] McLanahan from comment #7)

Amazing! Can we start using those on the site now Johan? Will they remain updated with new releases?

Yes to both 🙂 These links are update the same way [1] is.

[1] https://download.mozilla.org/?product=firefox-nightly-latest&os=win64&lang=fr

(In reply to Johan Lorenzo [:jlorenzo] from comment #6)

FYI, I just updated these bouncer entries to now point to https://archive.mozilla.org/pub/mobile/nightly/latest-mozilla-beta-android-api-16/ and https://archive.mozilla.org/pub/mobile/nightly/latest-mozilla-beta-android-x86/. This is new location now that we build Fennec Nightly off mozilla-beta. These files have been pushed to Google Play users since Friday.

Blocks: 1566385
You need to log in before you can comment on or make changes to this bug.