Crash when leaving applet [@ QDUnbindPortFromNativeWindow]

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
17 years ago
14 years ago

People

(Reporter: jnp, Assigned: peterl-bugs)

Tracking

({crash, qawanted})

Details

(Whiteboard: dupeme[testing needed], crash signature, URL)

Attachments

(5 attachments)

(Reporter)

Description

17 years ago
The above applet may crash chimera when closing the window with the applet.
It does not happen every time though, but I have seen it yesterday and today.
(Reporter)

Comment 1

17 years ago
Created attachment 89903 [details]
Crash log showing crash in QDUnbindPortFromNativeWindow on thread 22.

Updated

17 years ago
Attachment #89903 - Attachment description: Crash log. → Crash log showing crash in QDUnbindPortFromNativeWindow on thread 22.

Comment 2

17 years ago
Confirmed using Chimera/20020701, also crashing in QDUnbindPortFromNativeWindow.
Jørgen, can you reproduce this using Mozilla?
Severity: normal → critical
Keywords: crash
(Reporter)

Comment 3

17 years ago
Created attachment 89979 [details]
Crash log
(Reporter)

Comment 4

17 years ago
(I am really not a friendly term with bugzilla, thought I could type something
here and attach a file. Well)

Actually, yes. The first time even ;-)

Comment 5

17 years ago
->bnesse
Assignee: saari → bnesse

Comment 6

17 years ago
Somebody help me out here... I went to this site using Netscape 7, no crash, and
no Applet in the html... what am I supposed to be looking for?

Comment 7

17 years ago
Found the link in bug 154998 which exhibits the same behavior.

http://www.webreference.com/html/tools/colorizer/

Comment 8

17 years ago
This bug looks like a duplicate of that one (bug 154998); thread 15, the
crasher, looks the same in the stacks on both. Adding qawanted for duping.
Keywords: qawanted
Whiteboard: dupeme

Comment 9

17 years ago
Yes, it is a dupe. I left 'em both open because one is for chimera and one is
for fizilla... I didn't know which one to close and which one to leave alone. :)

Updated

17 years ago
Component: General → Plug-ins

Updated

17 years ago
Summary: Crash when leaving applet → Crash when leaving applet [@ QDUnbindPortFromNativeWindow]

Comment 10

16 years ago
*** Bug 162354 has been marked as a duplicate of this bug. ***

Comment 11

16 years ago
*** Bug 158408 has been marked as a duplicate of this bug. ***

Comment 12

16 years ago
I can not reproduce this bug any longer. It was likely fixed by another plugin
crash fix such as bug 154023. Please re-open if you can reproduce this in a
current build.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 13

16 years ago
*** Bug 159803 has been marked as a duplicate of this bug. ***

Comment 14

16 years ago
Marking verified with the 2002-10-04-04 NB.
Status: RESOLVED → VERIFIED

Comment 15

16 years ago
Reproduced using Chimera/2002101104 on 10.1.5 closing a Yahoo Games window
showing the game Spades. Reopening.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 16

16 years ago
Created attachment 102729 [details]
Crash report generated by Chimera/2002101104 on 10.1.5 showing crash at QDUnbindPortFromNativeWindow on thread 20

Comment 17

16 years ago
bnesse has left -> peterl
Assignee: bnesse → peterl
Status: REOPENED → NEW

Comment 18

16 years ago
assigning QA : need testing
QA Contact: winnie → petersen
Whiteboard: dupeme → dupeme[testing needed]

Comment 19

16 years ago
Shockwave plugins can also cause this crash. stack looks like:

Thread 0 Crashed:
 #0   0x91a88558 in QDUnbindPortFromNativeWindow
 #1   0x91a6e198 in CloseCPort
 #2   0x91a8d6d0 in DisposePort
 #3   0x029f7c74 in 0x29f7c74
 #4   0x029d0578 in 0x29d0578
 #5   0x02976d0c in 0x2976d0c
 #6   0x0297ab70 in 0x297ab70
 #7   0x02975dc0 in 0x2975dc0
 #8   0x00341494 in ns4xPlugin::Shutdown()
 #9   0x0034452c in nsPluginTag::TryUnloadPlugin(int)

Test url:
http://www.shockwave.com/sw/content/tetris
Load the tetris game, wait until the game starts, then close the window.

Comment 20

16 years ago
Created attachment 129630 [details]
Crash log from Camino 2003081102

Crash still happens with Camino 2003081102. The Tetris game has gone away, but
the same thing happens with Collapse -
<http://www.shockwave.com/sw/content/collapse>. Crash log attached.

Comment 21

16 years ago
Created attachment 129631 [details]
Crash log from firebird 0.6.1

OK, it seems that you can crash Firebird in exactly the same way. Looks like
this goes beyond just Camino.

Comment 22

16 years ago
WFM

The only working URL is http://www.webreference.com/html/tools/colorizer/ and
it's WFM. Can anyone reproduce this with a nightly with the given URL (or a
differnet one)?
(Reporter)

Comment 23

16 years ago
Seems to WFM

The Flash issue crashed Mozilla (and generated a talkback)

Comment 24

16 years ago
The original crash looks like bug 154998. (not marking dupe just yet because for
whatever reason it wasn't done post comment 7)

Those crashes that Joshua posted look like a different crash (a lot more like
bug 171789)

has anyone been able to repro this crash with the crash in
QDUnbindPortFromNativeWindow?

Comment 25

14 years ago
WFM using 20050214 NB on 10.3.8.

Please reopen as needed, looked at all testcases and they worked as expected.
Status: NEW → RESOLVED
Last Resolved: 16 years ago14 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ QDUnbindPortFromNativeWindow]
You need to log in before you can comment on or make changes to this bug.