Closed Bug 1553532 Opened 6 months ago Closed 6 months ago

[Stub installer] Updating Firefox without using Profile manager doesn't remove the previously installed add-ons

Categories

(Firefox :: Installer, defect, P3)

All
Windows
defect

Tracking

()

RESOLVED DUPLICATE of bug 1555117
Tracking Status
firefox68 --- affected

People

(Reporter: Anca, Unassigned)

Details

[Affected versions]:

  • 68.0b3

[Affected platforms]:

  • Windows 10
  • Windows 8.1

[Steps to reproduce]:

Preconditions:

  • Make sure option “Use the selected profile without asking at startup” is checked inside the Profile manager.
  1. Download and install an old Firefox version
  2. Once Firefox opens, install several add-ons
  3. Close Firefox
  4. Install the latest version of Firefox stub installer
    Note: Make sure the Paveover prompt appears and the option “Restore default settings and remove old add-ons for optimal performance” is checked before clicking on the Update button

[Expected result]:

  • Firefox automatically opens using the same profile and the add-on installed previously are removed.

[Actual result]:

  • Firefox in not opened, once the progress bar is completely filled, the prompt disappears and nothing happens (Note that here is an inconsistent behavior, if the option “Restore default settings and remove old add-ons for optimal performance” is unchecked Firefox opens instantly once the installation is finished).
  • If I open Firefox manually, I have the same profile used previously, the add-on are still present, but the current Firefox version is the latest one as expected.

[Regression range]:

  • I will provide information asap.

[Additional Notes]:

  • When the Profile Manager (“Use the selected profile without asking at startup” is unchecked) is used, this issue is not reproducible. The moment the latest stub installer version installation finishes, the Profile Manager is triggered, and no add-on remains when opening the previously used profile.

I need to investigate this a little; since the paveover prompt is appearing, I think it's likely that the installer has done its job, so this might be an issue with how the profile refresh is starting itself up.

Priority: -- → P3
Has Regression Range: --- → no

Unfortunately I cannot determine if this issue is a regression. Firefox builds get automatically updated to the latest available version for the desired channel when using the paveover prompt.

Has Regression Range: no → ---
Has STR: --- → yes
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1555117
You need to log in before you can comment on or make changes to this bug.