Closed Bug 1553534 Opened 7 months ago Closed 6 months ago

[about:addons] Addon details page tabs need styling for dark mode

Categories

(Toolkit :: Add-ons Manager, defect, P2)

defect

Tracking

()

VERIFIED FIXED
mozilla69
Tracking Status
firefox-esr68 --- verified
firefox67 --- unaffected
firefox68 --- verified
firefox69 --- verified

People

(Reporter: ke5trel, Assigned: ke5trel)

References

Details

Attachments

(3 files)

Details page tabs are white in dark mode and hovering over them has black text on dark background.

Priority: -- → P2

Tabs use --in-content-box colors as seen in common.css, about:preferences Certificate viewer and about:logins.

Keywords: checkin-needed

Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/71d648e912ef
Apply in-content colors to about:addons tab deck for dark mode compatibility r=jaws

Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Assignee: nobody → ke5trel
Attached image Bug1553534.gif

This issue is verified as fixed on Firefox 69.0a1 (20190620220631) under Win 7 64-bit and Mac OS X 10.14.1.

Please see the attached video.

Status: RESOLVED → VERIFIED

Comment on attachment 9072792 [details]
Bug 1553534 - Apply in-content colors to about:addons tab deck for dark mode compatibility

Beta/Release Uplift Approval Request

  • User impact if declined: When dark themes are enabled, the tabs on the about:addons details view are bright and unreadable upon hover.
    This is the only major defect in dark theme support in HTML about:addons.

Note: Dark themes are disabled by default (bug 1519547), but since the rest of about:addons has proper dark theme support, it would be nice to have full dark theme support in the HTML about:addons for users who opt in to this feature.

  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Only colors have been changed by the patch. The fix has been verified on Nightly by QA, and I just confirmed that the standard (light) theme still looks reasonable.
  • String changes made/needed: none
Attachment #9072792 - Flags: approval-mozilla-beta?

Comment on attachment 9072792 [details]
Bug 1553534 - Apply in-content colors to about:addons tab deck for dark mode compatibility

about:addons css fixes for dark mode compat, approved for 68 rc1

Attachment #9072792 - Flags: approval-mozilla-release+
Attachment #9072792 - Flags: approval-mozilla-esr68+
Attachment #9072792 - Flags: approval-mozilla-beta?

Verified the fix on the latest Beta Release Candidate (68.0 / 20190701181138) and ESR (68.0esr / 20190704173630) under Windows 10 Pro 64-bit and macOS 10.14.5 Mojave, obtaining the exact results documented in Comment 4.

However, before changing the status of the 68 and esr68 tracking flags to Verified, can you please confirm whether the ‘Options’ tab from the detail view of extensions should have a white background? Is this the intended behavior?

This can be clearly seen in the posted image of Comment 4 and those are the results I have obtained throughout the validation of this fix.

Flags: needinfo?(ke5trel)

The tab page contents is unrelated to this bug which is only concerned with the tab button styling. Extensions have full control over their settings page and only a few currently support dark mode (eg Decentraleyes) so this is expected behavior.

Flags: needinfo?(ke5trel)

As per the above comment, closing the issue as Verified.

You need to log in before you can comment on or make changes to this bug.