Closed Bug 1553579 Opened 4 months ago Closed 3 months ago

Intermittent GECKO(2997) | Assertion failure: !aCompositable->AsWebRenderImageHost(), at /builds/worker/workspace/build/src/gfx/layers/ipc/LayerTransactionParent.cpp:843

Categories

(Core :: Graphics: WebRender, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- wontfix
firefox68 --- wontfix
firefox69 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: kats)

References

Details

(Keywords: assertion, intermittent-failure, regression)

Attachments

(1 file)

Filed by: kgupta [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=247811282&repo=try
Full log: https://queue.taskcluster.net/v1/task/RTaaYZrxRuWZmvDgswSCNA/runs/0/artifacts/public/logs/live_backing.log


Another reproducible crash if I enable browser-chrome mochitests on linux-qr

Similar to https://bugzilla.mozilla.org/show_bug.cgi?id=1554234 my question here is really "why are we using LayerTransactionParent if WebRender is enabled"? Presumably this one is not from the hidden window because it seems to have a compositable of some kind. The crashes are in webrtc browser-mochitests so maybe they're opening non-WR windows somehow.

Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/962a2dc1dc62
Re-enable test that was fixed in bug 1557105. r=sotaro
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
You need to log in before you can comment on or make changes to this bug.