Closed Bug 1553610 Opened 3 years ago Closed 3 years ago

dark mode web site setting doesn't work on linux

Categories

(Core :: CSS Parsing and Computation, enhancement)

69 Branch
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1529323

People

(Reporter: slandden, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:69.0) Gecko/20100101 Firefox/69.0

Steps to reproduce:

Opening a new profile in nightly
set dark mode in settings ( which set browser.in-content.dark-mode to true)
went to https://ziglang.org/documentation/master/

Actual results:

not using dark style

Expected results:

used dark style

Hi Sean,

The dark theme media query on the ziglang.org is triggered on my Firefox (69, X11) when I try either of the following:

I believe that browser.in-content.dark-mode is not related to forcing the media selector (esp. after looking at the code to the addon).

And when I search on open and closed bugs that refer to browser.in-content.dark-mode the media query selector does not come up.

I'm asking which, if any, pref forces it.

Indeed you are correct. Maybe the mozilla dark-mode should follow the system one then.

See https://github.com/NixOS/nixpkgs/issues/61965 for a downstream issue report with some screenshots. It's surprising that Dark Theme can be selected, yet prefers-color-scheme will choose the "light" theme. Here is another example of user confusion: https://twitter.com/rsr_galo/status/1131284530785071104

In my opinion, if Default Theme is selected, Firefox should try to determine based on system configuration whether the intended mode is "light" or "dark" or maybe neither. However if Dark Theme is selected, this seems to me to be a clear indication from the user that they wish to override the system setting and have Firefox report prefers-color-scheme as dark.

Do Firefox devs agree with this?

I think further adjustments to the Dark Theme and hence a solution related to situations similar to this report are already discussed in bug 1529323.

Type: defect → enhancement
Component: Untriaged → CSS Parsing and Computation
Keywords: dupeme
Product: Firefox → Core

Yes, I am pretty sure this is a dup of bug 1553013.

Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Keywords: dupeme
Resolution: --- → DUPLICATE
Duplicate of bug: 1553013

Is that a typo? That bug seems unrelated to me.

yes, pasted a wrong bug number. :/

Duplicate of bug: 1529323
You need to log in before you can comment on or make changes to this bug.