Closed Bug 1553743 Opened 4 months ago Closed 3 months ago

The Firefox icon is improperly displayed on the installer's welcome screen when in tablet mode

Categories

(Firefox :: Installer, defect, P1)

Desktop
Windows 10
defect

Tracking

()

VERIFIED FIXED
Firefox 69
Tracking Status
firefox67 --- wontfix
firefox68 --- verified
firefox69 --- verified

People

(Reporter: danibodea, Assigned: mhowell)

Details

Attachments

(2 files)

Note

  • When the user opens the installer while his touchscreen device is set to tablet mode, then focuses another window and comes back to the installer welcome screen, he will notice that the Firefox icon is improperly displayed in the top-right corner of the screen.

Affected versions

  • all

Affected platforms

  • touch screen devices with Win10 in tablet mode

Steps to reproduce

  1. Download a Firefox Full installer.
  2. Set the touch screen device to tablet mode.
  3. Open the installer and see the welcome screen.
  4. Focus any other window (like a Windows Explorer window) and then focus back on the installer welcome screen.

Expected result

  • The Installer welcome screen is properly displayed.

Actual result

  • A Firefox icon is improperly displayed in the top-right corner of the screen.

Additional notes

  • Step 4 may sometimes be unnecessary.
  • This issue could be reproduced on Lenovo Yoga C630 with ARM architecture (aarch64build) and on the Microsoft Surface Pro with Intel architecture (64bit build).
Priority: -- → P3

I don't fully understand what's happening here. I noticed that while in tablet mode, focusing the window causes it to be completely repainted every time; if you watch closely for the first few frames after alt-tabbing into the installer window, you can see the controls gradually painting in. Presumably this is something to do with tablet mode's one-window-at-a-time behavior and how that's implemented. I'm also guessing that something is slightly wonky in that procedure and it's causing this image control, which is supposed to be completely occluded on this screen, to appear as if it were higher up the z order than it actually is. The reason I think that is because, as step 4 of the STR indicates, the bug isn't typically visible until the window has been blurred and then focused again.

It's a bit weird that this image can appear on that page at all; apparently MUI is using the dialog resource for the first options page, and then overlaying it with the actual controls for the welcome/finish page using InstallOptions. I don't know why it's doing this rather than having an additional dialog resource for the welcome/finish pages, but it means that all the controls for both of those pages actually all exist at the same time. When this bug happens, the image control from the next page is peeking out from behind the bounding box of the header label control from the current page. Another thing I don't understand is why this only happens in tablet mode and not all the time, because I don't see anything on the welcome page that should hide the image.

No matter what's causing this, calling ShowWindow(SW_HIDE) on the image control for the screens where it isn't supposed to appear should get us around it, so that's what I'll do.

Assignee: nobody → mhowell
Status: NEW → ASSIGNED
Priority: P3 → P1
Pushed by mhowell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0ad3760e38b6
Hide the header image from install/uninstall welcome/finish pages. r=agashlin
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69

Please nominate this for Beta uplift when you get a chance.

Flags: needinfo?(mhowell)

Comment on attachment 9069722 [details]
Bug 1553743 - Hide the header image from install/uninstall welcome/finish pages. r=agashlin

Beta/Release Uplift Approval Request

  • User impact if declined: Visual polish issue in the full installer and the uninstaller, triggered when using tablet mode (such as on a convertible laptop).
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This is a tightly targeted fix; the biggest risk is that the header image doesn't show up on pages where it should, and that would be a less severe problem than this bug is.
  • String changes made/needed:
Flags: needinfo?(mhowell)
Attachment #9069722 - Flags: approval-mozilla-beta?

Comment on attachment 9069722 [details]
Bug 1553743 - Hide the header image from install/uninstall welcome/finish pages. r=agashlin

installer fix for 68.0b11

Attachment #9069722 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

This issue has been verified with the installer of Nightly v6900a1 from 2019-06-17 on Lenovo Yoga and Microsoft Surface Pro.

This issue has also been reproduced with the installer of Beta v68.0b10 and verified with the installer of Beta v68.0b11 on both Lenovo Yoga and Microsoft Surface Pro. Thanks.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.