New Mail with attachment(s) of 8K or more in size does not go out & hang the apprunner

VERIFIED DUPLICATE of bug 14612

Status

defect
P3
blocker
VERIFIED DUPLICATE of bug 14612
20 years ago
11 years ago

People

(Reporter: momoi, Assigned: mscott)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

20 years ago
** Observed with 10/3/99 Win32 M10 candidate build **

With this build, I am not able to to send mail when I try to attach
a local page or locale pages. It does not seem to matter what kind of
charsets the pages bear. When I finish composing mail and click on
"send" button, the progress bar gets engaged and never seems to complete
and the apprunner also freezes so that I need to quit by CTRL+C
from the command line.
I had thought that the attachment mail is working for M10. If so,
we should fix this before M10 ships.
Reporter

Comment 1

20 years ago
I'm experincing this problem under both the HTML and Plain Text
send options.

Comment 2

20 years ago
May be related to http://bugzilla.mozilla.org/show_bug.cgi?id=14612.  What is
the size of your attachment?
Reporter

Comment 3

20 years ago
I tried the following pages downloaded to my hard disk first:

1. http://home.netscape.com/
2. http://home.netscape.com/fr
3. http://home.netscape.com/ja
4. http://home.netscape.com/ko

The sizes range from 14K to 25K. These file sizes are too small to
qualify for Bug 14612.

Let me also add that under the same SMTP server settings,
mail does go out if I don't attach a file.

Here's part of the DOS window output for the failed send with
attachment(s).

-------------------------------------
....
....
....
AttachFile()
SendMessage from XUL
GenericSendMessage from XUL
Identity = [nsIMsgIdentity: id1]
attachments = file:///E|/tests/home_netscape_com.html
There are 1 smtp servers
------------------------------------------------------

The last line is where the apprunner gets hung.

Comment 4

20 years ago
cc: pmock and esther and fenella.  For our M10 testing, what type of attachments
were you successful in sending?  Thanks.
Reporter

Updated

20 years ago
Summary: Mail with attachment(s) does not go out & hang the apprunner → Mail with HTML attachment(s) does not go out & hang the apprunner
Reporter

Comment 5

20 years ago
Perhaps this has to do with my specific SMTP sever setting,
but using the same mail server setting, the last build which I can
use to send out attachments is: 9/17/99 Win32 M10 build.

Note that Alec sent out a notice on 9/19/99 that the new SMTP
server settings will take effect on that evening. I went on vacation
on 9/18 and the next build I looked at is from 9/27/99 Win32 M11 build.
This build does not let me send out mail with attachments and the same
is true for all subsequent builds on my hard drive..

Note that in testing builds earlier than 9/19/99, I'm not using the
new SMTP server settings. (I also threw away mozregistry.dat and
started a new profile when going back to pre-9/19 builds).

For builds later than 9/19/99, my profile still contains per mail
account based mail server settings but they should not matter
and new SMTP server settings should work after 9/19/99.
For post 9/19/99 testing, I'm using the new SMTP settings.
And they do work but only for mail without attachments. Am I
missing something in the prefs settings? cc'ing alecf.

Here's my prefs.js (with password/user_ids and such masked).

http://rocknroll/users/momoi/publish/seamonkey/bugs/bug15538prefs.txt
Reporter

Comment 6

20 years ago
It turns out that plain text file attachment does work.
So take the http://home.netscape.com/ with 4.7 and save it as a plain
text file, and atatch this to a 5.0 mail. It does work and apprunner
does not get hung. However, as I mentioned above, the HTML version
of the Home Page does hung the apprunner when it's atatched.
Reporter

Updated

20 years ago
Summary: Mail with HTML attachment(s) does not go out & hang the apprunner → New Mail with HTML attachment(s) does not go out & hang the apprunner

Comment 7

20 years ago
your SMTP settings look correct in the above URL. I did not change the actual
behavior of SMTP, only the location of the hostname in the prefs....

Updated

20 years ago
Assignee: phil → rhp

Comment 8

20 years ago
I think rhp hooked up HTML attachments. Rich, if this isn't right, pls reassign.
Reporter

Updated

20 years ago
Severity: critical → blocker
Reporter

Comment 9

20 years ago
I haven't heard anybody contradict this bug so far.
I assume that HTML atatchment needs to work for M10
and on that basis will now raise the severity to M10 blocker
status.

Comment 10

20 years ago
If M10 is waiting on ME fixing this bug, it will be a long wait. First of all,
I have the tip pulled, not M10. Now, on the tip, I am having all sorts of
problems with plain text compose, Ender in general, attachments don't work,
etc, etc.... I have no idea what changed and I'm still trying to get some
traction after returning from sabbatical.

Phil, I could use some help here before I go postal.

- rhp

Updated

20 years ago
Target Milestone: M11

Comment 11

20 years ago
I don't understand what work is being blocked by this. M11 until that's made
clear to me. If it's just that the feature doesn't work, I can live with not
having this in M10.
Reporter

Updated

20 years ago
Summary: New Mail with HTML attachment(s) does not go out & hang the apprunner → New Mail with attachment(s) of 8K or more in size does not go out & hang the apprunner
Reporter

Comment 12

20 years ago
It seems that the size has something to do with this problem.
I took the English Netscape Home page and started paring down
the size of the file from the original 23K to about 7K and
that's when mail with this particular HTML page attached started
going out. I have found other smaller files -- all 6K or smaller --
which can go out as attachments.
This is not conclusive but the size of the HTML atttachment seems
to play a role in this bug.

The plain text version of Netscape English Home Page is only 5K
and so I padded it to make it 8K. I now have a problem of
not being to send this plain text attachment.

So the problem is not the HTML or plain text, it seems to be the
size. And the threshhold size here seems to be 7k. At 7k, it
goes out, at 8K it does not.

This may be related to Bug 14612 but at much smaller file size!
Reporter

Comment 13

20 years ago
cc'ing mscott.

Updated

20 years ago
Status: NEW → ASSIGNED

Comment 14

20 years ago
I see what is happening here...we seem to be hanging in Necko
...ugh. Sounds like a networking issue...I will investigate.

- rhp

Updated

20 years ago
Assignee: rhp → mscott
Status: ASSIGNED → NEW

Comment 15

20 years ago
Hi Scott,
I've looked into this and we are hanging when we try to send a mail message
with an attachment that is over 8K. We seem to be stuck in PR_Poll():

NTDLL! 77f6825b()
MSAFD! 77664a12()
WS2_32! 776b9f5e()
_PR_MD_PR_POLL(PRPollDesc * 0x02b8ae60, int 2, unsigned int 4294967295) line
224 + 35 bytes
PR_Poll(PRPollDesc * 0x02b8ae60, int 2, unsigned int 4294967295) line 115 + 17
bytes
nsSocketTransportService::Run(nsSocketTransportService * const 0x02b89114) line
403 + 23 bytes
nsThread::Main(void * 0x02b89080) line 79 + 26 bytes
_PR_NativeRunThread(void * 0x02b8ab40) line 379 + 13 bytes
_threadstartex(void * 0x02b8a990) line 212 + 13 bytes
KERNEL32! 77f04f3e()


Let me know if there is something I can do to help.

- rhp
Assignee

Comment 16

20 years ago
This is a known problem and a duplicate of a necko bug...

i'll mark it as a dup when I find it in a minute here.
Assignee

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → DUPLICATE
Assignee

Comment 17

20 years ago
The stack trace rhp provided is actually a bit of red herring =)...that's just
the generic polling for new data that netlib always runs through...I bet if you
looked at the UI thread in the debugger, you'd see that we are blocked in a
flush call for the output stream.

Marking as a dup of 14612.

*** This bug has been marked as a duplicate of 14612 ***

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 18

20 years ago
Bug 14612 has been verified. Mark this one verified.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.