Closed Bug 1553878 Opened 3 years ago Closed 2 months ago

Crash in [@ mozilla::jni::NativeStub<T>::Wrap<T>] (mozilla::a11y::SessionAccessibility)

Categories

(GeckoView :: General, defect, P1)

Unspecified
Android

Tracking

(firefox-esr91 unaffected, firefox100+ fixed, firefox101+ fixed, firefox102+ fixed)

RESOLVED FIXED
102 Branch
Tracking Status
firefox-esr91 --- unaffected
firefox100 + fixed
firefox101 + fixed
firefox102 + fixed

People

(Reporter: snorp, Assigned: eeejay)

References

(Regression)

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug is for crash report bp-14276951-5cf8-41a1-b550-0fd170190523.

Top 2 frames of crashing thread:

0 libxul.so void mozilla::jni::NativeStub<mozilla::java::GeckoSystemStateListener::OnDeviceChanged_t, mozilla::GeckoSystemStateListener, mozilla::jni::Args<> >::Wrap<&mozilla::GeckoSystemStateListener::OnDeviceChanged> widget/android/jni/Natives.h:710
1 base.odex base.odex@0x647b60 

This is an assertion failure due to GeckoSystemStateListener.nativeOnDeviceChanged() being called from a non-UI thread. We should probably just remove that restriction from the @WrapForJNI annotation.

I'm editing a bunch of GeckoView bugs. If you'd like to filter all this bugmail, search and destroy emails containing this UUID:

e88a5094-0fc0-4b7c-b7c5-aef00a11dbc9

Priority: P1 → P2
Whiteboard: [geckoview:fenix:m8]

Randall's fix for bug 1573697 (in GV 70) probably fixed this. We'll wait for Fenix to update to GV 70 and then watch the crash volume.

Depends on: 1573697
Whiteboard: [geckoview:fenix:m8] → [geckoview:fenix:m9]
Rank: 61
Whiteboard: [geckoview:fenix:m9]
Priority: P2 → P5

The crash volume started increasing in April and May. I wonder if there is a new regression in 100.

Unfortunately the crash stack traces don't look very useful:

Crash report: https://crash-stats.mozilla.org/report/index/1173b670-c280-45a5-bc95-a64bd0220505

Reason: SIGSEGV / SEGV_MAPERR

Top 10 frames of crashing thread:

0 libxul.so unsigned char mozilla::jni::NativeStub<mozilla::java::SessionAccessibility::NativeProvider::IsCacheEnabled_t, mozilla::a11y::SessionAccessibility, mozilla::jni::Args<> >::Wrap<&mozilla::a11y::SessionAccessibility widget/android/jni/Natives.h:1398
1 base.odex base.odex@0x000000000009b3dc 
2 base.odex base.odex@0x000000000009b3dc 
3 base.vdex base.vdex@0x00000000009ec59a 
4 libart.so libart.so@0x0000000000680844 
5 libart.so libart.so@0x0000000000680168 
6 boot-framework.art] boot-framework.art]@0x000000000129df7c 
7 boot-framework.art] boot-framework.art]@0x000000000129df7c 
8 boot-framework.art] boot-framework.art]@0x00000000003ab054 
9 libart.so libart.so@0x00000000006b81bc 

Likely from Bug 1758592, but it's not clear to me what's going on yet.

Regressed by: 1758592

Eitan, could this a11y::SessionAccessibility crash be a regression from your IsCacheEnabled JNI changes in bug 1758592? The crash volume started increasing in April and May. I wonder if there is a new regression in 100.

(This is an old bug report with a generic crash signature. The early bug comments are about an obsolete issue. If you'd prefer that I filed a new bug for the new SessionAccessibility crashes, just let me know.)

Flags: needinfo?(eitan)

Set release status flags based on info from the regressing bug 1758592

Changing the priority to P1 as the bug is tracked by a release manager for the current release.
See Triage for Bugzilla for more information.
If you disagree, please discuss with a release manager.

Priority: P5 → P1

I'm assuming this is happening because the native SessionAccessibility didn't have a chance to instantiate yet. I can't reproduce this locally, so this is all conjecture. I'm going to try a change where we change this to a static JNI method.

Flags: needinfo?(eitan)
Assignee: nobody → eitan
Status: NEW → ASSIGNED
Severity: critical → S2
Rank: 61
Attachment #9275903 - Attachment description: Bug 1553878 - Make IsCacheEnabled a static method in Settings. r?#geckoview-reviewers → Bug 1553878 - Check that SessionAccessibility is attached before calling isCacheEnabled. r?#geckoview-reviewers
Pushed by eisaacson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7632d55a169d
Check that SessionAccessibility is attached before calling isCacheEnabled. r=geckoview-reviewers,agi
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 102 Branch

The patch landed in nightly and beta is affected.
:eeejay, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(eitan)

Comment on attachment 9275903 [details]
Bug 1553878 - Check that SessionAccessibility is attached before calling isCacheEnabled. r?#geckoview-reviewers

Beta/Release Uplift Approval Request

  • User impact if declined: Startup crash
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky):
  • String changes made/needed:
  • Is Android affected?: Yes
Flags: needinfo?(eitan)
Attachment #9275903 - Flags: approval-mozilla-beta?

Comment on attachment 9275903 [details]
Bug 1553878 - Check that SessionAccessibility is attached before calling isCacheEnabled. r?#geckoview-reviewers

Beta/Release Uplift Approval Request

  • User impact if declined: Startup crash
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky):
  • String changes made/needed:
  • Is Android affected?: Yes
Attachment #9275903 - Flags: approval-mozilla-release?

Comment on attachment 9275903 [details]
Bug 1553878 - Check that SessionAccessibility is attached before calling isCacheEnabled. r?#geckoview-reviewers

Approved for Fenix 101.0.0-beta.4.

Attachment #9275903 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment on attachment 9275903 [details]
Bug 1553878 - Check that SessionAccessibility is attached before calling isCacheEnabled. r?#geckoview-reviewers

Approved for Fenix 100.1.3

Attachment #9275903 - Flags: approval-mozilla-release? → approval-mozilla-release+
You need to log in before you can comment on or make changes to this bug.