Download manager misreports finshed download size as '1kb of 1kb'

VERIFIED DUPLICATE of bug 149237

Status

--
minor
VERIFIED DUPLICATE of bug 149237
16 years ago
14 years ago

People

(Reporter: garth, Assigned: bugzilla)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; zh-TW; rv:1.1a) Gecko/20020611
BuildID:    2002061104

Case 1: 
http://fud.prohost.org/forum/index.php?t=msg&th=11

do a 'save link as...' on any of the file attachments... 

Case 2:
I also noticed this bug when downloading from a fix pack from IBM's FTP site
that was well over 240MB.   Download Manager did not know how big the file was
during download however it did know how much it had recieved so far.   At the
end of the transfer it reported the file as being '1kb of 1kb'

I sort of wonder if the mime type might be involved here, since I'm not sure
that FUDForum sends correct mime types on attachments and I don't think FTP
sends any mime type headers...  

It would be cool to fix this, since the first time I saw it I thought I had just
downloaded a 404 page or 500 page.


Reproducible: Always
Steps to Reproduce:
1. go to http://fud.prohost.org/forum/index.php?t=msg&th=11
2. do a 'save link as...' on any of the file attachments... 
3. look at download manager

Actual Results:  '1kb of 1kb' no matter how big the file really is

Expected Results:  '594kb of 594kb' or '594kb downloaded'

Comment 1

16 years ago
I see the same thing; Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.0)
Gecko/2002053012

Looking at the download manager shows "0KB of 0KB"

While downloading, the title bar of the download window (not manager) shows "-1%
of ..."

This is with Case 1.

Comment 2

16 years ago
confirming with 2002070204 on win2k.

Looking at my download history, the other files that show 1kb of 1kb are
downloads from bugzilla - correct MIME types, but also saved with "save link
target as...".  through the course of these downloads, mozilla shows "Xkb of 0kb".

the FUDforum seems to send the right type, BTW

HTTP/1.1 200 OK
Date: Tue, 02 Jul 2002 22:25:29 GMT
Server: Apache
Content-Disposition: inline; filename=Skyline_GTR_A1.jpg
Connection: close
Content-Type: image/jpeg
Severity: trivial → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

16 years ago
http://www.northern.ca/forums/msg.php?th=2 if you click normal on the attachment
you get a "source.list.php" as the file name vs "source.list" (if you do save
link as) that's what made me think it might have been a mime thing in FUDForum,
my bad though.

Comment 4

16 years ago
Got this downloading a Zip file attachment from Yahoo.com
I thought something went wrong, but the full file was downloaded correctly.

Comment 5

16 years ago

*** This bug has been marked as a duplicate of 149237 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
mass-verification of Duplicates.

mail search string for bugspam: SolarFlaresAreTheCause
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.