If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Select box is layed out incorrectly

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
P1
minor
RESOLVED WORKSFORME
15 years ago
6 years ago

People

(Reporter: YoaR, Assigned: John Keiser (jkeiser))

Tracking

({testcase})

Trunk
Future
x86
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.1a) Gecko/20020610
BuildID:    20020610



Reproducible: Always
Steps to Reproduce:
1. Browse to www.soulflytribe.com 
2. Click on "What we belive"
3. Click the select box

Actual Results:  Select box is layed out in different positions

Expected Results:  Lay out the list under the select box =)
(Reporter)

Comment 1

15 years ago
Created attachment 89936 [details]
snapshot of mozilla laying out select list box

Comment 2

15 years ago
WFM in build 2002070108 PC/Win98.

Comment 3

15 years ago
WFM 2002 07 01 04 w2k.  this kinda reminds me of the bug where the url dropdown
was misplaced, that bug was fixed a few weeks ago.  Reporter, can you try a more
recent build and see if you can reproduce there?
(Reporter)

Comment 4

15 years ago
Using Mozilla 1.1b (20020722) and the bug happens again, it's not fixed.
Happens for me too. (linux 2002091308)
But after going to another page, and going back, it is placed correctly.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

15 years ago
-->
Priority: -- → P1
Target Milestone: --- → Future

Comment 7

15 years ago
-->
Assignee: rods → jkeiser

Comment 8

15 years ago
Reproduced on 12/23 Trunk Build for Linux. The effect does not happen when I
have scrolled all the way up, but it does happen when I have scrolled the page
all the way down and then click the select box.
Keywords: testcase

Comment 9

15 years ago
It happens in Linux using the branch build too. Windows is fine. It seems to be
caused by a select box being in an iframe. Simplified test case attached.

Comment 10

15 years ago
Created attachment 110784 [details]
Minimised test case

Comment 11

14 years ago
I'm seeing this bug in 1.6 on Linux, but the current testcase (added in comment
10) works fine.  I only get this bug with a select box that I have to scroll
down to get to, and only when I have used another select box earlier in the page
before scrolling down.  The bug doesn't happen if I switch to another browser
tab and back again between opening the two select boxes.

Comment 12

14 years ago
Created attachment 139204 [details]
New testcase

Bug only occurs if both select boxes are in a block with "overflow: auto;" in
its style (I only discovered this while making the testcase.)  The text of this
file isn;t relevent to the bug, it is page 44 of "The Fairy Godmothers and
Other Tales" , a book currently being processed by Project Gutenberg's
Distributed Proofreaders - I noticed the bug while using DP's spellchecker.
WFM, SeaMonkey trunk 2005-06-28-07 on Linux.

Can anyone still reproduce this in a trunk build?
QA Contact: tpreston → layout.form-controls
wfm with FF10.0.1 on Ubunto
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.