Closed Bug 1554006 Opened 1 year ago Closed 1 year ago

Update builders to rustc 1.35

Categories

(Firefox Build System :: General, task, P3)

task

Tracking

(firefox69 fixed)

RESOLVED FIXED
mozilla69
Tracking Status
firefox69 --- fixed

People

(Reporter: chmanchester, Assigned: chmanchester)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

This released today.

For some reason the new version produces an archive that sends the windows builders into an infinite loop when they attempt to unpack it.

(In reply to Chris Manchester (:chmanchester) from comment #2)

For some reason the new version produces an archive that sends the windows builders into an infinite loop when they attempt to unpack it.

Something in bug 1545968 (together with the update) induces this.

See Also: → 1545968

The python docs for subprocess warn that calling .wait() can deadlock when using pipes. That seems to be happening in the code that was added in bug 1546870.

(In reply to Chris Manchester (:chmanchester) from comment #4)

The python docs for subprocess warn that calling .wait() can deadlock when using pipes. That seems to be happening in the code that was added in bug 1546870.

While I tracked down the cause of this and wrote up a fix, it looks like this was fixed in the interim recently, so I'll just push my origin patches for review.

Pushed by cmanchester@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c6c250b477a0
Bump max OOM hook version for the rust update to 1.35. r=froydnj
Pushed by cmanchester@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3bff8c732fb4
Update builders to rustc 1.35. r=froydnj
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/f3f918aef481
No bug - Add {linux|win}64-rust-1.34 and clean up unneeded rust-1.28 in taskcluster/ci/toolchain/kind.yml after bug 1554006. rs=bustage-fix

Looks like this won us some build time improvements:

== Change summary for alert #21158 (as of Wed, 29 May 2019 18:40:34 GMT) ==

Improvements:

53% build times linux64 opt rusttests taskcluster-c5d.4xlarge 306.37 -> 143.41
32% build times linux64 debug rusttests taskcluster-m4.4xlarge 307.44 -> 207.63
31% build times linux64 debug rusttests taskcluster-c5d.4xlarge 240.46 -> 166.76
29% build times linux32 debug rusttests taskcluster-m5.4xlarge 270.07 -> 192.27
18% build times windows2012-32 debug rusttests taskcluster-c4.4xlarge 637.96 -> 523.83
17% build times windows2012-64 debug rusttests taskcluster-c4.4xlarge 641.79 -> 531.10
17% build times windows2012-64 debug rusttests taskcluster-c5.4xlarge 503.69 -> 417.77
16% build times windows2012-32 debug rusttests taskcluster-c5.4xlarge 497.52 -> 417.80
12% build times windows2012-32 opt rusttests taskcluster-c5.4xlarge 585.66 -> 513.02

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=21158

You need to log in before you can comment on or make changes to this bug.