Closed Bug 1554073 Opened 1 year ago Closed 1 year ago

Crash in [@ nsFrameLoader::TryRemoteBrowser]

Categories

(Core :: Graphics, defect, critical)

68 Branch
Unspecified
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox67.0.1 --- unaffected
firefox68 --- unaffected
firefox69 --- fixed

People

(Reporter: calixte, Assigned: rhunt)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug is for crash report bp-5fc158ae-8f40-4dc3-a06e-c993c0190524.

Top 10 frames of crashing thread:

0 xul.dll nsFrameLoader::TryRemoteBrowser dom/base/nsFrameLoader.cpp:2605
1 xul.dll nsFrameLoader::ShowRemoteFrame dom/base/nsFrameLoader.cpp:1020
2 xul.dll nsFrameLoader::Show dom/base/nsFrameLoader.cpp:887
3 xul.dll nsSubDocumentFrame::ShowViewer layout/generic/nsSubDocumentFrame.cpp:201
4 xul.dll nsresult AsyncFrameInit::Run layout/generic/nsSubDocumentFrame.cpp:90
5 xul.dll nsContentUtils::RemoveScriptBlocker dom/base/nsContentUtils.cpp:5172
6 xul.dll mozilla::dom::Document::EndUpdate dom/base/Document.cpp:4958
7 xul.dll nsHTMLDocument::EndUpdate dom/html/nsHTMLDocument.cpp:1615
8 xul.dll nsINode::ReplaceOrInsertBefore dom/base/nsINode.cpp:2374
9 xul.dll static bool mozilla::dom::Node_Binding::appendChild dom/bindings/NodeBinding.cpp:1018

There are 2 crashes (from 1 installation) in nightly 69 with buildid 20190523215203. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1525720.

[1] https://hg.mozilla.org/mozilla-central/rev?node=a902acfbc868

Flags: needinfo?(rhunt)
QA Whiteboard: [qa-regression-triage]
Pushed by rhunt@eqrion.net:
https://hg.mozilla.org/integration/autoland/rev/5d11d295d7d4
Use GetContentParent in TryRemoteBrowser to avoid null-deref if PBrowser actor is destroyed. r=nika
Flags: needinfo?(rhunt)
Duplicate of this bug: 1554474
Crash Signature: [@ nsFrameLoader::TryRemoteBrowser] → [@ nsFrameLoader::TryRemoteBrowser] [@ nsFrameLoader::TryRemoteBrowserInternal]
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Crash Signature: [@ nsFrameLoader::TryRemoteBrowser] [@ nsFrameLoader::TryRemoteBrowserInternal] → [@ nsFrameLoader::TryRemoteBrowser] [@ nsFrameLoader::TryRemoteBrowserInternal]
QA Whiteboard: [qa-regression-triage]
You need to log in before you can comment on or make changes to this bug.