Closed Bug 1554095 Opened 4 months ago Closed 4 months ago

Block URL action doesn't work

Categories

(DevTools :: Netmonitor, defect, P2)

68 Branch
defect

Tracking

(firefox-esr60 unaffected, firefox67 unaffected, firefox68 fixed, firefox69 fixed)

RESOLVED FIXED
Firefox 69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox68 --- fixed
firefox69 --- fixed

People

(Reporter: Honza, Assigned: tanhengyeow)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Recently introduced Block URL action doesn't work since there is no selected request

STR:

  1. Load this page: http://janodvarko.cz/firebug/tests/601/Issue601.htm
  2. Open DevTools select the Network panel
  3. Click the POST button
  4. Right click on the request in the Network panel and pick: Block URL
  5. Click the POST button in the page again
  6. The request isn't blocked -> BUG

If you select the request by clicking on it and consequently executing the "Block URL" action it works properly.

The problem is in this method:
https://searchfox.org/mozilla-central/rev/662de518b1686c4769320d6b8825ce4864c4eda0/devtools/client/netmonitor/src/actions/requests.js#111-122

getSelectedRequest(getState()); returns null

Honza

@Heng Yeow: I think this is caused by bug 1466598, can you please look at that?

Honza

Flags: needinfo?(E0032242)
Priority: -- → P2

Regression range:

  • Last good build_date: 2019-05-17 17:46:47.191000 changeset: c94c54aff4669f52cebc76ddad34a76f4fafd03b
  • First bad build_date: 2019-05-17 17:46:47.191000 changeset: c94c54aff4669f52cebc76ddad34a76f4fafd03b
    Pushlog link

Thanks Cristi!

@Heng Yeow, yep the bug 1466598 is in the push log

Honza

Regressed by: 1466598

Fixed the regression! Try looks good as well :)

Flags: needinfo?(E0032242) → needinfo?(odvarko)
Assignee: nobody → E0032242
Status: NEW → ASSIGNED
Flags: needinfo?(odvarko)
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69

Comment on attachment 9067423 [details]
Bug 1554095 - Fix Block URL action. r=Honza

Beta/Release Uplift Approval Request

  • User impact if declined: Manual HTTP request blocking doesn't work in the Network panel (DevTools)
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Small patch, tested in Nightly, impact only on Web developers (not on regular Firefox users)
  • String changes made/needed:
Attachment #9067423 - Flags: approval-mozilla-beta?
Version: unspecified → 68 Branch

Comment on attachment 9067423 [details]
Bug 1554095 - Fix Block URL action. r=Honza

netmonitor fix for 68.0b8

Attachment #9067423 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.