Closed Bug 1554102 Opened 7 months ago Closed 7 months ago

The flow input values from about:welcome page are not set for custom fxa endpoint

Categories

(Firefox :: Messaging System, defect)

defect
Not set

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox67 --- wontfix
firefox67.0.1 --- wontfix
firefox68 --- wontfix
firefox69 --- wontfix

People

(Reporter: alin.ilea, Unassigned)

References

Details

Attachments

(1 file)

Attached image Actual result.png

Affected versions:

Tested on Nightly 69.0a1 (2019-05-23)

Affected platforms:

Tested on Mac OS 10.14 and Windows 10

Prerequisites:
To be able to see the about:welcome page on a version where this is not implemented please go to about:config and set:

identity.fxaccounts.autoconfig.uri to https://latest.dev.lcip.org/
browser.newtabpage.activity-stream.fxaccounts.endpoint to https://latest.dev.lcip.org/
Restart the browser.

Steps:

  1. Go to about:welcome page
  2. Click Menu button
  3. Select Web developer option
  4. Select Inspector option
  5. Inspect "Enter email" field
  6. Check the following inputs:
  • input name = "device_id"
  • input name = "flow_id"
  • input name = "flow_begin_time"

Expected result:

The three inputs show a numeric value (always random number), this values should never show "0" or blank.

Actual result:

For input name = "device_id" and input name = "flow_id" value is blank
For input name = "flow_begin_time" value = 0

Regression range:

With the Nightly build 69.0a1(2019-05-22) the issue is not reproducible, but with Nightly build 69.0a1(2019-05-23) the issue is reproducible.

Note:

Maybe this bug can be related to this one:

https://bugzilla.mozilla.org/show_bug.cgi?id=1553205

Keywords: regression
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1553205

Hmm.. Bug 1553205 was fixed for the 2019-05-22 build so there wasn't an explicit change for the 2019-05-23 build regarding the flow. Is this still happening with the latest nightly?

Blocks: trailhead-firstrun
No longer blocks: 1553143
Status: RESOLVED → REOPENED
Component: Server: Firefox Accounts → Activity Streams: Newtab
Flags: needinfo?(alin.ilea)
Product: Cloud Services → Firefox
Resolution: DUPLICATE → ---
Summary: The input values from about:welcome page are not set → The flow input values from about:welcome page are not set

(In reply to Ed Lee :Mardak from comment #2)

Hmm.. Bug 1553205 was fixed for the 2019-05-22 build so there wasn't an explicit change for the 2019-05-23 build regarding the flow. Is this still happening with the latest nightly?

Hi,

I've retested on latest Nightly build 69.0a1 (2019-05-28) and the issue is still reproducible.
The result is the same:
For input name = "device_id" and input name = "flow_id" value is blank
For input name = "flow_begin_time" value = 0

Flags: needinfo?(alin.ilea)

Ah, this looks like it's an issue specific to setting browser.newtabpage.activity-stream.fxaccounts.endpoint to https://latest.dev.lcip.org/

It ends up getting 404 for https://latest.dev.lcip.org//metrics-flow?… (note the double slash) instead of https://latest.dev.lcip.org/metrics-flow?… (this url will 401 instead of 404 when plain clicked on from bugzilla)

Notice that https://accounts.firefox.com//metrics-flow?… and https://accounts.firefox.com/metrics-flow?… both result in 401 instead of the double returning 404.

Confusingly firefox.js pref has a trailing slash while the getStringPref call defaults with no slash:
https://searchfox.org/mozilla-central/search?q=fxaccounts.endpoint

Status: REOPENED → NEW
Keywords: regression
Summary: The flow input values from about:welcome page are not set → The flow input values from about:welcome page are not set for custom fxa endpoint

I suppose perhaps the QA instruction should be to set browser.newtabpage.activity-stream.fxaccounts.endpoint to https://latest.dev.lcip.org for testing.

Do you see flow values when you set the pref without trailing slash?

Flags: needinfo?(alin.ilea)

(In reply to Ed Lee :Mardak from comment #5)

I suppose perhaps the QA instruction should be to set browser.newtabpage.activity-stream.fxaccounts.endpoint to https://latest.dev.lcip.org for testing.

Do you see flow values when you set the pref without trailing slash?

Yes, if I set the pref without trailing slash for browser.newtabpage.activity-stream.fxaccounts.endpoint to https://latest.dev.lcip.org it works ok, flow values are there.
Thanks.

Flags: needinfo?(alin.ilea)

Based on the fact that if user set the pref without trailing slash for:
browser.newtabpage.activity-stream.fxaccounts.endpoint to https://latest.dev.lcip.org
and
identity.fxaccounts.autoconfig.uri to https://latest.dev.lcip.org it works ok, flow values appears, I will close this bug as Resolved-Worksforme.

Status: NEW → RESOLVED
Closed: 7 months ago7 months ago
Resolution: --- → WORKSFORME
See Also: → 1556276
Component: Activity Streams: Newtab → Messaging System
You need to log in before you can comment on or make changes to this bug.