Open Bug 1554117 Opened 7 months ago Updated 15 days ago

Intermittent org.mozilla.geckoview.test.MediaElementTest.oggPlayMediaFromScript | status -2

Categories

(GeckoView :: General, defect, P5)

Unspecified
Android
defect

Tracking

(firefox-esr60 wontfix, firefox67 wontfix, firefox67.0.1 wontfix, firefox68 fixed, firefox69 disabled)

REOPENED
mozilla69
Tracking Status
firefox-esr60 --- wontfix
firefox67 --- wontfix
firefox67.0.1 --- wontfix
firefox68 --- fixed
firefox69 --- disabled

People

(Reporter: intermittent-bug-filer, Assigned: nataliaCs)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: intermittent-failure, leave-open, regression, Whiteboard: [retriggered][stockwell disabled])

Attachments

(1 file, 1 obsolete file)

Filed by: nerli [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=248156626&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/diWqGT8sShCc5Cih7tkdqw/runs/0/artifacts/public/logs/live_backing.log


[task 2019-05-24T09:48:31.349Z] 09:48:31 INFO - TEST-START | org.mozilla.geckoview.test.MediaElementTest.oggPlayMediaFromScript
[task 2019-05-24T09:48:39.772Z] 09:48:39 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: id=AndroidJUnitRunner
[task 2019-05-24T09:48:39.772Z] 09:48:39 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: current=77
[task 2019-05-24T09:48:39.773Z] 09:48:39 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: class=org.mozilla.geckoview.test.MediaElementTest
[task 2019-05-24T09:48:39.774Z] 09:48:39 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: stream=
[task 2019-05-24T09:48:39.774Z] 09:48:39 INFO - org.mozilla.geckoview.test | Error in oggPlayMediaFromScript(org.mozilla.geckoview.test.MediaElementTest):
[task 2019-05-24T09:48:39.774Z] 09:48:39 INFO - org.mozilla.geckoview.test | java.lang.ClassCastException: org.mozilla.geckoview.test.rdp.Grip cannot be cast to org.mozilla.geckoview.test.rdp.Promise
[task 2019-05-24T09:48:39.774Z] 09:48:39 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rdp.Promises.getPromisesFromArray(Promises.java:64)
[task 2019-05-24T09:48:39.774Z] 09:48:39 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rdp.Promises.onPacket(Promises.java:95)
[task 2019-05-24T09:48:39.774Z] 09:48:39 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rdp.RDPConnection$InputThread.processPacket(RDPConnection.java:131)
[task 2019-05-24T09:48:39.774Z] 09:48:39 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rdp.RDPConnection.processInputPacket(RDPConnection.java:314)
[task 2019-05-24T09:48:39.774Z] 09:48:39 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rdp.Actor$Reply.get(Actor.java:72)
[task 2019-05-24T09:48:39.774Z] 09:48:39 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rdp.Grip.release(Grip.java:281)
[task 2019-05-24T09:48:39.774Z] 09:48:39 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rdp.Promises.detach(Promises.java:53)
[task 2019-05-24T09:48:39.774Z] 09:48:39 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.cleanupStatement(GeckoSessionTestRule.java:1378)
[task 2019-05-24T09:48:39.774Z] 09:48:39 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule$3$1.run(GeckoSessionTestRule.java:1428)
[task 2019-05-24T09:48:39.774Z] 09:48:39 INFO - org.mozilla.geckoview.test | at android.app.Instrumentation$SyncRunnable.run(Instrumentation.java:1719)
[task 2019-05-24T09:48:39.774Z] 09:48:39 INFO - org.mozilla.geckoview.test | at android.os.Handler.handleCallback(Handler.java:730)
[task 2019-05-24T09:48:39.774Z] 09:48:39 INFO - org.mozilla.geckoview.test | at android.os.Handler.dispatchMessage(Handler.java:92)
[task 2019-05-24T09:48:39.774Z] 09:48:39 INFO - org.mozilla.geckoview.test | at android.os.Looper.loop(Looper.java:137)
[task 2019-05-24T09:48:39.774Z] 09:48:39 INFO - org.mozilla.geckoview.test | at android.app.ActivityThread.main(ActivityThread.java:5103)
[task 2019-05-24T09:48:39.774Z] 09:48:39 INFO - org.mozilla.geckoview.test | at java.lang.reflect.Method.invokeNative(Native Method)
[task 2019-05-24T09:48:39.774Z] 09:48:39 INFO - org.mozilla.geckoview.test | at java.lang.reflect.Method.invoke(Method.java:525)
[task 2019-05-24T09:48:39.774Z] 09:48:39 INFO - org.mozilla.geckoview.test | at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:737)
[task 2019-05-24T09:48:39.774Z] 09:48:39 INFO - org.mozilla.geckoview.test | at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:553)
[task 2019-05-24T09:48:39.774Z] 09:48:39 INFO - org.mozilla.geckoview.test | at dalvik.system.NativeStart.main(Native Method)
[task 2019-05-24T09:48:39.774Z] 09:48:39 INFO - org.mozilla.geckoview.test |
[task 2019-05-24T09:48:39.774Z] 09:48:39 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: numtests=156
[task 2019-05-24T09:48:39.774Z] 09:48:39 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: stack=java.lang.ClassCastException: org.mozilla.geckoview.test.rdp.Grip cannot be cast to org.mozilla.geckoview.test.rdp.Promise
[task 2019-05-24T09:48:39.774Z] 09:48:39 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rdp.Promises.getPromisesFromArray(Promises.java:64)
[task 2019-05-24T09:48:39.774Z] 09:48:39 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rdp.Promises.onPacket(Promises.java:95)
[task 2019-05-24T09:48:39.774Z] 09:48:39 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rdp.RDPConnection$InputThread.processPacket(RDPConnection.java:131)
[task 2019-05-24T09:48:39.774Z] 09:48:39 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rdp.RDPConnection.processInputPacket(RDPConnection.java:314)
[task 2019-05-24T09:48:39.774Z] 09:48:39 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rdp.Actor$Reply.get(Actor.java:72)
[task 2019-05-24T09:48:39.775Z] 09:48:39 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rdp.Grip.release(Grip.java:281)
[task 2019-05-24T09:48:39.775Z] 09:48:39 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rdp.Promises.detach(Promises.java:53)
[task 2019-05-24T09:48:39.775Z] 09:48:39 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.cleanupStatement(GeckoSessionTestRule.java:1378)
[task 2019-05-24T09:48:39.776Z] 09:48:39 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule$3$1.run(GeckoSessionTestRule.java:1428)
[task 2019-05-24T09:48:39.776Z] 09:48:39 INFO - org.mozilla.geckoview.test | at android.app.Instrumentation$SyncRunnable.run(Instrumentation.java:1719)
[task 2019-05-24T09:48:39.776Z] 09:48:39 INFO - org.mozilla.geckoview.test | at android.os.Handler.handleCallback(Handler.java:730)
[task 2019-05-24T09:48:39.776Z] 09:48:39 INFO - org.mozilla.geckoview.test | at android.os.Handler.dispatchMessage(Handler.java:92)
[task 2019-05-24T09:48:39.780Z] 09:48:39 INFO - org.mozilla.geckoview.test | at android.os.Looper.loop(Looper.java:137)
[task 2019-05-24T09:48:39.781Z] 09:48:39 INFO - org.mozilla.geckoview.test | at android.app.ActivityThread.main(ActivityThread.java:5103)
[task 2019-05-24T09:48:39.781Z] 09:48:39 INFO - org.mozilla.geckoview.test | at java.lang.reflect.Method.invokeNative(Native Method)
[task 2019-05-24T09:48:39.781Z] 09:48:39 INFO - org.mozilla.geckoview.test | at java.lang.reflect.Method.invoke(Method.java:525)
[task 2019-05-24T09:48:39.781Z] 09:48:39 INFO - org.mozilla.geckoview.test | at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:737)
[task 2019-05-24T09:48:39.781Z] 09:48:39 INFO - org.mozilla.geckoview.test | at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:553)
[task 2019-05-24T09:48:39.781Z] 09:48:39 INFO - org.mozilla.geckoview.test | at dalvik.system.NativeStart.main(Native Method)
[task 2019-05-24T09:48:39.781Z] 09:48:39 INFO - org.mozilla.geckoview.test |
[task 2019-05-24T09:48:39.781Z] 09:48:39 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: test=oggPlayMediaFromScript
[task 2019-05-24T09:48:39.781Z] 09:48:39 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS_CODE: -2
[task 2019-05-24T09:48:39.781Z] 09:48:39 WARNING - TEST-UNEXPECTED-FAIL | org.mozilla.geckoview.test.MediaElementTest.oggPlayMediaFromScript | status -2
[task 2019-05-24T09:48:39.781Z] 09:48:39 INFO - TEST-INFO took 8429ms
[task 2019-05-24T09:48:39.879Z] 09:48:39 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: id=AndroidJUnitRunner
[task 2019-05-24T09:48:39.879Z] 09:48:39 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: current=78
[task 2019-05-24T09:48:39.879Z] 09:48:39 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: class=org.mozilla.geckoview.test.MediaElementTest
[task 2019-05-24T09:48:39.880Z] 09:48:39 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: stream=
[task 2019-05-24T09:48:39.880Z] 09:48:39 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: numtests=156
[task 2019-05-24T09:48:39.881Z] 09:48:39 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: test=webmPlayMedia
[task 2019-05-24T09:48:39.881Z] 09:48:39 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS_CODE: 1

OS: All → Android
Regressed by: 1549633
Whiteboard: [retriggered]
Whiteboard: [retriggered][stockwell disable-recommended] → [retriggered]
Pushed by dvarga@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f34d86c242ae
Disable org.mozilla.geckoview.test.MediaElementTest.oggPlayMediaFromScript on Android debug && pgo for frequent failures. r=aryx

Backed out changeset f34d86c242ae (Bug 1554117) for MediaElementTest.kt related bustages

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=f34d86c242ae2b30ceb679187774d7b2b7a140b5&selectedJob=249567261

Backout link: https://hg.mozilla.org/integration/autoland/rev/057957209b255a91dfaf95e10e28fbb366dca612

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=249567261&repo=autoland&lineNumber=35488

[task 2019-06-01T17:08:12.591Z] 17:08:12 INFO - > Task :geckoview:generateWithGeckoBinariesDebugAndroidTestResources
[task 2019-06-01T17:08:12.790Z] 17:08:12 INFO - > Task :geckoview:mergeWithGeckoBinariesDebugAndroidTestResources
[task 2019-06-01T17:08:12.890Z] 17:08:12 INFO - > Task :geckoview:processWithGeckoBinariesDebugAndroidTestResources
[task 2019-06-01T17:08:25.790Z] 17:08:25 INFO - e: /builds/worker/workspace/build/src/mobile/android/geckoview/src/androidTest/java/org/mozilla/geckoview/test/MediaElementTest.kt: (228, 9): Unresolved reference: Assume
[task 2019-06-01T17:08:25.791Z] 17:08:25 INFO - /builds/worker/workspace/build/src/mobile/android/geckoview/src/androidTest/java/org/mozilla/geckoview/test/MediaElementTest.kt:228:9: error: Unresolved reference: Assume
[task 2019-06-01T17:08:25.890Z] 17:08:25 INFO - > Task :geckoview:compileWithGeckoBinariesDebugAndroidTestKotlin FAILED
[task 2019-06-01T17:08:25.891Z] 17:08:25 INFO - FAILURE: Build failed with an exception.
[task 2019-06-01T17:08:25.891Z] 17:08:25 INFO - * What went wrong:
[task 2019-06-01T17:08:25.891Z] 17:08:25 INFO - Execution failed for task ':geckoview:compileWithGeckoBinariesDebugAndroidTestKotlin'.
[task 2019-06-01T17:08:25.891Z] 17:08:25 INFO - > Compilation error. See log for more details
[task 2019-06-01T17:08:25.891Z] 17:08:25 INFO - * Try:
[task 2019-06-01T17:08:25.891Z] 17:08:25 INFO - Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
[task 2019-06-01T17:08:25.891Z] 17:08:25 INFO - * Get more help at https://help.gradle.org
[task 2019-06-01T17:08:25.891Z] 17:08:25 INFO - Deprecated Gradle features were used in this build, making it incompatible with Gradle 5.0.
[task 2019-06-01T17:08:25.891Z] 17:08:25 INFO - Use '--warning-mode all' to show the individual deprecation warnings.
[task 2019-06-01T17:08:25.892Z] 17:08:25 INFO - See https://docs.gradle.org/4.10.2/userguide/command_line_interface.html#sec:command_line_warnings
[task 2019-06-01T17:08:25.892Z] 17:08:25 INFO - BUILD FAILED in 39s
[task 2019-06-01T17:08:25.892Z] 17:08:25 INFO - 88 actionable tasks: 71 executed, 17 up-to-date
[task 2019-06-01T17:08:26.347Z] 17:08:26 ERROR - Return code: 1
[task 2019-06-01T17:08:26.347Z] 17:08:26 ERROR - 1 not in success codes: [0]
[task 2019-06-01T17:08:26.347Z] 17:08:26 WARNING - setting return code to 2
[task 2019-06-01T17:08:26.347Z] 17:08:26 FATAL - Halting on failure while running ['/builds/worker/workspace/build/src/obj-x86_64-pc-linux-gnu/_virtualenvs/init/bin/python', 'mach', '--log-no-times', 'android', 'archive-geckoview']
[task 2019-06-01T17:08:26.347Z] 17:08:26 FATAL - Running post_fatal callback...
[task 2019-06-01T17:08:26.347Z] 17:08:26 FATAL - Exiting 2
[task 2019-06-01T17:08:26.347Z] 17:08:26 INFO - [mozharness: 2019-06-01 17:08:26.347780Z] Finished build step (failed)

Flags: needinfo?(csabou)

^ Given that the failures occurred on pgo+debug, that implies opt being disabled as well (due to the disabling syntax for pgo) - so I've decided to completely skip the test.

Assignee: nobody → ncsoregi
Attachment #9069204 - Attachment description: Bug 1554117 - Disabled org.mozilla.geckoview.test.MediaElementTest.oggPlayMediaFromScript for frequent failures. r=Aryx → Bug 1554117 - Disabled org.mozilla.geckoview.test.MediaElementTest.oggPlayMediaFromScript for frequent failures. r=gbrown
Pushed by ncsoregi@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f31bc32ead20
Disabled org.mozilla.geckoview.test.MediaElementTest.oggPlayMediaFromScript for frequent failures. r=gbrown
Whiteboard: [retriggered][stockwell disable-recommended] → [retriggered][stockwell disabled]

Try push: https://treeherder.mozilla.org/#/jobs?repo=try&revision=83b6b369f0bb83a5b957de28ba81e65c773715b1

  • org.mozilla.geckoview.test.MediaElementTest.oggPlayMediaFromScript did not fail
Flags: needinfo?(csabou)
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Is this intermittent test failure a problem in GV 68 Beta? Should we uplift this patch to disable the test in mozilla-beta?

68=fix-optional

Attachment #9069157 - Attachment is obsolete: true
Attachment #9069157 - Attachment is obsolete: false

(In reply to Chris Peterson [:cpeterson] from comment #16)

Is this intermittent test failure a problem in GV 68 Beta? Should we uplift this patch to disable the test in mozilla-beta?

Seems like a drop in the bucket for these failures, but why not.

Status: RESOLVED → REOPENED
Keywords: leave-open
Resolution: FIXED → ---
Flags: needinfo?(etoop)
Attachment #9069157 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.