Closed Bug 1554131 Opened 6 months ago Closed 6 months ago

Firefox crashes when doing Selenium automation tests in Docker on Linux

Categories

(Firefox :: Untriaged, defect)

68 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1554128

People

(Reporter: newsletter2018.2, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3350.0 Iron Safari/537.36

Steps to reproduce:

  • Environment: Docker on Linux, based on image maven:3-jdk-8
  • install firefox-esr (also tested with v68.0 and 68.0b4)
  • use selenium to do browsertest in headless mode (as I am in Docker)
  • open a URL in selenium (sorry, cannot provide the login as it is an internal site)

(The same code and URL work when executing the tests in Windows)

Actual results:

  • on one specific page, firefox crashes MOST of the time (~40% of the cases) and core dumps.

I see a couple of messages in the console:
1558698423222 mozrunner::runner INFO Running command: "/usr/local/firefox/firefox" "-marionette" "-headless" "-foreground" "-no-remote" "-profile" "/tmp/rust_mozprofile.s1nHBk81SQVN"
*** You are running in headless mode.
...
[Parent 1312, Gecko_IOThread] WARNING: pipe error: Broken pipe: file /builds/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 727
[Parent 1312, Gecko_IOThread] WARNING: pipe error: Broken pipe: file /builds/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 727

###!!! [Parent][MessageChannel] Error: (msgtype=0x1E0074,name=PBrowser::Msg_StopIMEStateManagement) Channel error: cannot send/recv

###!!! [Parent][MessageChannel] Error: (msgtype=0x1E008F,name=PBrowser::Msg_Destroy) Channel error: cannot send/recv
[Parent 1312, Gecko_IOThread] WARNING: pipe error: Broken pipe: file /builds/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 727

Plus the subsequent exception from selenium:
org.openqa.selenium.NoSuchWindowException: Browsing context has been discarded
Build info: version: 'unknown', revision: 'unknown', time: 'unknown'
System info: host: '1327775e1d69', ip: '172.17.0.5', os.name: 'Linux', os.arch: 'amd64', os.version: '3.10.0-957.10.1.el7.x86_64', java.version: '1.8.0_212'
Driver info: org.openqa.selenium.firefox.FirefoxDriver
Capabilities {acceptInsecureCerts: true, browserName: firefox, browserVersion: 68.0, javascriptEnabled: true, moz:accessibilityChecks: false, moz:buildID: 20190523115432, moz:geckodriverVersion: 0.24.0, moz:headless: true, moz:processID: 1312, moz:profile: /tmp/rust_mozprofile.s1nHBk..., moz:shutdownTimeout: 60000, moz:useNonSpecCompliantPointerOrigin: false, moz:webdriverClick: true, pageLoadStrategy: normal, platform: LINUX, platformName: LINUX, platformVersion: 3.10.0-957.10.1.el7.x86_64, rotatable: false, setWindowRect: true, strictFileInteractability: false, timeouts: {implicit: 0, pageLoad: 300000, script: 30000}, unhandledPromptBehavior: dismiss and notify}

gzipped coredump attached

Expected results:

firefox should not crash

Status: UNCONFIRMED → RESOLVED
Closed: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1554128
You need to log in before you can comment on or make changes to this bug.